summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-02 07:55:40 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-02 07:55:40 +0000
commit5c407d79cabbdeac1dff1bc564147c33756fadb5 (patch)
tree77d4428fc5a7c9a138e0e5316ad0266e790475b9 /dev-db/pgagent
parentBump (diff)
downloadgentoo-2-5c407d79cabbdeac1dff1bc564147c33756fadb5.tar.gz
gentoo-2-5c407d79cabbdeac1dff1bc564147c33756fadb5.tar.bz2
gentoo-2-5c407d79cabbdeac1dff1bc564147c33756fadb5.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/pgagent')
-rw-r--r--dev-db/pgagent/ChangeLog10
-rw-r--r--dev-db/pgagent/pgagent-3.3.0.ebuild52
2 files changed, 59 insertions, 3 deletions
diff --git a/dev-db/pgagent/ChangeLog b/dev-db/pgagent/ChangeLog
index 90c70e1cc7f0..32c0161de056 100644
--- a/dev-db/pgagent/ChangeLog
+++ b/dev-db/pgagent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgagent
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgagent/ChangeLog,v 1.2 2012/07/28 12:21:42 titanofold Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgagent/ChangeLog,v 1.3 2013/02/02 07:55:40 patrick Exp $
+
+*pgagent-3.3.0 (02 Feb 2013)
+
+ 02 Feb 2013; Patrick Lauer <patrick@gentoo.org> +pgagent-3.3.0.ebuild:
+ Bump
28 Jul 2012; Aaron W. Swenson <titanofold@gentoo.org> pgagent-3.2.1.ebuild:
Add GPL-2 to $LICENSE. Fixes bug 425922.
@@ -10,4 +15,3 @@
28 Apr 2012; Aaron W. Swenson <titanofold@gentoo.org> +pgagent-3.2.1.ebuild,
+files/pgagent.confd, +files/pgagent.initd, +metadata.xml:
Initial commit. Bug 292767.
-
diff --git a/dev-db/pgagent/pgagent-3.3.0.ebuild b/dev-db/pgagent/pgagent-3.3.0.ebuild
new file mode 100644
index 000000000000..00e36d03ca6d
--- /dev/null
+++ b/dev-db/pgagent/pgagent-3.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgagent/pgagent-3.3.0.ebuild,v 1.1 2013/02/02 07:55:39 patrick Exp $
+
+EAPI="4"
+
+inherit cmake-utils eutils wxwidgets
+
+MY_PN=${PN/a/A}
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="${MY_PN} is a job scheduler for PostgreSQL"
+HOMEPAGE="http://www.pgadmin.org/download/pgagent.php"
+SRC_URI="mirror://postgresql/pgadmin3/release/${PN}/${MY_PN}-${PV}-Source.tar.gz"
+LICENSE="POSTGRESQL GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=dev-db/postgresql-base-8.3.0
+ x11-libs/wxGTK:2.8
+"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.6
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}-Source"
+
+src_prepare() {
+ sed -e "s:share):share/${P}):" \
+ -i CMakeLists.txt || die "Couldn't patch CMakeLists.txt"
+}
+
+src_configure() {
+ WX_GTK_VER="2.8"
+ if has_version "x11-libs/wxGTK[X]"; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets base-unicode
+ fi
+ mycmakeargs="-DSTATIC_BUILD:BOOLEAN=FALSE"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}/pgagent.initd" ${PN}
+ newconfd "${FILESDIR}/pgagent.confd" ${PN}
+
+ rm "${ED}"/usr/{LICENSE,README} || die "Failed to remove useless docs"
+}