summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-02-28 11:33:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-02-28 11:33:42 +0000
commitbd430fc04fe09dedbe7eaa303286e42e058e7768 (patch)
treed9d10a9052afc0e3d8079d945f61b5570fd61363 /dev-db/mysql
parentadd bzip2 (diff)
downloadgentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.tar.gz
gentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.tar.bz2
gentoo-2-bd430fc04fe09dedbe7eaa303286e42e058e7768.zip
Properly fix bug #83431, we missed something last time...
(Portage version: 2.0.51.16)
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/ChangeLog8
-rw-r--r--dev-db/mysql/mysql-4.0.22-r1.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.0.22-r2.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.0.22.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.0.23-r1.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.0.23-r2.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.0.23.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.1.7.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.1.8-r1.ebuild5
-rw-r--r--dev-db/mysql/mysql-4.1.8.ebuild5
10 files changed, 34 insertions, 19 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 4ad09948590a..968db45f8d0b 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.178 2005/02/28 09:51:49 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.179 2005/02/28 11:33:42 robbat2 Exp $
+
+ 28 Feb 2005; Robin H. Johnson <robbat2@gentoo.org> mysql-4.0.22-r1.ebuild,
+ mysql-4.0.22-r2.ebuild, mysql-4.0.22.ebuild, mysql-4.0.23-r1.ebuild,
+ mysql-4.0.23-r2.ebuild, mysql-4.0.23.ebuild, mysql-4.1.7.ebuild,
+ mysql-4.1.8-r1.ebuild, mysql-4.1.8.ebuild:
+ Properly fix bug #83431, we missed something last time...
28 Feb 2005; Michael Hanselmann <hansmi@gentoo.org> mysql-4.1.8-r1.ebuild:
Added to ~ppc.
diff --git a/dev-db/mysql/mysql-4.0.22-r1.ebuild b/dev-db/mysql/mysql-4.0.22-r1.ebuild
index 858f61ee37c9..88dafd5d229b 100644
--- a/dev-db/mysql/mysql-4.0.22-r1.ebuild
+++ b/dev-db/mysql/mysql-4.0.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22-r1.ebuild,v 1.7 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22-r1.ebuild,v 1.8 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -117,10 +117,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.0.22-r2.ebuild b/dev-db/mysql/mysql-4.0.22-r2.ebuild
index 01304101812b..c6ec4b6f14a9 100644
--- a/dev-db/mysql/mysql-4.0.22-r2.ebuild
+++ b/dev-db/mysql/mysql-4.0.22-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22-r2.ebuild,v 1.15 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22-r2.ebuild,v 1.16 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -127,10 +127,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.0.22.ebuild b/dev-db/mysql/mysql-4.0.22.ebuild
index 0958d075536e..e896715e42a3 100644
--- a/dev-db/mysql/mysql-4.0.22.ebuild
+++ b/dev-db/mysql/mysql-4.0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22.ebuild,v 1.15 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.22.ebuild,v 1.16 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -99,10 +99,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.0.23-r1.ebuild b/dev-db/mysql/mysql-4.0.23-r1.ebuild
index 2fdce6727221..374cfbf3639b 100644
--- a/dev-db/mysql/mysql-4.0.23-r1.ebuild
+++ b/dev-db/mysql/mysql-4.0.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23-r1.ebuild,v 1.9 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23-r1.ebuild,v 1.10 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -103,10 +103,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.0.23-r2.ebuild b/dev-db/mysql/mysql-4.0.23-r2.ebuild
index 3113b211ef77..d4af7559ad50 100644
--- a/dev-db/mysql/mysql-4.0.23-r2.ebuild
+++ b/dev-db/mysql/mysql-4.0.23-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23-r2.ebuild,v 1.6 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23-r2.ebuild,v 1.7 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -122,10 +122,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.0.23.ebuild b/dev-db/mysql/mysql-4.0.23.ebuild
index 800d2d72db57..9519b38fc728 100644
--- a/dev-db/mysql/mysql-4.0.23.ebuild
+++ b/dev-db/mysql/mysql-4.0.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23.ebuild,v 1.7 2005/02/27 06:20:29 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.23.ebuild,v 1.8 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -100,10 +100,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.1.7.ebuild b/dev-db/mysql/mysql-4.1.7.ebuild
index b7d2ead80b99..f6c5be2bca66 100644
--- a/dev-db/mysql/mysql-4.1.7.ebuild
+++ b/dev-db/mysql/mysql-4.1.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.7.ebuild,v 1.8 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.7.ebuild,v 1.9 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -98,10 +98,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.1.8-r1.ebuild b/dev-db/mysql/mysql-4.1.8-r1.ebuild
index 530c47d579b7..f9a4c0ee0748 100644
--- a/dev-db/mysql/mysql-4.1.8-r1.ebuild
+++ b/dev-db/mysql/mysql-4.1.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8-r1.ebuild,v 1.8 2005/02/28 09:51:49 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8-r1.ebuild,v 1.9 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -103,10 +103,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {
diff --git a/dev-db/mysql/mysql-4.1.8.ebuild b/dev-db/mysql/mysql-4.1.8.ebuild
index bf3dcc3ea2a9..30d79b37211a 100644
--- a/dev-db/mysql/mysql-4.1.8.ebuild
+++ b/dev-db/mysql/mysql-4.1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8.ebuild,v 1.7 2005/02/27 17:56:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.8.ebuild,v 1.8 2005/02/28 11:33:42 robbat2 Exp $
inherit eutils gnuconfig
#to accomodate -laadeedah releases
@@ -100,10 +100,11 @@ src_unpack() {
# upstream bug http://bugs.mysql.com/bug.php?id=7971
# names conflict with stuff in 2.6.10 kernel headers
+ echo ${S}/client/mysqltest.c ${S}/extra/replace.c | xargs -n1 \
sed -i \
-e "s/set_bit/my__set_bit/g" \
-e "s/clear_bit/my__clear_bit/g" \
- ${S}/extra/replace.c || die "Failed to fix bitops"
+ || die "Failed to fix bitops"
}
src_compile() {