summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-04-02 00:39:27 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-04-02 00:39:27 +0000
commit0b62c3f67838beba557422ba43e2a2b6404d33c0 (patch)
treed5dc3fc86d8b479ecfab1a4a0d7dff4d9cf74485 /dev-db/mysql
parentVersion bump (diff)
downloadgentoo-2-0b62c3f67838beba557422ba43e2a2b6404d33c0.tar.gz
gentoo-2-0b62c3f67838beba557422ba43e2a2b6404d33c0.tar.bz2
gentoo-2-0b62c3f67838beba557422ba43e2a2b6404d33c0.zip
Version bump to all series, 5.0, 5.1, 5.5. Please note that 5.0.x is hard-masked, and exists for the upgrade path only. It is not recommended for production use.
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/ChangeLog12
-rw-r--r--dev-db/mysql/mysql-5.0.96.ebuild215
-rw-r--r--dev-db/mysql/mysql-5.1.62.ebuild265
-rw-r--r--dev-db/mysql/mysql-5.5.22.ebuild129
4 files changed, 620 insertions, 1 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index b966692ca7fd..5c09e31c980d 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-db/mysql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.607 2012/03/03 17:12:21 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.608 2012/04/02 00:39:27 robbat2 Exp $
+
+*mysql-5.1.62 (02 Apr 2012)
+*mysql-5.0.96 (02 Apr 2012)
+*mysql-5.5.22 (02 Apr 2012)
+
+ 02 Apr 2012; Robin H. Johnson <robbat2@gentoo.org> +mysql-5.0.96.ebuild,
+ +mysql-5.1.62.ebuild, +mysql-5.5.22.ebuild:
+ Version bump to all series, 5.0, 5.1, 5.5. Please note that 5.0.x is hard-
+ masked, and exists for the upgrade path only. It is not recommended for
+ production use.
03 Mar 2012; Brent Baude <ranger@gentoo.org> mysql-5.1.61.ebuild:
Marking mysql-5.1.61 ppc64 for bug 399375
diff --git a/dev-db/mysql/mysql-5.0.96.ebuild b/dev-db/mysql/mysql-5.0.96.ebuild
new file mode 100644
index 000000000000..3c97dcac9988
--- /dev/null
+++ b/dev-db/mysql/mysql-5.0.96.ebuild
@@ -0,0 +1,215 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.96.ebuild,v 1.1 2012/04/02 00:39:27 robbat2 Exp $
+
+MY_EXTRAS_VER="20120401-2131Z"
+EAPI="4"
+
+inherit toolchain-funcs mysql
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND=""
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='berkdb -cluster embedded extraengine perl ssl community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mysql-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ emake check || die "make check failed"
+ if ! use "minimal" ; then
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus_ns
+ local retstatus_ps
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.4[3-9]|5.0.[56]*|5.0.70|5.0.87)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.43-70 and 5.0.87 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # New test was broken in first time
+ # Upstream bug 41066
+ # http://bugs.mysql.com/bug.php?id=41066
+ [ "${PV}" == "5.0.72" ] && \
+ mysql_disable_test \
+ "status2" \
+ "Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl.rpl_ssl rpl.rpl_ssl1 ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
+
+ # These are also failing in MySQL 5.0 for now, and are believed to be
+ # false positives:
+ #
+ # main.mysql_comment, main.mysql_upgrade:
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test:
+ # segfaults at random under Portage only, suspect resource limits.
+ case ${PV} in
+ 5.0.*)
+ for t in main.mysql_client_test main.mysql_comments main.mysql_upgrade; do
+ mysql_disable_test "$t" "False positives in Gentoo"
+ done
+ ;;
+ esac
+
+ use profiling && use community \
+ || mysql_disable_test main.profiling \
+ "Profiling test needs profiling support"
+
+ if [ "${PN}" == "mariadb" ]; then
+ for t in \
+ parts.part_supported_sql_func_ndb \
+ parts.partition_auto_increment_ndb ; do
+ mysql_disable_test $t "ndb not supported in mariadb"
+ done
+ fi
+
+ case $PV in
+ 5.0.91)
+ for t in archive archive_gis archive-big \
+ federated_archive mysqldump-max \
+ ; do
+ mysql_disable_test $t "Broken in $PV"
+ done
+ ;;
+ 5.0.96)
+ for t in \
+ client_xml compress connect ctype_recoding drop \
+ federated grant information_schema \
+ information_schema_db innodb lowercase_table \
+ lowercase_utf8 mysql-bug41486 mysql-bug45236 mysql \
+ mysqlcheck mysqldump-max mysqldump mysqldump_restore \
+ mysqlshow ps ps_1general rename rpl000009 rpl_ddl \
+ rpl_delete_all rpl_drop_db rpl_dual_pos_advance \
+ rpl_error_ignored_table rpl_filter_tables_not_exist \
+ rpl_replicate_do rpl_trigger_not_windows select \
+ show_check sp system_mysql_db system_mysql_db_fix30020 \
+ system_mysql_db_fix40123 view \
+ ; do
+ mysql_disable_test $t "Broken in $PV"
+ done
+ ;;
+ esac
+
+
+
+ # create directories because mysqladmin might make out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ emake test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus_ns=$?
+ [[ $retstatus_ns -eq 0 ]] || eerror "test-ns failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ emake test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus_ps=$?
+ [[ $retstatus_ps -eq 0 ]] || eerror "test-ps failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ failures=""
+ [[ $retstatus_ns -eq 0 ]] || failures="${failures} test-ns"
+ [[ $retstatus_ps -eq 0 ]] || failures="${failures} test-ps"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
diff --git a/dev-db/mysql/mysql-5.1.62.ebuild b/dev-db/mysql/mysql-5.1.62.ebuild
new file mode 100644
index 000000000000..bfbd134d24ea
--- /dev/null
+++ b/dev-db/mysql/mysql-5.1.62.ebuild
@@ -0,0 +1,265 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.1.62.ebuild,v 1.1 2012/04/02 00:39:27 robbat2 Exp $
+
+EAPI="4"
+
+MY_EXTRAS_VER="20120401-2131Z"
+# PBXT
+PBXT_VERSION='1.0.11-6-pre-ga'
+# XtraDB
+PERCONA_VER='5.1.45-10' XTRADB_VER='1.0.6-10'
+
+# Build type
+BUILD="autotools"
+
+inherit toolchain-funcs mysql-v2
+
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-solaris"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+# This is often broken still
+EPATCH_EXCLUDE=''
+
+# Most of these are in the eclass
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )
+ >=sys-devel/libtool-2.2.10"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+src_prepare() {
+ sed -i \
+ -e '/^noinst_PROGRAMS/s/basic-t//g' \
+ "${S}"/unittest/mytap/t/Makefile.am
+ mysql-v2_src_prepare
+}
+
+# Official test instructions:
+# USE='berkdb -cluster embedded extraengine perl ssl community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mysql-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ emake check || die "make check failed"
+ if ! use "minimal" ; then
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ cd "${S}"
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus_unit
+ local retstatus_ns
+ local retstatus_ps
+ local t
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # archive_gis really sucks a lot, but it's only relevant for the
+ # USE=extraengines case
+ case ${PV} in
+ 5.0.42)
+ mysql-v2_disable_test "archive_gis" "Totally broken in 5.0.42"
+ ;;
+
+ 5.0.4[3-9]|5.0.[56]*|5.0.70|5.0.87)
+ [ "$(tc-endian)" == "big" ] && \
+ mysql-v2_disable_test \
+ "archive_gis" \
+ "Broken in 5.0.43-70 and 5.0.87 on big-endian boxes only"
+ ;;
+ esac
+
+ # This was a slight testcase breakage when the read_only security issue
+ # was fixed.
+ case ${PV} in
+ 5.0.54|5.0.51*)
+ mysql-v2_disable_test \
+ "read_only" \
+ "Broken in 5.0.51-54, output in wrong order"
+ ;;
+ esac
+
+ # Ditto to read_only
+ [ "${PV}" == "5.0.51a" ] && \
+ mysql-v2_disable_test \
+ "view" \
+ "Broken in 5.0.51, output in wrong order"
+
+ # x86-specific, OOM issue with some subselects on low memory servers
+ [ "${PV}" == "5.0.54" ] && \
+ [ "${ARCH/x86}" != "${ARCH}" ] && \
+ mysql-v2_disable_test \
+ "subselect" \
+ "Testcase needs tuning on x86 for oom condition"
+
+ # Broke with the YaSSL security issue that didn't affect Gentoo.
+ [ "${PV}" == "5.0.56" ] && \
+ for t in openssl_1 rpl_openssl rpl_ssl ssl \
+ ssl_8k_key ssl_compress ssl_connect ; do \
+ mysql-v2_disable_test \
+ "$t" \
+ "OpenSSL tests broken on 5.0.56"
+ done
+
+ # New test was broken in first time
+ # Upstream bug 41066
+ # http://bugs.mysql.com/bug.php?id=41066
+ [ "${PV}" == "5.0.72" ] && \
+ mysql-v2_disable_test \
+ "status2" \
+ "Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*|5.4.*|5.5.*)
+ for t in openssl_1 rpl_openssl rpl.rpl_ssl rpl.rpl_ssl1 ssl ssl_8k_key \
+ ssl_compress ssl_connect rpl.rpl_heartbeat_ssl ; do \
+ mysql-v2_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
+
+ # These are also failing in MySQL 5.1 for now, and are believed to be
+ # false positives:
+ #
+ # main.mysql_comment, main.mysql_upgrade, main.information_schema,
+ # funcs_1.is_columns_mysql funcs_1.is_tables_mysql funcs_1.is_triggers:
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # main.not_partition:
+ # Failure reason unknown at this time, must resolve before package.mask
+ # removal FIXME
+ case ${PV} in
+ 5.1.*|5.4.*|5.5.*)
+ for t in main.mysql_client_test main.mysql_comments \
+ main.mysql_upgrade \
+ main.information_schema \
+ main.not_partition funcs_1.is_columns_mysql \
+ funcs_1.is_tables_mysql funcs_1.is_triggers; do
+ mysql-v2_disable_test "$t" "False positives in Gentoo"
+ done
+ ;;
+ esac
+
+ # New failures in 5.1.50/5.1.51, reported by jmbsvicetto.
+ # These tests are picking up a 'connect-timeout' config from somewhere,
+ # which is not valid, and since it does not have 'loose-' in front of
+ # it, it's causing a failure
+ case ${PV} in
+ 5.1.5*|5.4.*|5.5.*|6*)
+ for t in rpl.rpl_mysql_upgrade main.log_tables_upgrade ; do
+ mysql-v2_disable_test "$t" \
+ "False positives in Gentoo: connect-timeout"
+ done
+ ;;
+ esac
+
+ use profiling && use community \
+ || mysql-v2_disable_test main.profiling \
+ "Profiling test needs profiling support"
+
+ if [ "${PN}" == "mariadb" ]; then
+ for t in \
+ parts.part_supported_sql_func_ndb \
+ parts.partition_auto_increment_ndb ; do
+ mysql-v2_disable_test $t "ndb not supported in mariadb"
+ done
+ fi
+
+ # This fail with XtraDB in place of normal InnoDB
+ # TODO: test if they are broken with the rest of the Percona patches
+ if xtradb_patch_available && use xtradb ; then
+ for t in main.innodb innodb.innodb_bug51378 \
+ main.information_schema_db main.mysqlshow \
+ main.innodb-autoinc main.innodb_bug21704 \
+ main.innodb_bug44369 main.innodb_bug46000 \
+ main.index_merge_innodb \
+ innodb.innodb innodb.innodb_misc1 innodb.innodb_bug52663 \
+ innodb.innodb-autoinc innodb.innodb-autoinc-44030 \
+ innodb.innodb_bug21704 innodb.innodb_bug44369 \
+ innodb.innodb_bug46000 innodb.innodb_bug48024 \
+ innodb.innodb_bug49164 innodb.innodb_bug51920 \
+ innodb.innodb_bug54044 \
+ ; do
+ mysql-v2_disable_test $t "tests broken in xtradb"
+ done
+ fi
+
+ if ! use extraengine ; then
+ # bug 332565
+ for t in main.range ; do
+ mysql-v2_disable_test $t "Test $t requires USE=extraengine"
+ done
+ # bug 401673
+ for t in federated.federated_plugin ; do
+ mysql-v2_disable_test $t "Test $t requires USE=extraengine (Need federated engine)"
+ done
+ fi
+
+ # create directories because mysqladmin might make out of order
+ mkdir -p "${S}"/mysql-test/var-{ps,ns}{,/log}
+
+ # We run the test protocols seperately
+ emake test-unit
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ emake test-ns force="--force --vardir=${S}/mysql-test/var-ns"
+ retstatus_ns=$?
+ [[ $retstatus_ns -eq 0 ]] || eerror "test-ns failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ emake test-ps force="--force --vardir=${S}/mysql-test/var-ps"
+ retstatus_ps=$?
+ [[ $retstatus_ps -eq 0 ]] || eerror "test-ps failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ # TODO:
+ # When upstream enables the pr and nr testsuites, we need those as well.
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_ns -eq 0 ]] || failures="${failures} test-ns"
+ [[ $retstatus_ps -eq 0 ]] || failures="${failures} test-ps"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
diff --git a/dev-db/mysql/mysql-5.5.22.ebuild b/dev-db/mysql/mysql-5.5.22.ebuild
new file mode 100644
index 000000000000..e0d09d5d2d17
--- /dev/null
+++ b/dev-db/mysql/mysql-5.5.22.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.5.22.ebuild,v 1.1 2012/04/02 00:39:27 robbat2 Exp $
+
+EAPI="4"
+
+MY_EXTRAS_VER="20120401-2131Z"
+MY_PV="${PV//_alpha_pre/-m}"
+MY_PV="${MY_PV//_/-}"
+
+# Build type
+BUILD="cmake"
+
+inherit toolchain-funcs mysql-v2
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# Define the mysql-extras source
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/mysql-extras.git"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='berkdb -cluster embedded extraengine perl ssl community' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mysql-X.X.XX.ebuild \
+# digest clean package
+src_test() {
+
+ local TESTDIR="${CMAKE_BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if ! use "minimal" ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${S}"/mysql-test/var-{tests}{,/log}
+
+ # These are failing in MySQL 5.5 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help-notwin
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # sys_vars.plugin_dir_basic
+ # fails because PLUGIN_DIR is set to MYSQL_LIBDIR64/plugin
+ # instead of MYSQL_LIBDIR/plugin
+ #
+ # main.flush_read_lock_kill
+ # fails because of unknown system variable 'DEBUG_SYNC'
+ #
+ # main.openssl_1
+ # error message changing
+ # -mysqltest: Could not open connection 'default': 2026 SSL connection
+ # error: ASN: bad other signature confirmation
+ # +mysqltest: Could not open connection 'default': 2026 SSL connection
+ # error: error:00000001:lib(0):func(0):reason(1)
+ #
+
+ for t in main.mysql_client_test \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help-notwin main.flush_read_lock_kill \
+ sys_vars.plugin_dir_basic main.openssl_1 ; do
+ mysql-v2_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ perl mysql-test-run.pl --force --vardir="${S}/mysql-test/var-tests"
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}