summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-31 22:33:37 +0000
commita1f29c51189508182de429248cc1464c4893cf4b (patch)
tree4a6733b0340578ff75eaa9b09d3d80f0423a47ba /dev-db/mysql/mysql-5.0.76-r1.ebuild
parentCleanup of forgotten files, fixes bug 274865 (diff)
downloadgentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.tar.gz
gentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.tar.bz2
gentoo-2-a1f29c51189508182de429248cc1464c4893cf4b.zip
Disable the SSL tests in all old 5.x ebuilds because the SSL certificates have expired now.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mysql/mysql-5.0.76-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.76-r1.ebuild30
1 files changed, 28 insertions, 2 deletions
diff --git a/dev-db/mysql/mysql-5.0.76-r1.ebuild b/dev-db/mysql/mysql-5.0.76-r1.ebuild
index c3e5db99bc56..29ab3ecd576a 100644
--- a/dev-db/mysql/mysql-5.0.76-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.76-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76-r1.ebuild,v 1.1 2009/04/12 00:11:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.76-r1.ebuild,v 1.2 2010/01/31 22:33:37 robbat2 Exp $
MY_EXTRAS_VER="20090412-0009Z"
SERVER_URI="http://mirror.provenscaling.com/mysql/enterprise/source/5.0/${P}.tar.gz"
@@ -99,6 +99,32 @@ src_test() {
mysql_disable_test \
"status2" \
"Broken in 5.0.72, new test is broken, upstream bug #41066"
+
+ # The entire 5.0 series has pre-generated SSL certificates, they have
+ # mostly expired now. ${S}/mysql-tests/std-data/*.pem
+ # The certs really SHOULD be generated for the tests, so that they are
+ # not expiring like this. We cannot do so ourselves as the tests look
+ # closely as the cert path data, and we do not have the CA key to regen
+ # ourselves. Alternatively, upstream should generate them with at least
+ # 50-year validity.
+ #
+ # Known expiry points:
+ # 4.1.*, 5.0.0-5.0.22, 5.1.7: Expires 2013/09/09
+ # 5.0.23-5.0.77, 5.1.7-5.1.22?: Expires 2009/01/27
+ # 5.0.78-5.0.90, 5.1.??-5.1.42: Expires 2010/01/28
+ #
+ # mysql-test/std_data/untrusted-cacert.pem is MEANT to be
+ # expired/invalid.
+ case ${PV} in
+ 5.0.*|5.1.*)
+ for t in openssl_1 rpl_openssl rpl_ssl ssl ssl_8k_key \
+ ssl_compress ssl_connect ; do \
+ mysql_disable_test \
+ "$t" \
+ "These OpenSSL tests break due to expired certificates"
+ done
+ ;;
+ esac
# SSL certs expired shortly after the release of 5.0.76. Affects older
# versions as well.