summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-11 10:18:58 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-11 10:18:58 +0000
commitc5d868067283277811a0b9f9cf402483ecb90cb8 (patch)
tree1290d7593c644a55e2d0e0cb4bcfd542cd99ea8f /dev-db/mysql++
parentMake it possible to skip phpize via the PHP_EXT_SKIP_PHPIZE env var. (diff)
downloadgentoo-2-c5d868067283277811a0b9f9cf402483ecb90cb8.tar.gz
gentoo-2-c5d868067283277811a0b9f9cf402483ecb90cb8.tar.bz2
gentoo-2-c5d868067283277811a0b9f9cf402483ecb90cb8.zip
Polish 2.2.2 ebuild for installing proper docs and headers that work with the binary mysql as well as the source mysql per bug #158171.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-db/mysql++')
-rw-r--r--dev-db/mysql++/ChangeLog9
-rw-r--r--dev-db/mysql++/files/digest-mysql++-2.2.2-r13
-rw-r--r--dev-db/mysql++/mysql++-2.2.2-r1.ebuild56
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-db/mysql++/ChangeLog b/dev-db/mysql++/ChangeLog
index 3edefb401c1e..c21d3de6114a 100644
--- a/dev-db/mysql++/ChangeLog
+++ b/dev-db/mysql++/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/mysql++
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.41 2007/04/13 20:28:38 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/ChangeLog,v 1.42 2007/07/11 10:18:58 robbat2 Exp $
+
+*mysql++-2.2.2-r1 (11 Jul 2007)
+
+ 11 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +mysql++-2.2.2-r1.ebuild:
+ Polish 2.2.2 ebuild for installing proper docs and headers that work with
+ the binary mysql as well as the source mysql per bug #158171.
*mysql++-2.2.2 (13 Apr 2007)
diff --git a/dev-db/mysql++/files/digest-mysql++-2.2.2-r1 b/dev-db/mysql++/files/digest-mysql++-2.2.2-r1
new file mode 100644
index 000000000000..7a63e36f3a02
--- /dev/null
+++ b/dev-db/mysql++/files/digest-mysql++-2.2.2-r1
@@ -0,0 +1,3 @@
+MD5 a3484c53eb86e04d430053de150b756d mysql++-2.2.2.tar.gz 1709697
+RMD160 87c6c5ddfe45f2607c1256d8e15aefa3ddd91d9a mysql++-2.2.2.tar.gz 1709697
+SHA256 a13b798c4082d663610c6457ee41a2e949ec4740c7fd9faafc33411d92d59565 mysql++-2.2.2.tar.gz 1709697
diff --git a/dev-db/mysql++/mysql++-2.2.2-r1.ebuild b/dev-db/mysql++/mysql++-2.2.2-r1.ebuild
new file mode 100644
index 000000000000..e1b7a44b2dc0
--- /dev/null
+++ b/dev-db/mysql++/mysql++-2.2.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql++/mysql++-2.2.2-r1.ebuild,v 1.1 2007/07/11 10:18:58 robbat2 Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="C++ API interface to the MySQL database"
+# This is the download page but includes links to other places
+HOMEPAGE="http://www.mysql.org/downloads/api-mysql++.html"
+SRC_URI="http://www.tangentsoft.net/mysql++/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~hppa ~mips ~sparc ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=sys-devel/gcc-3"
+RDEPEND="${DEPEND}
+ >=virtual/mysql-4.0"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ for i in ${S}/lib/*.h ; do
+ sed -i \
+ -e '/#include </s,mysql.h,mysql/mysql.h,g' \
+ -e '/#include </s,mysql_version.h,mysql/mysql_version.h,g' \
+ "${i}" || die "Failed to sed ${i} for fixing MySQL includes"
+ done
+}
+
+src_compile() {
+ local myconf
+ # we want C++ exceptions turned on
+ myconf="--enable-exceptions"
+ # give threads a try
+ myconf="${myconf} --enable-thread-check"
+ # not including the directives to where MySQL is because it seems to
+ # find it just fine without
+
+ # force the cflags into place otherwise they get totally ignored by
+ # configure
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ econf ${myconf} || die "econf failed"
+
+ emake || die "unable to make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # install the docs and HTML pages
+ dodoc README* CREDITS ChangeLog HACKERS Wishlist
+ dodoc doc/*
+ cp -ra doc/html ${D}/usr/share/doc/${PF}/html
+ prepalldocs
+}