summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-01-31 07:51:19 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-01-31 07:51:19 +0000
commitf9b0779a03fabfe73b75e43de78788c4e10f07a5 (patch)
tree6030d7995ede2fd7f0acfa77e3e9eb587eabed4a /dev-db/mtop
parentBug #296317: version bump. Renumber old version to ensure correct increments. (diff)
downloadgentoo-2-f9b0779a03fabfe73b75e43de78788c4e10f07a5.tar.gz
gentoo-2-f9b0779a03fabfe73b75e43de78788c4e10f07a5.tar.bz2
gentoo-2-f9b0779a03fabfe73b75e43de78788c4e10f07a5.zip
Bug #296186: Revbump with fix to use SHOW GLOBAL STATUS for QPS count, like similar patch in mytop. Upstream no longer maintains mtop, you should probably move to mytop instead.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/mtop')
-rw-r--r--dev-db/mtop/ChangeLog12
-rw-r--r--dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch12
-rw-r--r--dev-db/mtop/mtop-0.6.6-r1.ebuild50
3 files changed, 72 insertions, 2 deletions
diff --git a/dev-db/mtop/ChangeLog b/dev-db/mtop/ChangeLog
index 0383d9aca640..3bcecf6e76f6 100644
--- a/dev-db/mtop/ChangeLog
+++ b/dev-db/mtop/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/mtop
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mtop/ChangeLog,v 1.9 2007/02/22 01:06:26 peper Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mtop/ChangeLog,v 1.10 2010/01/31 07:51:18 robbat2 Exp $
+
+*mtop-0.6.6-r1 (31 Jan 2010)
+
+ 31 Jan 2010; Robin H. Johnson <robbat2@gentoo.org> +mtop-0.6.6-r1.ebuild,
+ +files/mtop-0.6.6-globalstatusfix.patch:
+ Bug #296186: Revbump with fix to use SHOW GLOBAL STATUS for QPS count,
+ like similar patch in mytop. Upstream no longer maintains mtop, you should
+ probably move to mytop instead.
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch b/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch
new file mode 100644
index 000000000000..1d10acc42a99
--- /dev/null
+++ b/dev-db/mtop/files/mtop-0.6.6-globalstatusfix.patch
@@ -0,0 +1,12 @@
+diff -ur mtop-0.6.6/work/mtop-0.6.6/mtop.PL mtop-0.6.6-r1/work/mtop-0.6.6/mtop.PL
+--- mtop-0.6.6/work/mtop-0.6.6/mtop.PL 2004-09-13 00:22:03.000000000 +0200
++++ mtop-0.6.6-r1/work/mtop-0.6.6/mtop.PL 2009-12-08 15:04:56.000000000 +0100
+@@ -568,7 +568,7 @@
+ die "Unable to connect to mysql [", $DBI::errstr, "]\n";
+
+ my $st_procs = $dbh->prepare("show full processlist");
+-my $st_status = $dbh->prepare("show status");
++my $st_status = $dbh->prepare("show global status");
+ my $st_kill = $dbh->prepare("kill ?");
+ my $st_flush = $dbh->prepare("flush status");
+ my $st_vars = $dbh->prepare("show variables");
diff --git a/dev-db/mtop/mtop-0.6.6-r1.ebuild b/dev-db/mtop/mtop-0.6.6-r1.ebuild
new file mode 100644
index 000000000000..cab5793e6105
--- /dev/null
+++ b/dev-db/mtop/mtop-0.6.6-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mtop/mtop-0.6.6-r1.ebuild,v 1.1 2010/01/31 07:51:18 robbat2 Exp $
+
+EAPI=2
+inherit perl-app
+
+DESCRIPTION="Mysql top monitors a MySQL server"
+HOMEPAGE="http://mtop.sourceforge.net"
+SRC_URI="mirror://sourceforge/mtop/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="dev-perl/Curses
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ virtual/perl-libnet"
+
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}"/mtop-0.6.6-globalstatusfix.patch
+}
+
+src_prepare() {
+ perl-app_src_prep || die "Perl module preparation failed."
+}
+
+src_compile() {
+ perl-app_src_compile || die "Perl module compilation failed."
+}
+
+src_test() {
+ perl-module_src_test || die "Perl module tests failed."
+}
+
+src_install() {
+ perl-module_src_install || die "Perl module installation failed."
+ dodoc ChangeLog COPYING README README.devel
+}
+
+warnmsg() {
+ einfo "Upstream no longer maintains mtop. You should consider dev-db/mytop instead."
+}
+pkg_postinst() {
+ warnmsg
+}
+pkg_preinst() {
+ warnmsg
+}