summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2006-10-07 13:19:32 +0000
committerSimon Stelling <blubb@gentoo.org>2006-10-07 13:19:32 +0000
commit87feed25d73b55ff4e3f0eb1f3ca5a12ec610cbb (patch)
tree811ec6a78435fa967dbede0777942198d96618e0 /dev-db/metakit
parentversion bump (diff)
downloadgentoo-2-87feed25d73b55ff4e3f0eb1f3ca5a12ec610cbb.tar.gz
gentoo-2-87feed25d73b55ff4e3f0eb1f3ca5a12ec610cbb.tar.bz2
gentoo-2-87feed25d73b55ff4e3f0eb1f3ca5a12ec610cbb.zip
64bit compilation fixes; bug 133872; thanks to Denis Gubanov for the initial patch
(Portage version: 2.1.2_pre2-r3)
Diffstat (limited to 'dev-db/metakit')
-rw-r--r--dev-db/metakit/ChangeLog7
-rw-r--r--dev-db/metakit/files/metakit-2.4.9.3-64bit.patch40
-rw-r--r--dev-db/metakit/metakit-2.4.9.3-r2.ebuild6
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-db/metakit/ChangeLog b/dev-db/metakit/ChangeLog
index 6a4a12d57413..ff756589b47a 100644
--- a/dev-db/metakit/ChangeLog
+++ b/dev-db/metakit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/metakit
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.31 2006/07/13 02:22:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.32 2006/10/07 13:19:32 blubb Exp $
+
+ 07 Oct 2006; Simon Stelling <blubb@gentoo.org>
+ +files/metakit-2.4.9.3-64bit.patch, metakit-2.4.9.3-r2.ebuild:
+ 64bit compilation fixes; bug 133872; thanks to Denis Gubanov for the initial
+ patch
13 Jul 2006; Aron Griffis <agriffis@gentoo.org> metakit-2.4.9.3-r2.ebuild:
Mark 2.4.9.3-r2 stable on ia64
diff --git a/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch b/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch
new file mode 100644
index 000000000000..5b91a8995cf3
--- /dev/null
+++ b/dev-db/metakit/files/metakit-2.4.9.3-64bit.patch
@@ -0,0 +1,40 @@
+diff -Nur metakit-2.4.9.3-orig/python/PyRowRef.cpp metakit-2.4.9.3/python/PyRowRef.cpp
+--- metakit-2.4.9.3-orig/python/PyRowRef.cpp 2004-01-20 17:46:06.000000000 -0800
++++ metakit-2.4.9.3/python/PyRowRef.cpp 2006-07-03 23:40:57.000000000 -0700
+@@ -24,12 +24,12 @@
+ }
+
+ static int PyRowRef_print(PyRowRef *o, FILE *f, int) {
+- fprintf(f, "<PyRowRef object at %x>", (int)o);
++ fprintf(f, "<PyRowRef object at %p>", (long)o);
+ return 0;
+ }
+
+ static int PyRORowRef_print(PyRowRef *o, FILE *f, int) {
+- fprintf(f, "<PyRORowRef object at %x>", (int)o);
++ fprintf(f, "<PyRORowRef object at %p>", (long)o);
+ return 0;
+ }
+
+diff -Nur metakit-2.4.9.3-orig/python/PyView.cpp metakit-2.4.9.3/python/PyView.cpp
+--- metakit-2.4.9.3-orig/python/PyView.cpp 2004-01-20 17:46:06.000000000 -0800
++++ metakit-2.4.9.3/python/PyView.cpp 2006-07-03 23:40:57.000000000 -0700
+@@ -971,15 +971,15 @@
+ }
+
+ static int PyView_print(PyView *o, FILE *f, int) {
+- fprintf(f, "<PyView object at %x>", (int)o);
++ fprintf(f, "<PyView object at %p", (long)o);
+ return 0;
+ }
+ static int PyViewer_print(PyView *o, FILE *f, int) {
+- fprintf(f, "<PyViewer object at %x>", (int)o);
++ fprintf(f, "<PyViewer object at %p>", (long)o);
+ return 0;
+ }
+ static int PyROViewer_print(PyView *o, FILE *f, int) {
+- fprintf(f, "<PyROViewer object at %x>", (int)o);
++ fprintf(f, "<PyROViewer object at %p>", (long)o);
+ return 0;
+ }
+
diff --git a/dev-db/metakit/metakit-2.4.9.3-r2.ebuild b/dev-db/metakit/metakit-2.4.9.3-r2.ebuild
index e8add1282698..7dea4a01fdad 100644
--- a/dev-db/metakit/metakit-2.4.9.3-r2.ebuild
+++ b/dev-db/metakit/metakit-2.4.9.3-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.3-r2.ebuild,v 1.19 2006/07/13 02:22:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.3-r2.ebuild,v 1.20 2006/10/07 13:19:32 blubb Exp $
-inherit python multilib
+inherit python multilib eutils
DESCRIPTION="Embedded database library"
HOMEPAGE="http://www.equi4.com/metakit/"
@@ -29,6 +29,8 @@ src_unpack() {
done
sed -i -e "s:python2.3:python${PYVER}:" unix/configure
sed -i -e "s:^\(CXXFLAGS = \).*:\1${CXXFLAGS}:" unix/Makefile.in
+
+ epatch "${FILESDIR}"/${P}-64bit.patch
}
src_compile() {