summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2011-07-06 16:51:45 +0000
committerChristian Ruppert <idl0r@gentoo.org>2011-07-06 16:51:45 +0000
commit23cf990996e73a51ee7a54a9b08149fdef740f29 (patch)
treee97a0b3568609349b26aad82a0dd6c8228bc244c /dev-db/maatkit
parentFix documentation installation wrt #298445 by Christophe LEFEBVRE. (diff)
downloadgentoo-2-23cf990996e73a51ee7a54a9b08149fdef740f29.tar.gz
gentoo-2-23cf990996e73a51ee7a54a9b08149fdef740f29.tar.bz2
gentoo-2-23cf990996e73a51ee7a54a9b08149fdef740f29.zip
Version bump, bug 374231. Add myself as secondary maintainer.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/maatkit')
-rw-r--r--dev-db/maatkit/ChangeLog9
-rw-r--r--dev-db/maatkit/maatkit-5014.ebuild101
-rw-r--r--dev-db/maatkit/maatkit-5240.ebuild101
-rw-r--r--dev-db/maatkit/maatkit-6070.ebuild99
-rw-r--r--dev-db/maatkit/maatkit-7540.ebuild (renamed from dev-db/maatkit/maatkit-7041.ebuild)3
-rw-r--r--dev-db/maatkit/metadata.xml27
6 files changed, 26 insertions, 314 deletions
diff --git a/dev-db/maatkit/ChangeLog b/dev-db/maatkit/ChangeLog
index 7a9b80a3bdc1..6e171436fdf2 100644
--- a/dev-db/maatkit/ChangeLog
+++ b/dev-db/maatkit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/maatkit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/ChangeLog,v 1.21 2011/05/10 13:22:29 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/ChangeLog,v 1.22 2011/07/06 16:51:45 idl0r Exp $
+
+*maatkit-7540 (06 Jul 2011)
+
+ 06 Jul 2011; Christian Ruppert <idl0r@gentoo.org> -maatkit-5014.ebuild,
+ -maatkit-5240.ebuild, -maatkit-6070.ebuild, -maatkit-7041.ebuild,
+ +maatkit-7540.ebuild, metadata.xml:
+ Version bump, bug 374231. Add myself as secondary maintainer.
10 May 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> maatkit-7207.ebuild:
x86 stable wrt bug #363245
diff --git a/dev-db/maatkit/maatkit-5014.ebuild b/dev-db/maatkit/maatkit-5014.ebuild
deleted file mode 100644
index 54e4db3f4938..000000000000
--- a/dev-db/maatkit/maatkit-5014.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/maatkit-5014.ebuild,v 1.2 2011/04/25 14:58:42 armin76 Exp $
-
-EAPI=2
-inherit perl-app toolchain-funcs
-
-DESCRIPTION="maatkit: essential command-line utilities for MySQL"
-HOMEPAGE="http://www.maatkit.org/"
-SRC_URI="http://maatkit.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="udf"
-
-DEPEND="dev-perl/DBD-mysql
- dev-perl/TermReadKey
- udf? ( dev-db/mysql[-minimal] )"
-RDEPEND="${DEPEND}"
-
-mysql-udf_src_compile() {
- local udfdir="${T}/udf/"
- mkdir -p "${udfdir}"
-
- local udfname udffile udfext udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- shift
- CXX="$(tc-getCXX)"
- local src="$@"
- if [ -z "$@" ]; then
- src="${udfname}.cc"
- fi
- for f in ${src} ; do
- [ -f "${f}" ] || \
- die "UDF ${udfname}: Cannot find source file ${f} to compile"
- done
- einfo "UDF ${udfname}: compiling from ${src}"
- ${CXX} \
- ${CXXFLAGS} -fPIC \
- -I/usr/include/mysql \
- -shared -o "${udfoutpath}" \
- $src \
- || die "UDF ${udfname}: Failed to compile"
-}
-
-mysql-udf_src_install() {
- local udfdir="${T}/udf/"
- local udfname udffile udfext udffile udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- insinto /usr/$(get_libdir)/mysql/plugins
- doins "${udfoutpath}"
-}
-
-udf_done_intro=0
-mysql-udf_pkg_postinst() {
- local udfname udffile udfext udffunc udfreturn
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udffunc="${2}"
- udfreturn="${3}"
- if [ ${udf_done_intro} -eq 0 ]; then
- elog "To use the UDFs that were built:"
- elog "Update your configuration to include 'plugin_dir=/usr/$(get_libdir)/mysql/plugins'"
- elog "Issue the following commands as a user with FUNCTION privileges:"
- udf_done_intro=1
- fi
- elog "CREATE FUNCTION ${udffunc} RETURNS ${udfreturn} SONAME '${udffile}'"
-}
-
-src_compile() {
- perl-app_src_compile
- if use udf; then
- cd "${S}"/udf
- mysql-udf_src_compile murmur_udf
- mysql-udf_src_compile fnv_udf
- fi
-}
-
-src_install() {
- perl-module_src_install
- if use udf; then
- mysql-udf_src_install murmur_udf
- mysql-udf_src_install fnv_udf
- fi
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
- if use udf; then
- mysql-udf_pkg_postinst murmur_udf murmur_hash INTEGER
- mysql-udf_pkg_postinst fnv_udf fnv_64 INTEGER
- fi
-}
diff --git a/dev-db/maatkit/maatkit-5240.ebuild b/dev-db/maatkit/maatkit-5240.ebuild
deleted file mode 100644
index 4bc00ee42bb8..000000000000
--- a/dev-db/maatkit/maatkit-5240.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/maatkit-5240.ebuild,v 1.5 2011/04/25 14:58:42 armin76 Exp $
-
-EAPI=2
-inherit perl-app toolchain-funcs
-
-DESCRIPTION="maatkit: essential command-line utilities for MySQL"
-HOMEPAGE="http://www.maatkit.org/"
-SRC_URI="http://maatkit.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="udf"
-
-DEPEND="dev-perl/DBD-mysql
- dev-perl/TermReadKey
- udf? ( dev-db/mysql[-minimal] )"
-RDEPEND="${DEPEND}"
-
-mysql-udf_src_compile() {
- local udfdir="${T}/udf/"
- mkdir -p "${udfdir}"
-
- local udfname udffile udfext udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- shift
- CXX="$(tc-getCXX)"
- local src="$@"
- if [ -z "$@" ]; then
- src="${udfname}.cc"
- fi
- for f in ${src} ; do
- [ -f "${f}" ] || \
- die "UDF ${udfname}: Cannot find source file ${f} to compile"
- done
- einfo "UDF ${udfname}: compiling from ${src}"
- ${CXX} \
- ${CXXFLAGS} -fPIC \
- -I/usr/include/mysql \
- -shared -o "${udfoutpath}" \
- $src \
- || die "UDF ${udfname}: Failed to compile"
-}
-
-mysql-udf_src_install() {
- local udfdir="${T}/udf/"
- local udfname udffile udfext udffile udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- insinto /usr/$(get_libdir)/mysql/plugins
- doins "${udfoutpath}"
-}
-
-udf_done_intro=0
-mysql-udf_pkg_postinst() {
- local udfname udffile udfext udffunc udfreturn
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udffunc="${2}"
- udfreturn="${3}"
- if [ ${udf_done_intro} -eq 0 ]; then
- elog "To use the UDFs that were built:"
- elog "Update your configuration to include 'plugin_dir=/usr/$(get_libdir)/mysql/plugins'"
- elog "Issue the following commands as a user with FUNCTION privileges:"
- udf_done_intro=1
- fi
- elog "CREATE FUNCTION ${udffunc} RETURNS ${udfreturn} SONAME '${udffile}'"
-}
-
-src_compile() {
- perl-app_src_compile
- if use udf; then
- cd "${S}"/udf
- mysql-udf_src_compile murmur_udf
- mysql-udf_src_compile fnv_udf
- fi
-}
-
-src_install() {
- perl-module_src_install
- if use udf; then
- mysql-udf_src_install murmur_udf
- mysql-udf_src_install fnv_udf
- fi
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
- if use udf; then
- mysql-udf_pkg_postinst murmur_udf murmur_hash INTEGER
- mysql-udf_pkg_postinst fnv_udf fnv_64 INTEGER
- fi
-}
diff --git a/dev-db/maatkit/maatkit-6070.ebuild b/dev-db/maatkit/maatkit-6070.ebuild
deleted file mode 100644
index 8bac2c775fb8..000000000000
--- a/dev-db/maatkit/maatkit-6070.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/maatkit-6070.ebuild,v 1.6 2011/04/25 14:58:42 armin76 Exp $
-
-EAPI=2
-inherit perl-app toolchain-funcs
-
-DESCRIPTION="maatkit: essential command-line utilities for MySQL"
-HOMEPAGE="http://www.maatkit.org/"
-SRC_URI="http://maatkit.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="udf"
-
-DEPEND="dev-perl/DBD-mysql
- dev-perl/TermReadKey
- udf? ( dev-db/mysql[-minimal] )"
-RDEPEND="${DEPEND}"
-
-mysql-udf_src_compile() {
- local udfdir="${T}/udf/"
- mkdir -p "${udfdir}"
-
- local udfname udffile udfext udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- shift
- CXX="$(tc-getCXX)"
- local src="$@"
- if [ -z "$@" ]; then
- src="${udfname}.cc"
- fi
- for f in ${src} ; do
- [ -f "${f}" ] || \
- die "UDF ${udfname}: Cannot find source file ${f} to compile"
- done
- einfo "UDF ${udfname}: compiling from ${src}"
- ${CXX} \
- ${CXXFLAGS} -I/usr/include/mysql \
- ${LDFLAGS} -fPIC -shared -o "${udfoutpath}" $src \
- || die "UDF ${udfname}: Failed to compile"
-}
-
-mysql-udf_src_install() {
- local udfdir="${T}/udf/"
- local udfname udffile udfext udffile udfoutpath
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udfoutpath="${udfdir}/${udffile}"
- insinto /usr/$(get_libdir)/mysql/plugins
- doins "${udfoutpath}"
-}
-
-udf_done_intro=0
-mysql-udf_pkg_postinst() {
- local udfname udffile udfext udffunc udfreturn
- udfname="${1}"
- udfext=".so"
- udffile="${udfname}${udfext}"
- udffunc="${2}"
- udfreturn="${3}"
- if [ ${udf_done_intro} -eq 0 ]; then
- elog "To use the UDFs that were built:"
- elog "Update your configuration to include 'plugin_dir=/usr/$(get_libdir)/mysql/plugins'"
- elog "Issue the following commands as a user with FUNCTION privileges:"
- udf_done_intro=1
- fi
- elog "CREATE FUNCTION ${udffunc} RETURNS ${udfreturn} SONAME '${udffile}'"
-}
-
-src_compile() {
- perl-app_src_compile
- if use udf; then
- cd "${S}"/udf
- mysql-udf_src_compile murmur_udf
- mysql-udf_src_compile fnv_udf
- fi
-}
-
-src_install() {
- perl-module_src_install
- if use udf; then
- mysql-udf_src_install murmur_udf
- mysql-udf_src_install fnv_udf
- fi
-}
-
-pkg_postinst() {
- perl-module_pkg_postinst
- if use udf; then
- mysql-udf_pkg_postinst murmur_udf murmur_hash INTEGER
- mysql-udf_pkg_postinst fnv_udf fnv_64 INTEGER
- fi
-}
diff --git a/dev-db/maatkit/maatkit-7041.ebuild b/dev-db/maatkit/maatkit-7540.ebuild
index eeaca4ea4f77..6953a9ecc5a3 100644
--- a/dev-db/maatkit/maatkit-7041.ebuild
+++ b/dev-db/maatkit/maatkit-7540.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/maatkit-7041.ebuild,v 1.2 2011/04/25 14:58:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/maatkit/maatkit-7540.ebuild,v 1.1 2011/07/06 16:51:45 idl0r Exp $
EAPI=3
@@ -26,6 +26,7 @@ RDEPEND="${COMMON_DEPEND}
virtual/perl-File-Temp
virtual/perl-File-Spec
virtual/perl-Time-HiRes
+ virtual/perl-Scalar-List-Utils
dev-perl/TermReadKey"
DEPEND="${COMMON_DEPEND}
udf? ( dev-db/mysql )
diff --git a/dev-db/maatkit/metadata.xml b/dev-db/maatkit/metadata.xml
index 65d37298016b..274d3e58184b 100644
--- a/dev-db/maatkit/metadata.xml
+++ b/dev-db/maatkit/metadata.xml
@@ -1,19 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
- <email>wschlich@gentoo.org</email>
- <name>Wolfram Schlich</name>
- <description>Primary maintainer</description>
-</maintainer>
-<longdescription>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>idl0r@gentoo.org</email>
+ <name>Christian Ruppert</name>
+ <description>Secondary maintainer</description>
+ </maintainer>
+ <longdescription>
maatkit, formerly MySQL Toolkit, is a collection of command-line utilities that
provide missing functionality for MySQL. Some of the tools implement lacking
server functionality, such as online consistency checks for master/slave
replication; others are client-side utilities such as a query profiler.
-</longdescription>
-<use>
- <flag name='udf'>Build the MySQL UDFs shipped with maatkit, requires non-minimal MySQL</flag>
- </use>
+ </longdescription>
+ <use>
+ <flag name="udf">Build the MySQL UDFs shipped with maatkit, requires non-minimal MySQL</flag>
+ </use>
</pkgmetadata>