summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-05-08 23:00:24 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-05-08 23:00:24 +0000
commitc9e77ebb3c06668d11e8fa420304359609677e0d (patch)
tree0738d00e266a4b57a72bee57a0965616e12aebd0 /dev-db/libpq
parentadd ~ia64 (diff)
downloadgentoo-2-c9e77ebb3c06668d11e8fa420304359609677e0d.tar.gz
gentoo-2-c9e77ebb3c06668d11e8fa420304359609677e0d.tar.bz2
gentoo-2-c9e77ebb3c06668d11e8fa420304359609677e0d.zip
fixed
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-db/libpq')
-rw-r--r--dev-db/libpq/ChangeLog6
-rw-r--r--dev-db/libpq/libpq-3.2.ebuild10
-rw-r--r--dev-db/libpq/libpq-4.0.ebuild12
3 files changed, 20 insertions, 8 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index 1e279048e3d7..a9412a9eee5f 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libpq
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.1 2005/05/08 17:45:47 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.2 2005/05/08 23:00:24 nakano Exp $
+
+ 08 May 2005; Masatomo Nakano <nakano@gentoo.org> libpq-3.2.ebuild,
+ libpq-4.0.ebuild:
+ Added header file.
*libpq-4.0 (08 May 2005)
*libpq-3.2 (08 May 2005)
diff --git a/dev-db/libpq/libpq-3.2.ebuild b/dev-db/libpq/libpq-3.2.ebuild
index 756fff2e09df..78dac6a05175 100644
--- a/dev-db/libpq/libpq-3.2.ebuild
+++ b/dev-db/libpq/libpq-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.1 2005/05/08 17:45:47 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -77,8 +77,12 @@ src_install() {
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- dosym /usr/lib/${P}.a /usr/lib/libpq.a
+ cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
+
+ dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
dodir /usr/include/postgresql/internal/
dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/*.h /usr/include/postgresql/internal/
+ dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
+ dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
+ dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
}
diff --git a/dev-db/libpq/libpq-4.0.ebuild b/dev-db/libpq/libpq-4.0.ebuild
index acbb9ade492d..edb84dc6ea2a 100644
--- a/dev-db/libpq/libpq-4.0.ebuild
+++ b/dev-db/libpq/libpq-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.1 2005/05/08 17:45:47 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -12,7 +12,7 @@ MY_P="postgresql"-${POSTGRESQL_VER}
SRC_URI="mirror://postgresql/source/v${POSTGRESQL_VER}/postgresql-base-${POSTGRESQL_VER}.tar.bz2"
LICENSE="POSTGRESQL"
-SLOT="3"
+SLOT="4"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
IUSE="ssl nls pam readline zlib kerberos"
#pg-hier"
@@ -77,8 +77,12 @@ src_install() {
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- dosym /usr/lib/${P}.a /usr/lib/libpq.a
+ cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
+
+ dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
dodir /usr/include/postgresql/internal/
dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/*.h /usr/include/postgresql/internal/
+ dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
+ dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
+ dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
}