summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-07-31 17:21:09 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-07-31 17:21:09 +0000
commit26dc80456d91b51a76a3e9a59c3ffd1ede008967 (patch)
tree46f29c157987cf2a634c67cf80e316a078aef3cb /dev-db/libpq/files
parentppc stable, bug #142194 (diff)
downloadgentoo-2-26dc80456d91b51a76a3e9a59c3ffd1ede008967.tar.gz
gentoo-2-26dc80456d91b51a76a3e9a59c3ffd1ede008967.tar.bz2
gentoo-2-26dc80456d91b51a76a3e9a59c3ffd1ede008967.zip
Fix patches.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'dev-db/libpq/files')
-rw-r--r--dev-db/libpq/files/libpq-7.3.15-gentoo.patch53
-rw-r--r--dev-db/libpq/files/libpq-7.4.13-gentoo.patch60
2 files changed, 113 insertions, 0 deletions
diff --git a/dev-db/libpq/files/libpq-7.3.15-gentoo.patch b/dev-db/libpq/files/libpq-7.3.15-gentoo.patch
new file mode 100644
index 000000000000..017dc522a1c5
--- /dev/null
+++ b/dev-db/libpq/files/libpq-7.3.15-gentoo.patch
@@ -0,0 +1,53 @@
+diff -Naru postgresql-7.3.14.org/src/interfaces/libpq/Makefile postgresql-7.3.14/src/interfaces/libpq/Makefile
+--- postgresql-7.3.14.org/src/interfaces/libpq/Makefile 2002-12-13 22:18:22.000000000 +0000
++++ postgresql-7.3.14/src/interfaces/libpq/Makefile 2005-05-16 04:12:52.000000000 +0100
+@@ -17,6 +17,7 @@
+ NAME= pq
+ SO_MAJOR_VERSION= 3
+ SO_MINOR_VERSION= 0
++NAME_STATIC_LIB= pq-$(SO_MAJOR_VERSION)
+
+ override CPPFLAGS := -I$(srcdir) $(CPPFLAGS) -DFRONTEND -DSYSCONFDIR='"$(sysconfdir)"'
+
+diff -Naru postgresql-7.3.14.org/src/interfaces/libpq/nls.mk postgresql-7.3.14/src/interfaces/libpq/nls.mk
+--- postgresql-7.3.14.org/src/interfaces/libpq/nls.mk 2002-09-22 21:57:21.000000000 +0100
++++ postgresql-7.3.14/src/interfaces/libpq/nls.mk 2005-05-16 04:13:08.000000000 +0100
+@@ -1,5 +1,5 @@
+ # $Header: /cvsroot/pgsql/src/interfaces/libpq/nls.mk,v 1.8 2002/09/22 20:57:21 petere Exp $
+-CATALOG_NAME := libpq
++CATALOG_NAME := libpq-3
+ AVAIL_LANGUAGES := cs de es fr pt_BR ru sv zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext
+diff -Naru postgresql-7.3.14.org/src/Makefile.shlib postgresql-7.3.14/src/Makefile.shlib
+--- postgresql-7.3.14.org/src/Makefile.shlib 2003-01-11 17:22:34.000000000 +0000
++++ postgresql-7.3.14/src/Makefile.shlib 2005-05-16 04:25:54.000000000 +0100
+@@ -221,7 +221,7 @@
+
+ all-lib: all-static-lib all-shared-lib
+
+-all-static-lib: lib$(NAME).a
++all-static-lib: lib$(NAME_STATIC_LIB).a
+
+ all-shared-lib: $(shlib)
+
+@@ -231,7 +231,7 @@
+ MK_NO_LORDER := true
+ endif
+
+-lib$(NAME).a: $(OBJS)
++lib$(NAME_STATIC_LIB).a: $(OBJS)
+ ifdef MK_NO_LORDER
+ $(LINK.static) $@ $^
+ else
+@@ -302,8 +302,8 @@
+ .PHONY: install-lib install-lib-static install-lib-shared
+ install-lib: install-lib-static install-lib-shared
+
+-install-lib-static: lib$(NAME).a
+- $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
++install-lib-static: lib$(NAME_STATIC_LIB).a
++ $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME_STATIC_LIB).a
+
+ ifeq ($(enable_shared), yes)
+ install-lib-shared: $(shlib)
diff --git a/dev-db/libpq/files/libpq-7.4.13-gentoo.patch b/dev-db/libpq/files/libpq-7.4.13-gentoo.patch
new file mode 100644
index 000000000000..1af40d7077c7
--- /dev/null
+++ b/dev-db/libpq/files/libpq-7.4.13-gentoo.patch
@@ -0,0 +1,60 @@
+diff -Naru postgresql-7.4.12.org/src/interfaces/libpq/Makefile postgresql-7.4.12/src/interfaces/libpq/Makefile
+--- postgresql-7.4.12.org/src/interfaces/libpq/Makefile 2003-09-27 16:32:48.000000000 +0100
++++ postgresql-7.4.12/src/interfaces/libpq/Makefile 2005-05-16 04:37:16.000000000 +0100
+@@ -17,6 +17,7 @@
+ NAME= pq
+ SO_MAJOR_VERSION= 3
+ SO_MINOR_VERSION= 1
++NAME_STATIC_LIB= pq-$(SO_MAJOR_VERSION)
+
+ override CPPFLAGS := -I$(srcdir) $(CPPFLAGS) $(THREAD_CPPFLAGS) -DFRONTEND -DSYSCONFDIR='"$(sysconfdir)"'
+
+@@ -66,7 +67,7 @@
+ $(INSTALL_DATA) $(srcdir)/libpq-fe.h $(DESTDIR)$(includedir)
+ $(INSTALL_DATA) $(srcdir)/libpq-int.h $(DESTDIR)$(includedir_internal)
+ $(INSTALL_DATA) $(srcdir)/pqexpbuffer.h $(DESTDIR)$(includedir_internal)
+- $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service.conf.sample
++ $(INSTALL_DATA) $(srcdir)/pg_service.conf.sample $(DESTDIR)$(datadir)/pg_service-${SO_MAJOR_VERSION}.conf.sample
+
+ installdirs:
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir) $(DESTDIR)$(includedir_internal)
+diff -Naru postgresql-7.4.12.org/src/interfaces/libpq/nls.mk postgresql-7.4.12/src/interfaces/libpq/nls.mk
+--- postgresql-7.4.12.org/src/interfaces/libpq/nls.mk 2004-10-30 09:22:16.000000000 +0100
++++ postgresql-7.4.12/src/interfaces/libpq/nls.mk 2005-05-16 04:37:23.000000000 +0100
+@@ -1,5 +1,5 @@
+ # $Header: /cvsroot/pgsql/src/interfaces/libpq/nls.mk,v 1.13.2.1 2004/10/30 08:22:16 petere Exp $
+-CATALOG_NAME := libpq
++CATALOG_NAME := libpq-3
+ AVAIL_LANGUAGES := cs de es fr hr it nb pt_BR ru sl sv tr zh_CN zh_TW
+ GETTEXT_FILES := fe-auth.c fe-connect.c fe-exec.c fe-lobj.c fe-misc.c fe-secure.c
+ GETTEXT_TRIGGERS:= libpq_gettext pqInternalNotice:2
+diff -Naru postgresql-7.4.12.org/src/Makefile.shlib postgresql-7.4.12/src/Makefile.shlib
+--- postgresql-7.4.12.org/src/Makefile.shlib 2003-10-20 02:34:33.000000000 +0100
++++ postgresql-7.4.12/src/Makefile.shlib 2005-05-16 04:36:25.000000000 +0100
+@@ -224,7 +224,7 @@
+
+ all-lib: all-static-lib all-shared-lib
+
+-all-static-lib: lib$(NAME).a
++all-static-lib: lib$(NAME_STATIC_LIB).a
+
+ all-shared-lib: $(shlib)
+
+@@ -234,7 +234,7 @@
+ MK_NO_LORDER := true
+ endif
+
+-lib$(NAME).a: $(OBJS)
++lib$(NAME_STATIC_LIB).a: $(OBJS)
+ ifdef MK_NO_LORDER
+ $(LINK.static) $@ $^
+ else
+@@ -305,7 +305,7 @@
+ .PHONY: install-lib install-lib-static install-lib-shared
+ install-lib: install-lib-static install-lib-shared
+
+-install-lib-static: lib$(NAME).a
++install-lib-static: lib$(NAME_STATIC_LIB).a
+ $(INSTALL_STLIB) $< $(DESTDIR)$(libdir)/lib$(NAME).a
+ ifeq ($(PORTNAME), darwin)
+ cd $(DESTDIR)$(libdir) && \