summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2013-08-29 16:01:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2013-08-29 16:01:24 +0000
commit7df52ef0d316bf621fe2d34d0ce899e6e79ec912 (patch)
tree3c5805f833c2a3c5032dbc2b8b6d96bdcb791910 /dev-db/libdbi
parentUpdate HOMEPAGE wrt bug #479216. (diff)
downloadgentoo-2-7df52ef0d316bf621fe2d34d0ce899e6e79ec912.tar.gz
gentoo-2-7df52ef0d316bf621fe2d34d0ce899e6e79ec912.tar.bz2
gentoo-2-7df52ef0d316bf621fe2d34d0ce899e6e79ec912.zip
Bump per bug #465716.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-db/libdbi')
-rw-r--r--dev-db/libdbi/ChangeLog9
-rw-r--r--dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch22
-rw-r--r--dev-db/libdbi/libdbi-0.9.0.ebuild59
3 files changed, 88 insertions, 2 deletions
diff --git a/dev-db/libdbi/ChangeLog b/dev-db/libdbi/ChangeLog
index 639108761cb5..a3dce8bf7623 100644
--- a/dev-db/libdbi/ChangeLog
+++ b/dev-db/libdbi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdbi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.50 2013/05/14 02:23:38 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/ChangeLog,v 1.51 2013/08/29 16:01:24 robbat2 Exp $
+
+*libdbi-0.9.0 (29 Aug 2013)
+
+ 29 Aug 2013; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-0.9.0-doc-build-fix.patch, +libdbi-0.9.0.ebuild:
+ Bump per bug #465716.
14 May 2013; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
libdbi-0.8.4.ebuild, +files/libdbi-0.8.4-fix-ac-macro.patch:
@@ -173,4 +179,3 @@
24 Mar 2004; Robin H. Johnson <robbat2@gentoo.org> libdbi-0.7.2.ebuild:
Initial commit. Original ebuild submitted by Max <m.e.bruche@lse.ac.uk>. Bug
#45153.
-
diff --git a/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch b/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch
new file mode 100644
index 000000000000..c0818b9c295b
--- /dev/null
+++ b/dev-db/libdbi/files/libdbi-0.9.0-doc-build-fix.patch
@@ -0,0 +1,22 @@
+diff -Nuar libdbi-0.9.0.orig/configure.in libdbi-0.9.0/configure.in
+--- libdbi-0.9.0.orig/configure.in 2013-08-29 15:34:54.883102666 +0000
++++ libdbi-0.9.0/configure.in 2013-08-29 15:36:07.827905613 +0000
+@@ -201,14 +201,13 @@
+ dnl See whether to build the docs
+ dnl ==============================
+
+-ac_docs="YES"
++ac_docs="yes"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ if test "$enable_docs" = "no"; then
+- ac_docs="NO"
+- fi])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ docs_subdirs="doc"
+ else
+ docs_subdirs=""
diff --git a/dev-db/libdbi/libdbi-0.9.0.ebuild b/dev-db/libdbi/libdbi-0.9.0.ebuild
new file mode 100644
index 000000000000..bf40c894ca9b
--- /dev/null
+++ b/dev-db/libdbi/libdbi-0.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi/libdbi-0.9.0.ebuild,v 1.1 2013/08/29 16:01:24 robbat2 Exp $
+
+EAPI=4
+
+inherit eutils autotools multilib
+
+DESCRIPTION="libdbi is a database-independent abstraction layer in C, similar to the DBI/DBD layer in Perl."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://libdbi.sourceforge.net/"
+LICENSE="LGPL-2.1"
+
+IUSE="doc static-libs"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+SLOT=0
+
+DOCS="AUTHORS ChangeLog README README.osx TODO"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ virtual/pkgconfig
+ doc? ( app-text/openjade )
+"
+PDEPEND=">=dev-db/libdbi-drivers-0.9.0" # On purpose, libdbi-drivers 0.8.4 does not exist
+
+src_unpack() {
+ unpack ${A}
+ chown -R portage:portage "${S}"
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}"/${PN}-0.9.0-fix-ac-macro.patch
+ #epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
+ #cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
+ epatch "${FILESDIR}"/libdbi-0.9.0-doc-build-fix.patch
+
+ # configure.in has been changed
+ eautoreconf
+ # should append CFLAGS, not replace them
+ sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ default
+
+ prune_libtool_files --all
+
+ # syslog-ng requires dbi.pc
+ insinto /usr/$(get_libdir)/pkgconfig/
+ doins dbi.pc
+}