summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-06-11 09:52:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-06-11 09:52:53 +0000
commitec09cf8de340825965925722dbbf1f1debe19294 (patch)
treec044d092fd08c534a984326e2cd7d738886e2000 /dev-db/libdbi-drivers
parentnew version (#132495), the m4 issue is fixed, the --as-needed patch is still ... (diff)
downloadgentoo-2-ec09cf8de340825965925722dbbf1f1debe19294.tar.gz
gentoo-2-ec09cf8de340825965925722dbbf1f1debe19294.tar.bz2
gentoo-2-ec09cf8de340825965925722dbbf1f1debe19294.zip
Bug #134918 - Compile fix for oci8 driver.
(Portage version: 2.1)
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog6
-rw-r--r--dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff20
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild7
3 files changed, 31 insertions, 2 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
index dd7a4e55e36d..80786429d090 100644
--- a/dev-db/libdbi-drivers/ChangeLog
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libdbi-drivers
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.18 2006/03/24 14:36:37 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.19 2006/06/11 09:52:53 robbat2 Exp $
+
+ 11 Jun 2006; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-drivers-0.8.1-oci8.diff, libdbi-drivers-0.8.1-r1.ebuild:
+ Bug #134918 - Compile fix for oci8 driver.
24 Mar 2006; Joseph Jezak <josejx@gentoo.org>
libdbi-drivers-0.7.1-r1.ebuild:
diff --git a/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff b/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff
new file mode 100644
index 000000000000..23916d34cb79
--- /dev/null
+++ b/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.1-oci8.diff
@@ -0,0 +1,20 @@
+--- libdbi-drivers-0.8.1/drivers/oracle/dbd_oracle.c.orig 2005-08-31 23:44:53.000000000 +0200
++++ libdbi-drivers-0.8.1/drivers/oracle/dbd_oracle.c 2006-05-30 13:10:48.000000000 +0200
+@@ -523,7 +523,7 @@
+ unsigned int sizeattrib;
+ dbi_data_t *data;
+ char *ptr, *cols[result->numfields];
+- dword status;
++ sword status;
+
+ /*
+ * Prefetch all cols as char *'s
+@@ -700,7 +700,7 @@
+ }
+
+ /* taken from sqlite3 driver */
+-size_t dbd_quote_binary (dbi_conn_t *conn, const unsigned char *orig, size_t from_length, char **ptr_dest ) {
++size_t dbd_quote_binary (dbi_conn_t *conn, const unsigned char *orig, size_t from_length, unsigned char **ptr_dest ) {
+ unsigned char *temp;
+ size_t len;
+
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild
index fbe05d85c2d5..2afafa048022 100644
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild,v 1.2 2006/03/07 11:44:53 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.1-r1.ebuild,v 1.3 2006/06/11 09:52:53 robbat2 Exp $
DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -17,6 +17,11 @@ IUSE="mysql postgres sqlite oci8 firebird sqlite3"
KEYWORDS="~amd64 hppa ~ppc ~sparc ~x86"
SLOT=0
+src_unpack() {
+ unpack ${A}
+ EPATCH_OPTS="-p1 -d${S}" epatch ${FILESDIR}/${P}-oci8.diff
+}
+
src_compile() {
local myconf=""
local drivers=""