summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-10-10 00:32:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-10-10 00:32:18 +0000
commitb9c2b9811d3e4eca889373e36c3f0eea2ff9e089 (patch)
tree6e5c27c5a23eef568cf260bdf18d390d2ea842be /dev-db/libdbi-drivers
parentMake documentation build properly optional instead of dependant on system con... (diff)
downloadgentoo-2-b9c2b9811d3e4eca889373e36c3f0eea2ff9e089.tar.gz
gentoo-2-b9c2b9811d3e4eca889373e36c3f0eea2ff9e089.tar.bz2
gentoo-2-b9c2b9811d3e4eca889373e36c3f0eea2ff9e089.zip
Make documentation build properly optional instead of dependant on system contents.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog8
-rw-r--r--dev-db/libdbi-drivers/files/libdbi-drivers-0.8.3-doc-build-fix.patch15
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild18
3 files changed, 35 insertions, 6 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
index 3e442a4fdea6..9a7402154b44 100644
--- a/dev-db/libdbi-drivers/ChangeLog
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/libdbi-drivers
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.28 2008/09/29 02:47:33 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.29 2008/10/10 00:32:18 robbat2 Exp $
+
+ 10 Oct 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/libdbi-drivers-0.8.3-doc-build-fix.patch,
+ libdbi-drivers-0.8.3.ebuild:
+ Make documentation build properly optional instead of dependant on system
+ contents.
29 Sep 2008; Robin H. Johnson <robbat2@gentoo.org>
-libdbi-drivers-0.7.1.ebuild, -libdbi-drivers-0.7.1-r1.ebuild,
diff --git a/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.3-doc-build-fix.patch b/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.3-doc-build-fix.patch
new file mode 100644
index 000000000000..f3caedb1dbc6
--- /dev/null
+++ b/dev-db/libdbi-drivers/files/libdbi-drivers-0.8.3-doc-build-fix.patch
@@ -0,0 +1,15 @@
+diff -Nuar libdbi-drivers-0.8.3-1.orig/configure.in libdbi-drivers-0.8.3-1/configure.in
+--- libdbi-drivers-0.8.3-1.orig/configure.in 2008-10-09 17:09:09.303141877 -0700
++++ libdbi-drivers-0.8.3-1/configure.in 2008-10-09 17:10:48.100635797 -0700
+@@ -149,7 +149,8 @@
+-ac_docs="YES"
++ac_docs="no"
+ AC_ARG_ENABLE(docs,
+ [ --disable-docs do not build and install the documentation.],
+- [ ac_docs="NO" ])
++ [ ac_docs="$enableval" ],
++ [ ac_docs="no" ])
+
+-if test "$ac_docs" = "YES"; then
++if test "$ac_docs" = "yes"; then
+ dnl AC_PATH_PROGS(myjade, openjade jade)
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild
index a2ad7c7f5455..400912f06149 100644
--- a/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild,v 1.1 2008/09/29 02:41:13 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/libdbi-drivers-0.8.3.ebuild,v 1.2 2008/10/10 00:32:18 robbat2 Exp $
-inherit eutils
+inherit eutils autotools
MY_PV="${PV}-1"
MY_P="${PN}-${MY_PV}"
@@ -16,13 +16,21 @@ DEPEND=">=dev-db/libdbi-0.8.3
postgres? ( virtual/postgresql-server )
sqlite? ( <dev-db/sqlite-3 )
sqlite3? ( >=dev-db/sqlite-3 )
- !bindist? ( firebird? ( dev-db/firebird ) )"
+ !bindist? ( firebird? ( dev-db/firebird ) )
+ doc? ( app-text/openjade )"
-IUSE="mysql postgres sqlite oci8 firebird sqlite3 bindist"
+IUSE="mysql postgres sqlite oci8 firebird sqlite3 bindist doc"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
SLOT=0
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-0.8.3-doc-build-fix.patch
+ cd "${S}"
+ eautoreconf
+}
+
pkg_setup() {
local drivers=""
use mysql && drivers="${drivers} mysql"
@@ -66,7 +74,7 @@ src_compile() {
myconf="${myconf} --with-oracle-dir=${ORACLE_HOME} --with-oracle"
fi
- econf ${myconf} || die "econf failed"
+ econf $(use_enable doc docs) ${myconf} || die "econf failed"
emake || die "emake failed"
}