summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-06-18 17:17:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-06-18 17:17:45 +0000
commit201d284e862470adf2c2c086b69ee434bb8830a3 (patch)
tree92c64a3bc0dc268b4cf712cc6af40a25fb27e0c7 /dev-db/kyotocabinet
parentReassigning to maintainer-needed. (diff)
downloadgentoo-2-201d284e862470adf2c2c086b69ee434bb8830a3.tar.gz
gentoo-2-201d284e862470adf2c2c086b69ee434bb8830a3.tar.bz2
gentoo-2-201d284e862470adf2c2c086b69ee434bb8830a3.zip
Bump, fixes #368867
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/kyotocabinet')
-rw-r--r--dev-db/kyotocabinet/ChangeLog8
-rw-r--r--dev-db/kyotocabinet/files/fix_configure-1.2.62.patch51
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.62.ebuild52
3 files changed, 110 insertions, 1 deletions
diff --git a/dev-db/kyotocabinet/ChangeLog b/dev-db/kyotocabinet/ChangeLog
index 864621a910da..6185cfb69307 100644
--- a/dev-db/kyotocabinet/ChangeLog
+++ b/dev-db/kyotocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/kyotocabinet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.10 2011/03/19 16:27:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/ChangeLog,v 1.11 2011/06/18 17:17:45 patrick Exp $
+
+*kyotocabinet-1.2.62 (18 Jun 2011)
+
+ 18 Jun 2011; Patrick Lauer <patrick@gentoo.org> +kyotocabinet-1.2.62.ebuild,
+ +files/fix_configure-1.2.62.patch:
+ Bump, fixes #368867
*kyotocabinet-1.2.50 (19 Mar 2011)
diff --git a/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch b/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
new file mode 100644
index 000000000000..97789627e0b8
--- /dev/null
+++ b/dev-db/kyotocabinet/files/fix_configure-1.2.62.patch
@@ -0,0 +1,51 @@
+diff --git a/configure.in b/configure.in
+index 94e9d29..6999615 100644
+--- a/configure.in
++++ b/configure.in
+@@ -35,27 +35,18 @@ MYDOCUMENTFILES="COPYING FOSSEXCEPTION ChangeLog doc kyotocabinet.idl"
+ MYPCFILES="kyotocabinet.pc"
+
+ # Building flags
+-MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char -g0 -O2"
+-MYCXXFLAGS="-Wall -fPIC -fsigned-char -g0 -O2"
+-MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I/usr/local/include"
++MYCFLAGS="-Wall -ansi -pedantic -fPIC -fsigned-char -g0"
++MYCXXFLAGS="-Wall -fPIC -fsigned-char -g0"
++MYCPPFLAGS="-I. -I\$(INCLUDEDIR)"
+ MYCPPFLAGS="$MYCPPFLAGS -DNDEBUG -D_GNU_SOURCE=1"
+ MYCPPFLAGS="$MYCPPFLAGS -D_FILE_OFFSET_BITS=64 -D_REENTRANT -D__EXTENSIONS__"
+-MYLDFLAGS="-L. -L\$(LIBDIR) -L/usr/local/lib"
++MYLDFLAGS="-L. -L\$(LIBDIR)"
+ MYCMDLDFLAGS=""
+ MYCMDLIBS=""
+ MYLDLIBPATH=""
+ MYLDLIBPATHENV="LD_LIBRARY_PATH"
+ MYPOSTCMD="true"
+
+-# Building paths
+-PATH=".:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:$PATH"
+-CPATH=".:/usr/local/include:$CPATH"
+-LIBRARY_PATH=".:/usr/local/lib:$LIBRARY_PATH"
+-LD_LIBRARY_PATH=".:/usr/local/lib:$LD_LIBRARY_PATH"
+-PKG_CONFIG_PATH=".:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
+-export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
+-
+-
+
+ #================================================================
+ # Options
+@@ -285,14 +276,6 @@ then
+ MYCMDLIBS="$MYCMDLIBS $LIBS"
+ fi
+
+-# As-needed linking
+-if uname | grep Linux >config.tmp
+-then
+- MYLDFLAGS="$MYLDFLAGS -Wl,-rpath-link,.:/usr/local/lib:$MYLDLIBPATH"
+- MYLDFLAGS="$MYLDFLAGS -Wl,--as-needed"
+-else
+- MYCMDLIBS="$MYCMDLIBS $LIBS"
+-fi
+
+ # Shared libraries
+ if test "$enable_shared" != "no" && test "$enable_profile" != "yes" \ No newline at end of file
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.62.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.62.ebuild
new file mode 100644
index 000000000000..ae158f2cb2ad
--- /dev/null
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.62.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/kyotocabinet/kyotocabinet-1.2.62.ebuild,v 1.1 2011/06/18 17:17:45 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A straightforward implementation of DBM"
+HOMEPAGE="http://fallabs.com/kyotocabinet/"
+SRC_URI="${HOMEPAGE}pkg/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples static-libs"
+
+DEPEND="sys-libs/zlib
+ app-arch/xz-utils"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_configure-${PV}.patch"
+ sed -ie "/ldconfig/d" Makefile.in
+ sed -ie "/DOCDIR/d" Makefile.in
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable static-libs static) \
+ $(use_enable !static-libs shared) \
+ --enable-lzma --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+
+ if use examples; then
+ insinto /usr/share/${PF}/example
+ doins example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+} \ No newline at end of file