summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-18 01:42:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-10-18 01:42:43 +0000
commit3f0b4810488b309e304d135e8c286bfafc01866e (patch)
treebe6be00b733c22b293bc85a34b83995fadbcdd58 /dev-db/haildb
parentMove into unstable. (diff)
downloadgentoo-2-3f0b4810488b309e304d135e8c286bfafc01866e.tar.gz
gentoo-2-3f0b4810488b309e304d135e8c286bfafc01866e.tar.bz2
gentoo-2-3f0b4810488b309e304d135e8c286bfafc01866e.zip
Initial import of haildb proxy-maintained by Pavel Stratil, that will be used in the (near) future by dev-db/drizzle.
(Portage version: 2.2_rc97/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/haildb')
-rw-r--r--dev-db/haildb/ChangeLog12
-rw-r--r--dev-db/haildb/haildb-2.2.0.ebuild54
-rw-r--r--dev-db/haildb/haildb-2.3.1.ebuild54
-rw-r--r--dev-db/haildb/metadata.xml30
4 files changed, 150 insertions, 0 deletions
diff --git a/dev-db/haildb/ChangeLog b/dev-db/haildb/ChangeLog
new file mode 100644
index 000000000000..3fdada34b194
--- /dev/null
+++ b/dev-db/haildb/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-db/haildb
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/haildb/ChangeLog,v 1.1 2010/10/18 01:42:43 flameeyes Exp $
+
+*haildb-2.3.1 (17 Oct 2010)
+*haildb-2.2.0 (17 Oct 2010)
+
+ 17 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +haildb-2.2.0.ebuild, +haildb-2.3.1.ebuild, +metadata.xml:
+ Initial import of haildb proxy-maintained by Pavel Stratil, that will be
+ used in the (near) future by dev-db/drizzle.
+
diff --git a/dev-db/haildb/haildb-2.2.0.ebuild b/dev-db/haildb/haildb-2.2.0.ebuild
new file mode 100644
index 000000000000..2331218dd982
--- /dev/null
+++ b/dev-db/haildb/haildb-2.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/haildb/haildb-2.2.0.ebuild,v 1.1 2010/10/18 01:42:43 flameeyes Exp $
+
+EAPI=2
+
+inherit versionator
+
+DESCRIPTION="a relational database in shared library form"
+HOMEPAGE="http://www.haildb.com/"
+SRC_URI="http://launchpad.net/haildb/$(get_major_version).x/$(get_version_component_range 1-2)/+download/${P}.tar.gz"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug tcmalloc zlib"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_configure() {
+ local myconf
+
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ # never allow it to find valgrind, easier this way
+ export ac_cv_header_valgrind_memcheck_h=no
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-silent-rules \
+ --disable-mtmalloc \
+ $(use_enable zlib compression) \
+ $(use_enable tcmalloc) \
+ ${myconf} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README || die
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-db/haildb/haildb-2.3.1.ebuild b/dev-db/haildb/haildb-2.3.1.ebuild
new file mode 100644
index 000000000000..763929cb421c
--- /dev/null
+++ b/dev-db/haildb/haildb-2.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/haildb/haildb-2.3.1.ebuild,v 1.1 2010/10/18 01:42:43 flameeyes Exp $
+
+EAPI=2
+
+inherit versionator
+
+DESCRIPTION="a relational database in shared library form"
+HOMEPAGE="http://www.haildb.com/"
+SRC_URI="http://launchpad.net/haildb/$(get_version_component_range 1-2)/athens/+download/${P}.tar.gz"
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug tcmalloc zlib"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_configure() {
+ local myconf
+
+ if use debug; then
+ # Since --with-debug would turn off optimisations as well as
+ # enabling debug, we just enable debug through the
+ # preprocessor then.
+ append-flags -DDEBUG
+ else
+ myconf="${myconf} --disable-assert"
+ fi
+
+ # never allow it to find valgrind, easier this way
+ export ac_cv_header_valgrind_memcheck_h=no
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-silent-rules \
+ --disable-mtmalloc \
+ $(use_enable zlib compression) \
+ $(use_enable tcmalloc) \
+ ${myconf} \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README || die
+
+ find "${D}" -name '*.la' -delete || die
+} \ No newline at end of file
diff --git a/dev-db/haildb/metadata.xml b/dev-db/haildb/metadata.xml
new file mode 100644
index 000000000000..b1f30bdb403b
--- /dev/null
+++ b/dev-db/haildb/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>pavel.stratil-jun@fenix.cz</email>
+ <description>Proxied co-maintainer, CC on all bugs</description>
+ </maintainer>
+
+ <use>
+ <flag name="tcmalloc">
+ Use the <pkg>dev-util/google-perftools</pkg> libraries to
+ replace the malloc() implementation with a possibly faster one.
+ </flag>
+
+ <flag name="zlib">
+ Add support for compressed tables through
+ <pkg>sys-libs/zlib</pkg>.
+ </flag>
+
+ <flag name="debug">
+ Enable extra debug codepaths and assertions. If disabled, both
+ the debug code and assertions are removed from the resulting
+ binaries. Optimisations are untouched.
+ </flag>
+ </use>
+</pkgmetadata>