summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-01-30 14:58:19 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-01-30 14:58:19 +0000
commitf0cbf73f442471121f0698ca331a89dfffbfc824 (patch)
treed2f8ba15a98056f5d4d721222a60a517e73464c3 /dev-cpp
parent * remove copy of aclocal, fix bug #208042 (diff)
downloadgentoo-2-f0cbf73f442471121f0698ca331a89dfffbfc824.tar.gz
gentoo-2-f0cbf73f442471121f0698ca331a89dfffbfc824.tar.bz2
gentoo-2-f0cbf73f442471121f0698ca331a89dfffbfc824.zip
old
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libherdstat/ChangeLog6
-rw-r--r--dev-cpp/libherdstat/files/digest-libherdstat-0.2.06
-rw-r--r--dev-cpp/libherdstat/files/libherdstat-0.2.0-gcc.patch148
-rw-r--r--dev-cpp/libherdstat/libherdstat-0.2.0.ebuild72
4 files changed, 5 insertions, 227 deletions
diff --git a/dev-cpp/libherdstat/ChangeLog b/dev-cpp/libherdstat/ChangeLog
index df9a680be9f8..14aa87f2e423 100644
--- a/dev-cpp/libherdstat/ChangeLog
+++ b/dev-cpp/libherdstat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/libherdstat
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libherdstat/ChangeLog,v 1.16 2008/01/24 20:27:55 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libherdstat/ChangeLog,v 1.17 2008/01/30 14:58:19 armin76 Exp $
+
+ 30 Jan 2008; Raúl Porcel <armin76@gentoo.org>
+ -files/libherdstat-0.2.0-gcc.patch, -libherdstat-0.2.0.ebuild:
+ old
24 Jan 2008; Christoph Mende <angelos@gentoo.org>
libherdstat-0.1.1-r1.ebuild:
diff --git a/dev-cpp/libherdstat/files/digest-libherdstat-0.2.0 b/dev-cpp/libherdstat/files/digest-libherdstat-0.2.0
deleted file mode 100644
index 9fc4814b4759..000000000000
--- a/dev-cpp/libherdstat/files/digest-libherdstat-0.2.0
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 3a7bff68e6a5818c461ad359291181c0 herdstat-test-data-20060119.tar.bz2 15549
-RMD160 d48b869e00ad03771a4a2fa9fc2ecfead80810da herdstat-test-data-20060119.tar.bz2 15549
-SHA256 0d154483310b59054cfd6ddb9fb5c477ad786cdb7ff11cdfaa74a82c0c0e8633 herdstat-test-data-20060119.tar.bz2 15549
-MD5 8806057274b326a4a63a091bf4f666a1 libherdstat-0.2.0.tar.bz2 360556
-RMD160 adac363187d0f942fa11be7444d669abf2e919e0 libherdstat-0.2.0.tar.bz2 360556
-SHA256 7937387d76558c3ced5cf03d5469cb21e9c8096476aceb7d68f33e8fd7861a8c libherdstat-0.2.0.tar.bz2 360556
diff --git a/dev-cpp/libherdstat/files/libherdstat-0.2.0-gcc.patch b/dev-cpp/libherdstat/files/libherdstat-0.2.0-gcc.patch
deleted file mode 100644
index 1b341d167b6f..000000000000
--- a/dev-cpp/libherdstat/files/libherdstat-0.2.0-gcc.patch
+++ /dev/null
@@ -1,148 +0,0 @@
-Index: tests/src/binaryio-test.hh
-===================================================================
---- tests/src/binaryio-test.hh (revision 223)
-+++ tests/src/binaryio-test.hh (revision 224)
-@@ -115,11 +115,10 @@
- if (not stream)
- throw herdstat::FileException("bar");
-
-- herdstat::io::BinaryIStreamIterator<std::string> strEOF;
-+ std::vector<std::string> s2;
-+ s2.assign(herdstat::io::BinaryIStreamIterator<std::string>(stream),
-+ herdstat::io::BinaryIStreamIterator<std::string>());
-
-- std::vector<std::string> s2(
-- herdstat::io::BinaryIStreamIterator<std::string>(stream), strEOF);
--
- std::cout << "s2 = '";
- std::copy(s2.begin(), s2.end(),
- std::ostream_iterator<std::string>(std::cout, " "));
-Index: configure.ac
-===================================================================
---- configure.ac (revision 223)
-+++ configure.ac (revision 224)
-@@ -10,8 +10,8 @@
- VERSION_MAJOR=0
- VERSION_MINOR=2
- VERSION_MICRO=0
--VERSION_SUFFIX=
--VERSION_SUFFIX_VERSION=
-+VERSION_SUFFIX=p
-+VERSION_SUFFIX_VERSION=1
- VERSION_FULL="$VERSION_MAJOR.$VERSION_MINOR.$VERSION_MICRO"
-
- if ! test -z "$VERSION_SUFFIX" ; then
-@@ -104,6 +104,41 @@
- AC_DEFINE_UNQUOTED(HAVE_GCC4, 1, [GCC Version 4])
- fi
-
-+AC_MSG_CHECKING([if ${CXX} supports __attribute__ ((unused))])
-+AC_COMPILE_IFELSE(AC_LANG_PROGRAM([
-+#include <stdio.h>
-+void foo(int x __attribute__ ((unused)))
-+{ printf("foo\n"); }
-+],[
-+ int i = 10;
-+ foo(i);
-+ return 0;
-+ ]),
-+ [HAS_ATTR_UNUSED="yes"],[HAS_ATTR_UNUSED="no"])
-+AC_MSG_RESULT([$HAS_ATTR_UNUSED])
-+
-+if test "x$HAS_ATTR_UNUSED" = "xyes" ; then
-+ AC_DEFINE(HAVE_ATTR_UNUSED, 1, [C compiler supports the unused attribute])
-+fi
-+
-+AC_MSG_CHECKING([if ${CXX} supports __attribute__ ((deprecated))])
-+AC_COMPILE_IFELSE(AC_LANG_PROGRAM([
-+class __attribute__ ((deprecated)) Foo
-+{
-+ public:
-+ Foo() __attribute__ ((deprecated)) { }
-+};
-+],[
-+ Foo foo;
-+ return 0;
-+ ]),
-+ [HAS_ATTR_DEPRECAED="yes"],[HAS_ATTR_DEPRECAED="no"])
-+AC_MSG_RESULT([$HAS_ATTR_DEPRECAED])
-+
-+if test "x$HAS_ATTR_DEPRECAED" = "xyes" ; then
-+ AC_DEFINE(HAVE_ATTR_DEPRECATED, 1, [C compiler supports the deprecated attribute])
-+fi
-+
- LHS_CHECK_CXXFLAG([-pedantic])
- LHS_CHECK_CXXFLAG([-ansi])
- LHS_CHECK_CXXFLAG([-W])
-Index: herdstat/defs.hh
-===================================================================
---- herdstat/defs.hh (revision 223)
-+++ herdstat/defs.hh (revision 224)
-@@ -35,7 +35,7 @@
- #define NELEMS(x) (sizeof(x) / sizeof(x[0]))
-
- #ifndef LIBHERDSTAT_DEPRECATED
--# if defined(__GNUC__) || defined(DOXYGEN)
-+# if defined(HAVE_ATTR_DEPRECATED) || defined(DOXYGEN)
- # define LIBHERDSTAT_DEPRECATED __attribute__ ((deprecated))
- # else
- # define LIBHERDSTAT_DEPRECATED
-@@ -43,7 +43,7 @@
- #endif
-
- #ifndef LIBHERDSTAT_UNUSED
--# if defined(__GNUC__) || defined(DOXYGEN)
-+# if defined(HAVE_ATTR_UNUSED) || defined(DOXYGEN)
- # define LIBHERDSTAT_UNUSED __attribute__ ((unused))
- # else
- # define LIBHERDSTAT_UNUSED
-Index: herdstat/fetcher/impmap.cc
-===================================================================
---- herdstat/fetcher/impmap.cc (revision 223)
-+++ herdstat/fetcher/impmap.cc (revision 224)
-@@ -24,6 +24,8 @@
- # include "config.h"
- #endif
-
-+#include <cassert>
-+
- #include <herdstat/fetcher/curlfetcher.hh>
- #include <herdstat/fetcher/wgetfetcher.hh>
- #include <herdstat/fetcher/impmap.hh>
-Index: herdstat/portage/exceptions.cc
-===================================================================
---- herdstat/portage/exceptions.cc (revision 223)
-+++ herdstat/portage/exceptions.cc (revision 224)
-@@ -24,6 +24,8 @@
- # include "config.h"
- #endif
-
-+#include <cassert>
-+
- #include <herdstat/portage/exceptions.hh>
-
- namespace herdstat {
-Index: herdstat/io/binary_stream.cc
-===================================================================
---- herdstat/io/binary_stream.cc (revision 223)
-+++ herdstat/io/binary_stream.cc (revision 224)
-@@ -24,6 +24,7 @@
- # include "config.h"
- #endif
-
-+#include <cassert>
- #include <herdstat/io/binary_stream.hh>
-
- namespace herdstat {
-Index: herdstat/util/file.hh
-===================================================================
---- herdstat/util/file.hh (revision 223)
-+++ herdstat/util/file.hh (revision 224)
-@@ -39,6 +39,7 @@
- #include <vector>
- #include <cstdlib>
- #include <cerrno>
-+#include <cassert>
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <unistd.h>
diff --git a/dev-cpp/libherdstat/libherdstat-0.2.0.ebuild b/dev-cpp/libherdstat/libherdstat-0.2.0.ebuild
deleted file mode 100644
index 8891603ddedf..000000000000
--- a/dev-cpp/libherdstat/libherdstat-0.2.0.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libherdstat/libherdstat-0.2.0.ebuild,v 1.5 2007/02/28 14:58:02 the_paya Exp $
-
-inherit eutils autotools
-
-TEST_DATA_PV="20060119"
-TEST_DATA_P="${PN/lib/}-test-data-${TEST_DATA_PV}"
-
-DESCRIPTION="C++ library offering interfaces for portage-related things such as Gentoo-specific XML files, package searching, and version sorting"
-HOMEPAGE="http://developer.berlios.de/projects/libherdstat/"
-SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2
- test? ( http://download.berlios.de/${PN}/${TEST_DATA_P}.tar.bz2 )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc curl test"
-
-RDEPEND=">=dev-libs/xmlwrapp-0.5.0
- >=dev-cpp/libebt-1.1.0
- curl? ( net-misc/curl )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-doc/doxygen )"
-RDEPEND="${RDEPEND}
- net-misc/wget"
-
-pkg_setup() {
- if has test $FEATURES && ! use test ; then
- die "FEATURES=test is set but USE=test is not; tests will fail without USE=test"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc.patch
- AT_M4DIR="${WORKDIR}"/${P}/m4 eautoreconf
-}
-
-src_compile() {
- econf \
- --disable-examples \
- --with-test-data=${WORKDIR}/${TEST_DATA_P} \
- --enable-static \
- $(use_enable debug) \
- $(use_with curl) \
- || die "econf failed"
-
- emake || die "emake failed"
-
- use doc && { emake doxygen || die "failed to build API docs" ; }
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO NEWS
-
- if use doc ; then
- dohtml -r doc/html/*
- doman doc/man/*/*.[0-9]
-
- # examples
- cp -R examples ${D}/usr/share/doc/${PF}
- # remove all Makefile's and .{dep,lib}s directories
- find ${D}/usr/share/doc/${PF}/examples \
- \( -name 'Makefile*' -or -name '.*s' \) \
- -exec rm -fr {} \; 2>/dev/null
- fi
-}