summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-09-15 15:09:14 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-09-15 15:09:14 +0000
commite5f428c4a90c15bb409ef18864f0b45cfbb35d05 (patch)
treeac28c43d0f2003ce95348802bef4966c443faf9d /dev-cpp
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-e5f428c4a90c15bb409ef18864f0b45cfbb35d05.tar.gz
gentoo-2-e5f428c4a90c15bb409ef18864f0b45cfbb35d05.tar.bz2
gentoo-2-e5f428c4a90c15bb409ef18864f0b45cfbb35d05.zip
verbump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index c06988552324..4342a21043d5 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.36 2008/08/05 12:56:49 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.37 2008/09/15 15:09:14 iluxa Exp $
+
+*sptk-3.5.8 (15 Sep 2008)
+
+ 15 Sep 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.8.ebuild:
+ Verbump
05 Aug 2008; Ulrich Mueller <ulm@gentoo.org> metadata.xml:
Add USE flag description to metadata wrt GLEP 56.
diff --git a/dev-cpp/sptk/sptk-3.5.8.ebuild b/dev-cpp/sptk/sptk-3.5.8.ebuild
new file mode 100644
index 000000000000..4b43d414b206
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2006-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.ebuild,v 1.1 2008/09/15 15:09:14 iluxa Exp $
+
+inherit eutils flag-o-matic autotools
+
+IUSE="fltk odbc doc sqlite3 excel postgres aspell"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ sed -r -i -e 's|SET \(LIBRARY_TYPE STATIC\)|SET \(LIBRARY_TYPE SHARED\)|' src/CMakeLists.txt
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}