summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-05 12:25:26 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-05 12:25:26 +0000
commitc5336e12f560657613cc0034f44d04c774c400c5 (patch)
tree6bbe6714425d8fd47eda18c00cc1da96c563108e /dev-cpp
parentdev-cpp/pstreams: Drop old (diff)
downloadgentoo-2-c5336e12f560657613cc0034f44d04c774c400c5.tar.gz
gentoo-2-c5336e12f560657613cc0034f44d04c774c400c5.tar.bz2
gentoo-2-c5336e12f560657613cc0034f44d04c774c400c5.zip
dev-cpp/pstreams: Install all docs correctly, #442982; bump to EAPI=5 and use doheader
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pstreams/ChangeLog5
-rw-r--r--dev-cpp/pstreams/pstreams-0.7.0.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/dev-cpp/pstreams/ChangeLog b/dev-cpp/pstreams/ChangeLog
index 7904bbfad3fa..21b0250d7bcf 100644
--- a/dev-cpp/pstreams/ChangeLog
+++ b/dev-cpp/pstreams/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/pstreams
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.3 2012/12/05 12:17:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.4 2012/12/05 12:25:26 jlec Exp $
+
+ 05 Dec 2012; Justin Lecher <jlec@gentoo.org> pstreams-0.7.0.ebuild:
+ Install all docs correctly, #442982; bump to EAPI=5 and use doheader
05 Dec 2012; Justin Lecher <jlec@gentoo.org> -pstreams-0.48.ebuild:
Drop old
diff --git a/dev-cpp/pstreams/pstreams-0.7.0.ebuild b/dev-cpp/pstreams/pstreams-0.7.0.ebuild
index 97786d528e5a..e64bebfd2345 100644
--- a/dev-cpp/pstreams/pstreams-0.7.0.ebuild
+++ b/dev-cpp/pstreams/pstreams-0.7.0.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/pstreams-0.7.0.ebuild,v 1.1 2010/05/18 20:31:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/pstreams-0.7.0.ebuild,v 1.2 2012/12/05 12:25:26 jlec Exp $
+
+EAPI=5
inherit toolchain-funcs
@@ -11,16 +13,17 @@ SRC_URI="
doc? ( mirror://sourceforge/${PN}/${PN}-docs-${PV}.tar.gz )"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
LICENSE="LGPL-3"
IUSE="doc"
+KEYWORDS="~amd64 ~x86"
RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
src_compile() {
if use doc; then
- emake || die
+ doxygen -u || die
+ emake
fi
}
@@ -32,12 +35,9 @@ src_test() {
}
src_install() {
- insinto /usr/include
- doins pstream.h || die
+ doheader pstream.h
- dodoc AUTHORS ChangeLog README || die
+ dodoc AUTHORS ChangeLog README
- if use doc; then
- dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/* -R
- fi
+ use doc && dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/*
}