summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-08-02 10:13:14 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-08-02 10:13:14 +0000
commitbbaf54c0c2aaf4ab96362e5f2343455269a78118 (patch)
treec5e6459913999fc2026d63bae793837ba702df3b /dev-cpp
parentVersion bump. Fix system plugin lookup, bug #279417. Clean up old revisions. (diff)
downloadgentoo-2-bbaf54c0c2aaf4ab96362e5f2343455269a78118.tar.gz
gentoo-2-bbaf54c0c2aaf4ab96362e5f2343455269a78118.tar.bz2
gentoo-2-bbaf54c0c2aaf4ab96362e5f2343455269a78118.zip
Version bump. Build fixes.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog8
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.26.1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index c4e5535918d0..69f321fcf946 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.87 2009/05/10 22:26:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.88 2009/08/02 10:13:14 eva Exp $
+
+*libxmlpp-2.26.1 (02 Aug 2009)
+
+ 02 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +libxmlpp-2.26.1.ebuild:
+ Version bump. Build fixes.
*libxmlpp-2.26.0 (10 May 2009)
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.26.1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.26.1.ebuild
new file mode 100644
index 000000000000..8131e5b0e1fd
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.26.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.26.1.ebuild,v 1.1 2009/08/02 10:13:14 eva Exp $
+
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # don't waste time building the examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${D}"/usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}