summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-08-02 17:17:30 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-08-02 17:17:30 +0000
commit984a8bc2f4d4f0e3586a19e7e1cb70056b3e8b3a (patch)
tree2b309ce2d977520d61d878ff3bfae152d6c773b3 /dev-cpp
parentRemoved old. (diff)
downloadgentoo-2-984a8bc2f4d4f0e3586a19e7e1cb70056b3e8b3a.tar.gz
gentoo-2-984a8bc2f4d4f0e3586a19e7e1cb70056b3e8b3a.tar.bz2
gentoo-2-984a8bc2f4d4f0e3586a19e7e1cb70056b3e8b3a.zip
Version bump, switched to EAPI4
(Portage version: 2.1.10.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tbb/ChangeLog7
-rw-r--r--dev-cpp/tbb/tbb-3.0.221.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 0d9d6fe5229d..55244ef1e571 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.12 2011/05/31 21:34:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.13 2011/08/02 17:17:30 bicatali Exp $
+
+*tbb-3.0.221 (02 Aug 2011)
+
+ 02 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> +tbb-3.0.221.ebuild:
+ Version bump, switched to EAPI4
*tbb-3.0.196 (31 May 2011)
diff --git a/dev-cpp/tbb/tbb-3.0.221.ebuild b/dev-cpp/tbb/tbb-3.0.221.ebuild
new file mode 100644
index 000000000000..36a20ff9e06c
--- /dev/null
+++ b/dev-cpp/tbb/tbb-3.0.221.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.221.ebuild,v 1.1 2011/08/02 17:17:30 bicatali Exp $
+
+EAPI=4
+inherit eutils versionator toolchain-funcs
+
+# those 2 below change pretty much every release
+# url number
+MYU="78/172"
+# release update
+MYR="%20update%208"
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}${MYR}/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+DEPEND="!<=dev-cpp/tbb-2.1.016"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.104-tests.patch
+ # use fully qualified compilers. do not force pentium4 for x86 users
+ local CC="$(tc-getCC)"
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ -e 's/^\(CPLUS = \)g++ $/\1'"$(tc-getCXX)/" \
+ -e 's/^\(CONLY = \)gcc$/\1'"${CC}/" \
+ -e 's/\(shell \)gcc\( --version\)/\1'"${CC}"'\2/' \
+ -e '/CPLUS_FLAGS +=/s/-march=pentium4//' \
+ build/*.inc || die
+ # - Strip the $(shell ... >$(NUL) 2>$(NUL)) wrapping, leaving just the
+ # actual command.
+ # - Force generation of version_string.tmp immediately after the directory
+ # is created. This avoids a race when the user builds tbb and tbbmalloc
+ # concurrently. The choice of Makefile.tbb (instead of
+ # Makefile.tbbmalloc) is arbitrary.
+ sed -i \
+ -e 's/^\t\$(shell \(.*\) >\$(NUL) 2>\$(NUL))\s*/\t\1/' \
+ -e 's!^\t@echo Created \$(work_dir)_\(debug\|release\).*$!&\n\t$(MAKE) -C "$(work_dir)_\1" -r -f $(tbb_root)/build/Makefile.tbb cfg=\1 tbb_root=$(tbb_root) version_string.tmp!' \
+ src/Makefile || die
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++ ]]; then
+ myconf="compiler=gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ myconf="compiler=icc"
+ fi
+ local ccconf="${myconf}"
+ if use debug || use examples; then
+ ccconf="${ccconf} tbb_debug tbbmalloc_debug"
+ fi
+ emake -C src ${ccconf} tbb_release tbbmalloc_release
+}
+
+src_test() {
+ local ccconf="${myconf}"
+ if use debug || use examples; then
+ ${ccconf}="${myconf} test_debug tbbmalloc_test_debug"
+ fi
+ emake -C src ${ccconf} test_release
+}
+
+src_install(){
+ for l in $(find build -name lib\*.so.\*); do
+ dolib.so ${l}
+ local bl=$(basename ${l})
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ insinto /usr
+ doins -r include
+
+ dodoc README CHANGES doc/Release_Notes.txt
+ use doc && dohtml -r doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples
+ fi
+}