summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2011-05-23 13:48:26 +0000
committerIlya Volynets <iluxa@gentoo.org>2011-05-23 13:48:26 +0000
commit7a861101020e38abfeff8561f587e0bb12ca5f0e (patch)
tree6689b59100faa7cee0223ceda9503a769b5336fe /dev-cpp
parentStable on amd64 wrt bug #368239 (diff)
downloadgentoo-2-7a861101020e38abfeff8561f587e0bb12ca5f0e.tar.gz
gentoo-2-7a861101020e38abfeff8561f587e0bb12ca5f0e.tar.bz2
gentoo-2-7a861101020e38abfeff8561f587e0bb12ca5f0e.zip
Verbump SPTK to 4.11
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog7
-rw-r--r--dev-cpp/sptk/sptk-4.11.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 5e3e92717934..f6ce40d8971d 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.72 2011/03/20 20:19:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.73 2011/05/23 13:48:26 iluxa Exp $
+
+*sptk-4.11 (23 May 2011)
+
+ 23 May 2011; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org> +sptk-4.11.ebuild:
+ Verbump to 4.11
20 Mar 2011; Justin Lecher <jlec@gentoo.org> sptk-3.5.8.10.ebuild,
sptk-3.5.8.14.ebuild, sptk-3.5.8.14-r1.ebuild, sptk-4.00.ebuild,
diff --git a/dev-cpp/sptk/sptk-4.11.ebuild b/dev-cpp/sptk/sptk-4.11.ebuild
new file mode 100644
index 000000000000..78f23aab5e2c
--- /dev/null
+++ b/dev-cpp/sptk/sptk-4.11.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-4.11.ebuild,v 1.1 2011/05/23 13:48:26 iluxa Exp $
+
+EAPI=1
+
+inherit cmake-utils eutils
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="4"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="fltk odbc doc sqlite excel postgres aspell mysql gnutls"
+
+RDEPEND="
+ aspell? ( >=app-text/aspell-0.50 )
+ fltk? ( x11-libs/fltk:1 )
+ gnutls? ( net-libs/gnutls )
+ mysql? ( virtual/mysql )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ postgres? ( >=dev-db/postgresql-base-8.0 )
+ sqlite? ( >=dev-db/sqlite-3 )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ local mycmakeargs="$(cmake-utils_use_no postgres POSTGRESQL)
+ $(cmake-utils_use_no mysql MYSQL)
+ $(cmake-utils_use_no sqlite SQLITE3)
+ $(cmake-utils_use_no odbc ODBC)
+ $(cmake-utils_use_no aspell ASPELL)
+ $(cmake-utils_use_no fltk FLTK)
+ $(cmake-utils_use_no excel EXCEL)
+ $(cmake-utils_use_no gnutls TLS)"
+
+ mycmakeargs="${mycmakeargs} -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} -DNO_EXAMPLES:BOOLEAN=TRUE"
+
+ cmake-utils_src_configure
+
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+}
+
+src_install () {
+ DOCS="README AUTHORS"
+ cmake-utils_src_install
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+ [ -f mv "${D}/usr/bin/sql2cpp.pl" ] && mv "${D}/usr/bin/sql2cpp.pl" "${D}/usr/bin/sql2cpp"
+}