summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-15 12:51:53 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-15 12:51:53 +0000
commit77fd4cbe49d9bd03b62fde18ef6db099d5b40fee (patch)
treebeb10442c82fcc70b7e988bb94d16e5d20c9a641 /dev-cpp
parentRevert documentation change as it causes breakage, bug #336928. Sorry a lot f... (diff)
downloadgentoo-2-77fd4cbe49d9bd03b62fde18ef6db099d5b40fee.tar.gz
gentoo-2-77fd4cbe49d9bd03b62fde18ef6db099d5b40fee.tar.bz2
gentoo-2-77fd4cbe49d9bd03b62fde18ef6db099d5b40fee.zip
Revision bump directly to stable to apply previous changes as talked with leio on IRC.
(Portage version: 2.1.8.3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/glibmm/ChangeLog8
-rw-r--r--dev-cpp/glibmm/glibmm-2.24.2-r1.ebuild65
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-cpp/glibmm/ChangeLog b/dev-cpp/glibmm/ChangeLog
index 24661bbbc3b2..cfcda53d8d1c 100644
--- a/dev-cpp/glibmm/ChangeLog
+++ b/dev-cpp/glibmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/glibmm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.154 2010/09/15 12:48:23 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/ChangeLog,v 1.155 2010/09/15 12:51:53 pacho Exp $
+
+*glibmm-2.24.2-r1 (15 Sep 2010)
+
+ 15 Sep 2010; Pacho Ramos <pacho@gentoo.org> +glibmm-2.24.2-r1.ebuild:
+ Revision bump directly to stable to apply previous changes as talked with
+ leio on IRC.
15 Sep 2010; Pacho Ramos <pacho@gentoo.org> glibmm-2.24.2.ebuild:
Revert documentation change as it causes breakage, bug #336928. Sorry a
diff --git a/dev-cpp/glibmm/glibmm-2.24.2-r1.ebuild b/dev-cpp/glibmm/glibmm-2.24.2-r1.ebuild
new file mode 100644
index 000000000000..7e8f732b7c4b
--- /dev/null
+++ b/dev-cpp/glibmm/glibmm-2.24.2-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.24.2-r1.ebuild,v 1.1 2010/09/15 12:51:53 pacho Exp $
+
+EAPI="3"
+inherit gnome2
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="|| ( LGPL-2.1 GPL-2 )"
+SLOT="2"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-libs/libsigc++-2.2
+ >=dev-libs/glib-2.24.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+# We cannot set this just now as it causes breakage, bug #336928
+#pkg_setup() {
+# G2CONF="${G2CONF} $(use_enable doc documentation)"
+#}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed 2 failed"
+ fi
+}
+
+src_test() {
+ cd "${S}/tests/"
+ emake check || die "emake check failed"
+
+ for i in */test; do
+ ${i} || die "Running tests failed at ${i}"
+ done
+}
+
+src_install() {
+ gnome2_src_install
+
+ if ! use doc && ! use examples; then
+ rm -fr "${ED}usr/share/doc/glibmm*"
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+ dodoc examples
+ fi
+}