summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-01-02 01:37:51 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-01-02 01:37:51 +0000
commit77e225ba9692a81de02f79653163052a301b5c4d (patch)
treef67ffdd93ddd4d09495a9155909e25978bc8ed26 /dev-cpp
parentoptimize memory/string usage a bit more (diff)
downloadgentoo-2-77e225ba9692a81de02f79653163052a301b5c4d.tar.gz
gentoo-2-77e225ba9692a81de02f79653163052a301b5c4d.tar.bz2
gentoo-2-77e225ba9692a81de02f79653163052a301b5c4d.zip
Add patch to fix building with gcc-4.3. Thanks to Marek Cruz <programatorfreez AT gmail DOT com>; bug #248922
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-rc5 i686)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gccxml/ChangeLog9
-rw-r--r--dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch21
-rw-r--r--dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild19
3 files changed, 38 insertions, 11 deletions
diff --git a/dev-cpp/gccxml/ChangeLog b/dev-cpp/gccxml/ChangeLog
index 03cfb13eefc0..02d3dbf62ba8 100644
--- a/dev-cpp/gccxml/ChangeLog
+++ b/dev-cpp/gccxml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gccxml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/ChangeLog,v 1.22 2008/06/07 16:57:59 dev-zero Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/ChangeLog,v 1.23 2009/01/02 01:37:51 halcy0n Exp $
+
+ 02 Jan 2009; Mark Loeser <halcy0n@gentoo.org>
+ +files/gccxml-0.6.0-gcc43.patch, gccxml-0.6.0-r1.ebuild:
+ Add patch to fix building with gcc-4.3. Thanks to Marek Cruz
+ <programatorfreez AT gmail DOT com>; bug #248922
*gccxml-0.9.0_pre20080607 (07 Jun 2008)
diff --git a/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch b/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch
new file mode 100644
index 000000000000..ed65ca2758a9
--- /dev/null
+++ b/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch
@@ -0,0 +1,21 @@
+--- GCC_XML/GXFront/gxConfiguration.cxx 2004-01-22 22:51:36.000000000 +0100
++++ GCC_XML/GXFront/gxConfiguration.cxx 2008-11-26 18:17:34.000000000 +0100
+@@ -15,6 +15,7 @@
+
+ =========================================================================*/
+ #include "gxConfiguration.h"
++#include <cstring>
+
+ //----------------------------------------------------------------------------
+ const char* gxConfigurationVc6Registry =
+--- GCC_XML/KWSys/SystemTools.cxx 2004-01-22 16:30:01.000000000 +0100
++++ GCC_XML/KWSys/SystemTools.cxx 2008-11-26 18:16:53.000000000 +0100
+@@ -17,6 +17,7 @@
+
+ #include KWSYS_HEADER(ios/iostream)
+ #include KWSYS_HEADER(ios/fstream)
++#include <cstring>
+
+ #ifdef _MSC_VER
+ # pragma warning (disable: 4786)
+
diff --git a/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild b/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild
index 152dadd91594..c18642f32c2a 100644
--- a/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild
+++ b/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild,v 1.6 2007/02/11 11:20:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild,v 1.7 2009/01/02 01:37:51 halcy0n Exp $
inherit versionator eutils
PVM="$(get_version_component_range 1-2)"
@@ -16,20 +16,21 @@ IUSE=""
DEPEND="dev-util/cmake"
RDEPEND=""
-MYBUILDDIR=${WORKDIR}/build
+MYBUILDDIR="${WORKDIR}"/build
src_unpack() {
- mkdir ${MYBUILDDIR}
+ mkdir "${MYBUILDDIR}"
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/obstack.h.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/obstack.h.diff
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {
- cd ${MYBUILDDIR}
+ cd "${MYBUILDDIR}"
cmake ../${P} -DCMAKE_INSTALL_PREFIX:PATH=/usr || die "cmake failed"
emake || die "emake failed"
}
src_install() {
- cd ${MYBUILDDIR}
- make DESTDIR=${D} install || die
+ cd "${MYBUILDDIR}"
+ make DESTDIR="${D}" install || die
}