summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-04-20 12:30:29 +0000
committerPacho Ramos <pacho@gentoo.org>2011-04-20 12:30:29 +0000
commit7536b33b027e85011bb9d1023160c4c2686bffa9 (patch)
tree8404ab95e09d2b59c6f35d628a350d15a30b5453 /dev-cpp
parentAdded minimal use flag to virtual/mysql ebuilds. (diff)
downloadgentoo-2-7536b33b027e85011bb9d1023160c4c2686bffa9.tar.gz
gentoo-2-7536b33b027e85011bb9d1023160c4c2686bffa9.tar.bz2
gentoo-2-7536b33b027e85011bb9d1023160c4c2686bffa9.zip
Version bump including upstream fixes to not require mm-common at buildtime ever. Remove old.
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog9
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild (renamed from dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild)19
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index f386398897a0..c6f72a2e91e6 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.107 2011/04/14 17:55:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.108 2011/04/20 12:30:29 pacho Exp $
+
+*libxmlpp-2.34.1 (20 Apr 2011)
+
+ 20 Apr 2011; Pacho Ramos <pacho@gentoo.org> -libxmlpp-2.33.2.ebuild,
+ +libxmlpp-2.34.1.ebuild:
+ Version bump including upstream fixes to not require mm-common at buildtime
+ ever. Remove old.
14 Apr 2011; Pacho Ramos <pacho@gentoo.org> libxmlpp-2.32.0-r1.ebuild,
libxmlpp-2.33.2.ebuild:
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild
index e4ea3455aa95..bb86048cc496 100644
--- a/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild
+++ b/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.33.2.ebuild,v 1.3 2011/04/14 17:55:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild,v 1.1 2011/04/20 12:30:29 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
-inherit gnome2 autotools
+inherit gnome2
MY_PN="${PN/pp/++}"
MY_P="${MY_PN}-${PV}"
@@ -23,12 +23,8 @@ IUSE="doc"
RDEPEND=">=dev-libs/libxml2-2.6.1
>=dev-cpp/glibmm-2.4"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( || (
- <dev-cpp/glibmm-2.27.97:2[doc?]
- >=dev-cpp/mm-common-0.9.3
- ) )
-"
+ dev-util/pkgconfig"
+
pkg_setup() {
G2CONF="${G2CONF} $(use_enable doc documentation)"
DOCS="AUTHORS ChangeLog NEWS README*"
@@ -40,13 +36,6 @@ src_prepare() {
# don't waste time building the examples
sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
-i Makefile.am Makefile.in || die "sed Makefile.in failed"
-
- # doc-install.pl was removed from glibmm, and is provided by mm-common now
- # This should not be needed if the tarball is generated with mm-common-0.9.3
- if use doc && has_version '>=dev-cpp/glibmm-2.27.97'; then
- mm-common-prepare --copy --force
- eautoreconf
- fi
}
src_install() {