summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-19 13:55:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-19 13:55:46 +0000
commit742e7f5e0c19ea5ce3e40b06db14ac4069a8b235 (patch)
tree4132ee69aff32ff1f3b69672b3029426e7cc6423 /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-742e7f5e0c19ea5ce3e40b06db14ac4069a8b235.tar.gz
gentoo-2-742e7f5e0c19ea5ce3e40b06db14ac4069a8b235.tar.bz2
gentoo-2-742e7f5e0c19ea5ce3e40b06db14ac4069a8b235.zip
Version bumped.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/rudiments/ChangeLog9
-rw-r--r--dev-cpp/rudiments/rudiments-0.32.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-cpp/rudiments/ChangeLog b/dev-cpp/rudiments/ChangeLog
index 4141def0e25f..b18f294c362e 100644
--- a/dev-cpp/rudiments/ChangeLog
+++ b/dev-cpp/rudiments/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/rudiments
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/ChangeLog,v 1.12 2008/04/04 01:10:49 halcy0n Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/ChangeLog,v 1.13 2009/05/19 13:55:46 matsuu Exp $
+
+*rudiments-0.32 (19 May 2009)
+
+ 19 May 2009; MATSUU Takuto <matsuu@gentoo.org> +rudiments-0.32.ebuild:
+ Version bumped.
*rudiments-0.31 (04 Apr 2008)
diff --git a/dev-cpp/rudiments/rudiments-0.32.ebuild b/dev-cpp/rudiments/rudiments-0.32.ebuild
new file mode 100644
index 000000000000..53c0ec95710a
--- /dev/null
+++ b/dev-cpp/rudiments/rudiments-0.32.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/rudiments-0.32.ebuild,v 1.1 2009/05/19 13:55:46 matsuu Exp $
+
+DESCRIPTION="C++ class library for daemons, clients and servers"
+HOMEPAGE="http://rudiments.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rudiments/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug pcre ssl"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # It's a buggy configure-script
+ # We can only disable, but not enable
+ local options
+ use pcre || options="${options} --disable-pcre"
+ use ssl || options="${options} --disable-ssl"
+ econf \
+ $(use_enable debug) \
+ ${options} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}/html" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}