summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-02-26 12:38:44 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-02-26 12:38:44 +0000
commit42d35147743c8afaa25f7cfc49bf1e2bad80245c (patch)
tree8113131e98c661e4a5d53da8b410de36c0383142 /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-42d35147743c8afaa25f7cfc49bf1e2bad80245c.tar.gz
gentoo-2-42d35147743c8afaa25f7cfc49bf1e2bad80245c.tar.bz2
gentoo-2-42d35147743c8afaa25f7cfc49bf1e2bad80245c.zip
Add SPTK-3.5.7.05
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog10
-rw-r--r--dev-cpp/sptk/sptk-3.5.7.05.ebuild76
2 files changed, 84 insertions, 2 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 14affd56f62b..a6a38251585c 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.26 2007/11/17 18:50:16 iluxa Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.27 2008/02/26 12:38:44 iluxa Exp $
+
+*sptk-3.5.7.05 (26 Feb 2008)
+
+ 26 Feb 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.7.05.ebuild:
+ Add SPTK 3.5.7.05
17 Nov 2007; <ilya@gentoo.org> sptk-3.5.6.ebuild:
Build SPTK as shared libraries
diff --git a/dev-cpp/sptk/sptk-3.5.7.05.ebuild b/dev-cpp/sptk/sptk-3.5.7.05.ebuild
new file mode 100644
index 000000000000..b3040563182d
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.7.05.ebuild
@@ -0,0 +1,76 @@
+# Copyright 2006-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.7.05.ebuild,v 1.1 2008/02/26 12:38:44 iluxa Exp $
+
+inherit eutils flag-o-matic autotools
+
+IUSE="fltk odbc doc sqlite3 excel postgres aspell"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="dev-util/cmake
+ fltk? ( >=x11-libs/fltk-1.1.6 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ postgres? ( >=dev-db/libpq-8.0 )
+ aspell? ( >=app-text/aspell-0.50 )
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ sed -r -i -e 's|SET \(LIBRARY_TYPE STATIC\)|SET \(LIBRARY_TYPE SHARED\)|' src/CMakeLists.txt
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}