summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-03-16 18:56:21 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-03-16 18:56:21 +0000
commit3e36a5d4dd226487eb8739347e6f5efcccd68229 (patch)
tree9a5bd9fa1a6fa9bd160fa9cb59cd27dce1396d03 /dev-cpp
parentBump (diff)
downloadgentoo-2-3e36a5d4dd226487eb8739347e6f5efcccd68229.tar.gz
gentoo-2-3e36a5d4dd226487eb8739347e6f5efcccd68229.tar.bz2
gentoo-2-3e36a5d4dd226487eb8739347e6f5efcccd68229.zip
Move cmake call to src_compile, per #261975
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog6
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.10.ebuild7
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 2f872a630e77..0c95e60c023a 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.53 2009/03/10 12:53:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.54 2009/03/16 18:56:21 iluxa Exp $
+
+ 16 Mar 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ sptk-3.5.8.10.ebuild:
+ Move cmake call to src_compile, per #261975
10 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
sptk-3.5.8.10.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.10.ebuild b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
index e08772b751a2..6d832a27dc73 100644
--- a/dev-cpp/sptk/sptk-3.5.8.10.ebuild
+++ b/dev-cpp/sptk/sptk-3.5.8.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 2006-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.10.ebuild,v 1.2 2009/03/10 12:53:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.10.ebuild,v 1.3 2009/03/16 18:56:21 iluxa Exp $
EAPI=1
@@ -38,7 +38,9 @@ sptk_use_enable() {
src_unpack() {
unpack ${A}
cd "${S}"
+}
+src_compile() {
sptk_use_enable examples EXAMPLES
sptk_use_enable postgres POSTGRESQL
sptk_use_enable mysql MYSQL
@@ -49,9 +51,6 @@ src_unpack() {
sptk_use_enable excel EXCEL
cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} . || die "Configuration Failed"
-}
-
-src_compile() {
emake || die "Parallel Make Failed"