summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-07-14 12:04:39 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-07-14 12:04:39 +0000
commit32abcda9cdab3992db77e403d96e8af00711f890 (patch)
treeeefa45a95f4604d18e225644bda16b34f99c2d94 /dev-cpp
parentUpdated patch. (diff)
downloadgentoo-2-32abcda9cdab3992db77e403d96e8af00711f890.tar.gz
gentoo-2-32abcda9cdab3992db77e403d96e8af00711f890.tar.bz2
gentoo-2-32abcda9cdab3992db77e403d96e8af00711f890.zip
First patch released
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ice/ChangeLog9
-rw-r--r--dev-cpp/ice/files/digest-ice-3.1.0-r13
-rw-r--r--dev-cpp/ice/files/ice-3.1-patches/GCCountMap.h24
-rwxr-xr-xdev-cpp/ice/files/ice-3.1-patches/GCShared.h71
-rw-r--r--dev-cpp/ice/files/ice-3.1-patches/ObjectF.h40
-rw-r--r--dev-cpp/ice/ice-3.1.0-r1.ebuild61
6 files changed, 207 insertions, 1 deletions
diff --git a/dev-cpp/ice/ChangeLog b/dev-cpp/ice/ChangeLog
index 6def47eed49e..2109cf34d54b 100644
--- a/dev-cpp/ice/ChangeLog
+++ b/dev-cpp/ice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/ice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.7 2006/07/13 01:13:39 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.8 2006/07/14 12:04:39 caleb Exp $
+
+*ice-3.1.0-r1 (14 Jul 2006)
+
+ 14 Jul 2006; Caleb Tennis <caleb@gentoo.org>
+ +files/ice-3.1-patches/GCCountMap.h, +files/ice-3.1-patches/GCShared.h,
+ +files/ice-3.1-patches/ObjectF.h, +ice-3.1.0-r1.ebuild:
+ Revbump to include the first patch release
*ice-3.1.0 (13 Jul 2006)
diff --git a/dev-cpp/ice/files/digest-ice-3.1.0-r1 b/dev-cpp/ice/files/digest-ice-3.1.0-r1
new file mode 100644
index 000000000000..ba729b9d94a3
--- /dev/null
+++ b/dev-cpp/ice/files/digest-ice-3.1.0-r1
@@ -0,0 +1,3 @@
+MD5 f37f7c6c1de570a5782f61430557ef4e Ice-3.1.0.tar.gz 2110940
+RMD160 e65fd990a77938d8e35b425cf9e6cc59a912a3ee Ice-3.1.0.tar.gz 2110940
+SHA256 c2de63f99d881ce0229f5cc10e0936f2bb4e7257a74220f5eec74712425f7ac4 Ice-3.1.0.tar.gz 2110940
diff --git a/dev-cpp/ice/files/ice-3.1-patches/GCCountMap.h b/dev-cpp/ice/files/ice-3.1-patches/GCCountMap.h
new file mode 100644
index 000000000000..8d14f43c3815
--- /dev/null
+++ b/dev-cpp/ice/files/ice-3.1-patches/GCCountMap.h
@@ -0,0 +1,24 @@
+// **********************************************************************
+//
+// Copyright (c) 2003-2006 ZeroC, Inc. All rights reserved.
+//
+// This copy of Ice is licensed to you under the terms described in the
+// ICE_LICENSE file included in this distribution.
+//
+// **********************************************************************
+
+#ifndef ICE_GCCOUNTMAP_H
+#define ICE_GCCOUNTMAP_H
+
+#include <map>
+
+namespace IceInternal
+{
+
+class GCShared;
+
+typedef ::std::map<GCShared*, int> GCCountMap;
+
+}
+
+#endif
diff --git a/dev-cpp/ice/files/ice-3.1-patches/GCShared.h b/dev-cpp/ice/files/ice-3.1-patches/GCShared.h
new file mode 100755
index 000000000000..863084267d63
--- /dev/null
+++ b/dev-cpp/ice/files/ice-3.1-patches/GCShared.h
@@ -0,0 +1,71 @@
+// **********************************************************************
+//
+// Copyright (c) 2003-2006 ZeroC, Inc. All rights reserved.
+//
+// This copy of Ice is licensed to you under the terms described in the
+// ICE_LICENSE file included in this distribution.
+//
+// **********************************************************************
+
+#ifndef ICE_GC_SHARED_H
+#define ICE_GC_SHARED_H
+
+#include <IceUtil/Config.h>
+#include <Ice/GCRecMutex.h>
+#include <Ice/GCCountMap.h>
+#include <set>
+
+namespace IceInternal
+{
+
+class GC;
+class GCShared;
+
+typedef std::set<GCShared*> GCObjectSet;
+extern ICE_API GCObjectSet gcObjects; // Set of pointers to all existing classes with class data members.
+
+class ICE_API GCShared
+{
+public:
+
+ GCShared();
+ GCShared(const GCShared&);
+ virtual ~GCShared() {}
+
+ GCShared& operator=(const GCShared&)
+ {
+ return *this;
+ }
+
+ virtual void __incRef(); // First derived class with class data members overrides this.
+ virtual void __decRef(); // Ditto.
+ virtual void __addObject(GCCountMap&) {} // Ditto.
+ virtual bool __usesClasses() { return false; } // Ditto.
+
+ virtual int __getRef() const;
+ virtual void __setNoDelete(bool);
+
+ virtual void __gcReachable(GCCountMap&) const = 0;
+ virtual void __gcClear() = 0;
+
+ int __getRefUnsafe() const
+ {
+ return _ref;
+ }
+
+ void __decRefUnsafe()
+ {
+ --_ref;
+ }
+
+protected:
+
+ int _ref;
+ bool _noDelete;
+
+ friend class IceInternal::GC; // Allows IceInternal::GC to read value of _ref.
+};
+
+}
+
+#endif
diff --git a/dev-cpp/ice/files/ice-3.1-patches/ObjectF.h b/dev-cpp/ice/files/ice-3.1-patches/ObjectF.h
new file mode 100644
index 000000000000..c6b40780fa30
--- /dev/null
+++ b/dev-cpp/ice/files/ice-3.1-patches/ObjectF.h
@@ -0,0 +1,40 @@
+// **********************************************************************
+//
+// Copyright (c) 2003-2006 ZeroC, Inc. All rights reserved.
+//
+// This copy of Ice is licensed to you under the terms described in the
+// ICE_LICENSE file included in this distribution.
+//
+// **********************************************************************
+
+#ifndef ICE_OBJECT_F_H
+#define ICE_OBJECT_F_H
+
+#include <Ice/Handle.h>
+#include <Ice/GCCountMap.h>
+
+namespace Ice
+{
+
+class Object;
+
+}
+
+namespace IceInternal
+{
+
+ICE_API void incRef(::Ice::Object*);
+ICE_API void decRef(::Ice::Object*);
+
+}
+
+namespace Ice
+{
+
+typedef IceInternal::Handle< Object > ObjectPtr;
+
+void ICE_API __patch__ObjectPtr(void*, ObjectPtr&);
+
+}
+
+#endif
diff --git a/dev-cpp/ice/ice-3.1.0-r1.ebuild b/dev-cpp/ice/ice-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..1b6a111e5d1d
--- /dev/null
+++ b/dev-cpp/ice/ice-3.1.0-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.1.0-r1.ebuild,v 1.1 2006/07/14 12:04:39 caleb Exp $
+
+inherit eutils
+
+MY_P=${PN/i/I}-${PV}
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.1/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ncurses test debug"
+
+DEPEND="ncurses? ( sys-libs/ncurses
+ sys-libs/readline )
+ test? ( >=dev-lang/python-2.2 )
+ =sys-libs/db-4.3.29
+ >=dev-libs/openssl-0.9.7"
+RDEPEND=">=dev-libs/expat-1.9
+ >=app-arch/bzip2-1.0"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ built_with_use sys-libs/db nocxx && die "DB must be compiled with C++ support!"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ cp ${FILESDIR}/ice-3.1-patches/*.h ${S}/include/Ice
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use ncurses; then
+ sed -i -e "s# USE_READLINE.*# USE_READLINE := no#g" \
+ ${S}/config/Make.rules || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed!"
+}