summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-11 08:21:33 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-11 08:21:33 +0000
commit317f7519b0e37b59f360151060da4afb37da53f3 (patch)
tree64d2a7b183f6a2e12da6cc7992ffc5d126160f4f /dev-cpp
parentAdd patch to respect LINGUAS (bug #402677, thanks to Piotr Szymaniak for repo... (diff)
downloadgentoo-2-317f7519b0e37b59f360151060da4afb37da53f3.tar.gz
gentoo-2-317f7519b0e37b59f360151060da4afb37da53f3.tar.bz2
gentoo-2-317f7519b0e37b59f360151060da4afb37da53f3.zip
Version bump.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ctemplate/ChangeLog7
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index fc1826bf1f87..5d360c4e3f86 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.18 2012/02/11 05:11:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.19 2012/02/11 08:21:33 radhermit Exp $
+
+*ctemplate-2.0 (11 Feb 2012)
+
+ 11 Feb 2012; Tim Harder <radhermit@gentoo.org> +ctemplate-2.0.ebuild:
+ Version bump.
11 Feb 2012; Mike Frysinger <vapier@gentoo.org> ctemplate-1.0.ebuild:
Add some arm love.
diff --git a/dev-cpp/ctemplate/ctemplate-2.0.ebuild b/dev-cpp/ctemplate/ctemplate-2.0.ebuild
new file mode 100644
index 000000000000..f4f0e82403d7
--- /dev/null
+++ b/dev-cpp/ctemplate/ctemplate-2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-2.0.ebuild,v 1.1 2012/02/11 08:21:33 radhermit Exp $
+
+EAPI="4"
+
+inherit elisp-common python
+
+DESCRIPTION="A simple but powerful template language for C++"
+HOMEPAGE="http://code.google.com/p/ctemplate/"
+SRC_URI="http://ctemplate.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax static-libs test"
+
+DEPEND="test? ( =dev-lang/python-2* )"
+RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
+ emacs? ( virtual/emacs )"
+
+SITEFILE="70ctemplate-gentoo.el"
+
+pkg_setup() {
+ if use test ; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile contrib/tpl-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Installs just every piece
+ rm -rf "${ED}/usr/share/doc"
+
+ dodoc AUTHORS ChangeLog NEWS README
+ use doc && dohtml doc/*
+
+ if use vim-syntax ; then
+ cd "${S}/contrib"
+ sh highlighting.vim || die "unpacking vim scripts failed"
+ insinto /usr/share/vim/vimfiles
+ doins -r .vim/*
+ fi
+
+ if use emacs ; then
+ cd "${S}/contrib"
+ elisp-install ${PN} tpl-mode.el tpl-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}