summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-18 20:31:41 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-18 20:31:41 +0000
commit27267a9bf9b91dd42134aa8e702711c9ddfc0e9f (patch)
tree6265727cb118ab9e70a7915bfe7ad464d686e8ab /dev-cpp
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-27267a9bf9b91dd42134aa8e702711c9ddfc0e9f.tar.gz
gentoo-2-27267a9bf9b91dd42134aa8e702711c9ddfc0e9f.tar.bz2
gentoo-2-27267a9bf9b91dd42134aa8e702711c9ddfc0e9f.zip
Initial addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pstreams/ChangeLog10
-rw-r--r--dev-cpp/pstreams/metadata.xml34
-rw-r--r--dev-cpp/pstreams/pstreams-0.7.0.ebuild43
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-cpp/pstreams/ChangeLog b/dev-cpp/pstreams/ChangeLog
new file mode 100644
index 000000000000..c49a1cc70aab
--- /dev/null
+++ b/dev-cpp/pstreams/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/pstreams
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.1 2010/05/18 20:31:41 jlec Exp $
+
+*pstreams-0.7.0 (18 May 2010)
+
+ 18 May 2010; Justin Lecher <jlec@gentoo.org> +pstreams-0.7.0.ebuild,
+ +metadata.xml:
+ Initial addition
+
diff --git a/dev-cpp/pstreams/metadata.xml b/dev-cpp/pstreams/metadata.xml
new file mode 100644
index 000000000000..971a5ca8e455
--- /dev/null
+++ b/dev-cpp/pstreams/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+$Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/metadata.xml,v 1.1 2010/05/18 20:31:41 jlec Exp $
+
+This is the example metadata file.
+The root element of this file is <pkgmetadata>. Within this element a
+number of subelements are allowed: herd, maintainer, and
+longdescription. herd is a required subelement.
+
+For a full description look at:
+http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml?part=2&chap=4
+
+
+Before committing, please remove the comments from this file. They are
+not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>@gentoo.org</email>
+<!-- <description>Description of the maintainership</description> -->
+</maintainer>
+<!-- <longdescription>Long description of the package</longdescription> -->
+<!--
+<use>
+ <flag name='flag'>Description of how USE='flag' affects this package</flag>
+ <flag name='userland_GNU'>Description of how USERLAND='GNU' affects this
+ package</flag>
+ <flag name='aspell'>Uses <pkg>app-text/aspell</pkg> for spell checking.
+ Requires an installed dictionary from <cat>app-dicts</cat></flag>
+</use>
+-->
+</pkgmetadata>
diff --git a/dev-cpp/pstreams/pstreams-0.7.0.ebuild b/dev-cpp/pstreams/pstreams-0.7.0.ebuild
new file mode 100644
index 000000000000..97786d528e5a
--- /dev/null
+++ b/dev-cpp/pstreams/pstreams-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/pstreams-0.7.0.ebuild,v 1.1 2010/05/18 20:31:41 jlec Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ wrapper for the POSIX.2 functions popen(3) and pclose(3)"
+HOMEPAGE="http://pstreams.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${PN}-docs-${PV}.tar.gz )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-3"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ if use doc; then
+ emake || die
+ fi
+}
+
+src_test() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ check
+}
+
+src_install() {
+ insinto /usr/include
+ doins pstream.h || die
+
+ dodoc AUTHORS ChangeLog README || die
+
+ if use doc; then
+ dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/* -R
+ fi
+}