summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-25 11:47:28 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-25 11:47:28 +0000
commit0df9bccc5fdf66cdf3f55e0192aa6e69382ce134 (patch)
treeb55a103b7e1bd38218897485a8203bb417542998 /dev-cpp
parentx86 stable wrt bug 168280 (diff)
downloadgentoo-2-0df9bccc5fdf66cdf3f55e0192aa6e69382ce134.tar.gz
gentoo-2-0df9bccc5fdf66cdf3f55e0192aa6e69382ce134.tar.bz2
gentoo-2-0df9bccc5fdf66cdf3f55e0192aa6e69382ce134.zip
version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libthrowable/ChangeLog8
-rw-r--r--dev-cpp/libthrowable/files/digest-libthrowable-1.0.03
-rw-r--r--dev-cpp/libthrowable/libthrowable-1.0.0.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-cpp/libthrowable/ChangeLog b/dev-cpp/libthrowable/ChangeLog
index a5c82ab38a2f..d5e9d7286cb3 100644
--- a/dev-cpp/libthrowable/ChangeLog
+++ b/dev-cpp/libthrowable/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libthrowable
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/ChangeLog,v 1.4 2007/01/26 12:58:15 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/ChangeLog,v 1.5 2007/02/25 11:47:28 opfer Exp $
+
+*libthrowable-1.0.0 (25 Feb 2007)
+
+ 25 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ +libthrowable-1.0.0.ebuild:
+ version bump
26 Jan 2007; Gustavo Zacarias <gustavoz@gentoo.org>
libthrowable-0.9.6.ebuild:
diff --git a/dev-cpp/libthrowable/files/digest-libthrowable-1.0.0 b/dev-cpp/libthrowable/files/digest-libthrowable-1.0.0
new file mode 100644
index 000000000000..2f505bf243f4
--- /dev/null
+++ b/dev-cpp/libthrowable/files/digest-libthrowable-1.0.0
@@ -0,0 +1,3 @@
+MD5 b38c72dfccb19a229bd1bdcad6cc1597 libthrowable-1.0.0.tar.bz2 275166
+RMD160 07bf59b150ccbe26adbb66dc915fad779b48dc0e libthrowable-1.0.0.tar.bz2 275166
+SHA256 d9a5e3710be3645a62ba3af711d291b72c3d2d5e73154b31131afcc5ecaafbf4 libthrowable-1.0.0.tar.bz2 275166
diff --git a/dev-cpp/libthrowable/libthrowable-1.0.0.ebuild b/dev-cpp/libthrowable/libthrowable-1.0.0.ebuild
new file mode 100644
index 000000000000..269e38c589d5
--- /dev/null
+++ b/dev-cpp/libthrowable/libthrowable-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/libthrowable-1.0.0.ebuild,v 1.1 2007/02/25 11:47:28 opfer Exp $
+
+inherit eutils
+
+DESCRIPTION="Easy error handling and debugging in C++"
+HOMEPAGE="http://libthrowable.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="threads examples"
+
+DEPEND=""
+RDEPEND=">=dev-util/pkgconfig-0.20"
+
+pkg_setup() {
+ # check if this is a recompile and if the USE flag threads has changed
+ # must be done before anything is installed!
+ if use threads; then
+ has_version dev-cpp/libthrowable && ! built_with_use dev-cpp/libthrowable threads \
+ && ewarn "You recompile with USE=threads, so remember to rebuilt all depending packages!" && epause
+ else
+ has_version dev-cpp/libthrowable && built_with_use dev-cpp/libthrowable threads \
+ && ewarn "You recompile without USE=threads, so remember to rebuilt all depending packages!" && epause
+ fi
+}
+
+src_compile() {
+ econf $(use_enable threads pthreads) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installing ${PF} failed"
+ dodoc README NEWS AUTHORS
+
+ if use examples; then
+ insinto /usr/share/doc/${PN}/examples/
+ doins examples/*
+ fi
+}
+
+pkg_postinstall() {
+ elog "Please run revdep-rebuild from app-portage/gentoolkit or rebuild"
+ elog "all depending packages yourself."
+}