summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-10 11:22:31 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-10 11:22:31 +0000
commit0dbd469da2198f7762378dd3d7eae97ef280379a (patch)
tree5abd9512dc7a023ef348167053405aa0ba893e5a /dev-cpp
parentAdd media-sound/gnaural to the tree. #128275 (diff)
downloadgentoo-2-0dbd469da2198f7762378dd3d7eae97ef280379a.tar.gz
gentoo-2-0dbd469da2198f7762378dd3d7eae97ef280379a.tar.bz2
gentoo-2-0dbd469da2198f7762378dd3d7eae97ef280379a.zip
Fix copying of internal headers to installed files. Fixes bug#434476.
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/clucene/ChangeLog7
-rw-r--r--dev-cpp/clucene/clucene-2.3.3.4-r4.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-cpp/clucene/ChangeLog b/dev-cpp/clucene/ChangeLog
index 62b55b77a745..ccafd1523bc8 100644
--- a/dev-cpp/clucene/ChangeLog
+++ b/dev-cpp/clucene/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/clucene
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.50 2012/09/08 01:51:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.51 2012/09/10 11:22:31 scarabeus Exp $
+
+*clucene-2.3.3.4-r4 (10 Sep 2012)
+
+ 10 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> +clucene-2.3.3.4-r4.ebuild:
+ Fix copying of internal headers to installed files. Fixes bug#434476.
08 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
clucene-2.3.3.4-r3.ebuild:
diff --git a/dev-cpp/clucene/clucene-2.3.3.4-r4.ebuild b/dev-cpp/clucene/clucene-2.3.3.4-r4.ebuild
new file mode 100644
index 000000000000..5afb2b1055f3
--- /dev/null
+++ b/dev-cpp/clucene/clucene-2.3.3.4-r4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/clucene-2.3.3.4-r4.ebuild,v 1.1 2012/09/10 11:22:31 scarabeus Exp $
+
+EAPI=4
+
+MY_PN="${PN}"-core
+MY_P="${MY_PN}"-"${PV}"
+
+inherit cmake-utils multilib
+
+DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++"
+HOMEPAGE="http://clucene.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clucene/${MY_P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+IUSE="debug doc static-libs"
+
+DEPEND="
+ doc? ( >=app-doc/doxygen-1.4.2 )
+"
+RDEPEND="!<app-misc/strigi-0.7.5-r3"
+
+RESTRICT="test"
+
+DOCS=(AUTHORS ChangeLog README README.PACKAGE REQUESTS)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-contrib.patch"
+ "${FILESDIR}/${P}-pkgconfig.patch"
+)
+
+src_prepare() {
+ base_src_prepare
+
+ # patch out installing bundled boost headers, we build against system one
+ sed -i \
+ -e '/ADD_SUBDIRECTORY (src\/ext)/d' \
+ CMakeLists.txt || die
+ rm -rf src/ext || die
+}
+
+src_configure() {
+ # Disabled threads: see upstream bug
+ # https://sourceforge.net/tracker/?func=detail&aid=3237301&group_id=80013&atid=558446
+ local mycmakeargs=(
+ -DENABLE_ASCII_MODE=OFF
+ -DENABLE_PACKAGING=OFF
+ -DDISABLE_MULTITHREADING=OFF
+ -DBUILD_CONTRIBS_LIB=ON
+ "-DLIB_DESTINATION=${EPREFIX}/usr/$(get_libdir)"
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_enable doc CLDOCS)
+ $(cmake-utils_use_build static-libs STATIC_LIBRARIES)
+ )
+
+ cmake-utils_src_configure
+}