summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-12-01 18:28:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-12-01 18:28:13 +0000
commit0bf732498eb70326bf2ccb6dbd178faec6973e0d (patch)
tree12f64eb25c8befd276b95e74a51ab5791b0409f7 /dev-cpp
parentamd64 stable, bug #200748. (diff)
downloadgentoo-2-0bf732498eb70326bf2ccb6dbd178faec6973e0d.tar.gz
gentoo-2-0bf732498eb70326bf2ccb6dbd178faec6973e0d.tar.bz2
gentoo-2-0bf732498eb70326bf2ccb6dbd178faec6973e0d.zip
Version bump (bug #199226)
(Portage version: 2.1.4_rc4)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/ChangeLog7
-rw-r--r--dev-cpp/asio/asio-0.3.8.ebuild51
-rw-r--r--dev-cpp/asio/files/digest-asio-0.3.83
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index e7e8fdc21b1e..236c6c8cf02c 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/asio
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.9 2007/07/12 23:17:07 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.10 2007/12/01 18:28:12 dev-zero Exp $
+
+*asio-0.3.8 (01 Dec 2007)
+
+ 01 Dec 2007; Tiziano Müller <dev-zero@gentoo.org> +asio-0.3.8.ebuild:
+ Version bump (bug #199226)
*asio-0.3.7-r1 (12 Jul 2007)
diff --git a/dev-cpp/asio/asio-0.3.8.ebuild b/dev-cpp/asio/asio-0.3.8.ebuild
new file mode 100644
index 000000000000..e3a82098c9e6
--- /dev/null
+++ b/dev-cpp/asio/asio-0.3.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-0.3.8.ebuild,v 1.1 2007/12/01 18:28:12 dev-zero Exp $
+
+inherit eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="doc examples ssl test"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.34.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use test ; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+ if use examples ; then
+ # Get rid of the object files
+ emake clean || die "emake clean failed"
+
+ insinto /usr/share/doc/${PF}
+ doins -r src/examples
+ fi
+}
+
diff --git a/dev-cpp/asio/files/digest-asio-0.3.8 b/dev-cpp/asio/files/digest-asio-0.3.8
new file mode 100644
index 000000000000..25b6053359f2
--- /dev/null
+++ b/dev-cpp/asio/files/digest-asio-0.3.8
@@ -0,0 +1,3 @@
+MD5 309d2c353392d1b7caf3bb48980c743d asio-0.3.8.tar.bz2 509783
+RMD160 2b47a071cf65730b9958dcdcd312a2a7e00441b6 asio-0.3.8.tar.bz2 509783
+SHA256 461466c6630c1025ff5a8174868967cad87500c13e5751337f4ce102eb335e7e asio-0.3.8.tar.bz2 509783