summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-17 19:35:01 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-17 19:35:01 +0000
commit028c0ccd1c59bdc07ccd5cddb402ee591b8bc518 (patch)
treea13c53b812ff1113b0652e1896885655a3988b97 /dev-cpp
parentNew version for GNOME 2.24. Port plugins and core to GIO, and port to GtkBuil... (diff)
downloadgentoo-2-028c0ccd1c59bdc07ccd5cddb402ee591b8bc518.tar.gz
gentoo-2-028c0ccd1c59bdc07ccd5cddb402ee591b8bc518.tar.bz2
gentoo-2-028c0ccd1c59bdc07ccd5cddb402ee591b8bc518.zip
New version for GNOME 2.24. A few new APIs and bug fixes.
(Portage version: 2.2_rc14/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog8
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.24.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index 245dc0610e18..7d4cf2e20e31 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.77 2008/08/10 10:43:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.78 2008/11/17 19:35:01 eva Exp $
+
+*libxmlpp-2.24.0 (17 Nov 2008)
+
+ 17 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +libxmlpp-2.24.0.ebuild:
+ New version for GNOME 2.24. A few new APIs and bug fixes.
10 Aug 2008; Markus Meier <maekke@gentoo.org> ChangeLog:
x86 stable, bug #229709
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.24.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.24.0.ebuild
new file mode 100644
index 000000000000..594cae95eb2b
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-2.24.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.24.0.ebuild,v 1.1 2008/11/17 19:35:01 eva Exp $
+
+inherit gnome2 eutils
+
+MY_PN="${PN/pp/++}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/libxml2-2.6.1
+ >=dev-cpp/glibmm-2.4"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+DOCS="AUTHORS ChangeLog NEWS README*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm -fr "${D}"/usr/share/doc/libxml++*
+ use doc && dohtml docs/reference/${PV%.*}/html/*
+}