summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-08-04 22:23:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-08-04 22:23:36 +0000
commitca0ee44a41bd0e1af1835694b99801b6a1f1268b (patch)
tree649e2ddc209de039de18b95070cc1c6f73ddbca9 /dev-cpp/tbb
parentChange =www-client/firefox-2* depend to plain www-client/firefox to fix deptree. (diff)
downloadgentoo-2-ca0ee44a41bd0e1af1835694b99801b6a1f1268b.tar.gz
gentoo-2-ca0ee44a41bd0e1af1835694b99801b6a1f1268b.tar.bz2
gentoo-2-ca0ee44a41bd0e1af1835694b99801b6a1f1268b.zip
Version bump. Disabled buggy tests and reported upstream
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/ChangeLog10
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.018-tests.patch20
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.056-tests.patch (renamed from dev-cpp/tbb/files/tbb-3.0.035-tests.patch)12
-rw-r--r--dev-cpp/tbb/tbb-3.0.018.ebuild81
-rw-r--r--dev-cpp/tbb/tbb-3.0.056.ebuild (renamed from dev-cpp/tbb/tbb-3.0.035.ebuild)13
5 files changed, 23 insertions, 113 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 23f6f5301cec..947a0e2f13cd 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.6 2010/07/19 15:43:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.7 2010/08/04 22:23:35 bicatali Exp $
+
+*tbb-3.0.056 (04 Aug 2010)
+
+ 04 Aug 2010; Sébastien Fabbro <bicatali@gentoo.org> -tbb-3.0.018.ebuild,
+ -files/tbb-3.0.018-tests.patch, -tbb-3.0.035.ebuild,
+ -files/tbb-3.0.035-tests.patch, +tbb-3.0.056.ebuild,
+ +files/tbb-3.0.056-tests.patch:
+ Version bump. Disabled buggy tests and reported upstream
*tbb-3.0.035 (19 Jul 2010)
diff --git a/dev-cpp/tbb/files/tbb-3.0.018-tests.patch b/dev-cpp/tbb/files/tbb-3.0.018-tests.patch
deleted file mode 100644
index c10e20a466e3..000000000000
--- a/dev-cpp/tbb/files/tbb-3.0.018-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- build/Makefile.test.orig 2010-05-28 20:00:18.000000000 +0100
-+++ build/Makefile.test 2010-05-28 20:06:20.000000000 +0100
-@@ -193,7 +193,7 @@
- # If a component Y uses component X, then tests for Y should come after tests for X.
- # Note that usually run_cmd is empty, and tests run directly
- test_tbb_plain: $(TEST_PREREQUISITE) $(TASK_CPP_DIRECTLY_INCLUDED) $(TEST_TBB_PLAIN.EXE)
-- $(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
-+ #$(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
- # Checking TBB version first to make sure the following testing has anything in it
- $(run_cmd) ./test_assembly.$(TEST_EXT) $(args)
- $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
-@@ -254,7 +254,7 @@
-
- CPLUS_FLAGS_DEPRECATED = $(DEFINE_KEY)TBB_DEPRECATED=1 $(subst $(WARNING_KEY),,$(CPLUS_FLAGS_NOSTRICT)) $(WARNING_SUPPRESS)
-
--TEST_TBB_OLD.OBJ = test_concurrent_vector_v2.$(OBJ) test_concurrent_queue_v2.$(OBJ) test_mutex_v2.$(OBJ) test_task_v2.$(OBJ)
-+TEST_TBB_OLD.OBJ = test_concurrent_vector_v2.$(OBJ) test_concurrent_queue_v2.$(OBJ) test_mutex_v2.$(OBJ)
-
- TEST_TBB_DEPRECATED.OBJ = test_concurrent_queue_deprecated.$(OBJ) \
- test_concurrent_vector_deprecated.$(OBJ) \
diff --git a/dev-cpp/tbb/files/tbb-3.0.035-tests.patch b/dev-cpp/tbb/files/tbb-3.0.056-tests.patch
index c756dfd908ea..183f8c83e440 100644
--- a/dev-cpp/tbb/files/tbb-3.0.035-tests.patch
+++ b/dev-cpp/tbb/files/tbb-3.0.056-tests.patch
@@ -1,6 +1,6 @@
---- build/Makefile.test.orig 2010-07-16 16:45:38.000000000 +0100
-+++ build/Makefile.test 2010-07-16 16:46:09.000000000 +0100
-@@ -191,7 +191,7 @@
+--- build/Makefile.test.orig 2010-08-04 23:37:11.000000000 +0100
++++ build/Makefile.test 2010-08-04 23:38:11.000000000 +0100
+@@ -191,10 +191,10 @@
# If a component Y uses component X, then tests for Y should come after tests for X.
# Note that usually run_cmd is empty, and tests run directly
test_tbb_plain: $(TEST_PREREQUISITE) $(TASK_CPP_DIRECTLY_INCLUDED) $(TEST_TBB_PLAIN.EXE)
@@ -8,4 +8,8 @@
+ #$(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
# Checking TBB version first to make sure the following testing has anything in it
$(run_cmd) ./test_assembly.$(TEST_EXT) $(args)
- $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
+- $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
++ #$(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
+ # Yes, 4:8 is intended on the next line.
+ $(run_cmd) ./test_yield.$(TEST_EXT) $(args) 4:8
+ $(run_cmd) ./test_handle_perror.$(TEST_EXT) $(args)
diff --git a/dev-cpp/tbb/tbb-3.0.018.ebuild b/dev-cpp/tbb/tbb-3.0.018.ebuild
deleted file mode 100644
index baf84d5779a7..000000000000
--- a/dev-cpp/tbb/tbb-3.0.018.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.018.ebuild,v 1.2 2010/05/28 19:09:14 bicatali Exp $
-
-EAPI=2
-inherit eutils versionator toolchain-funcs alternatives
-# url number
-MYU="78/154"
-# release update
-MYR=""
-
-PV1="$(get_version_component_range 1)"
-PV2="$(get_version_component_range 2)"
-PV3="$(get_version_component_range 3)"
-MYP="${PN}${PV1}${PV2}_${PV3}oss"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="http://www.threadingbuildingblocks.org/"
-SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}/${MYP}_src.tgz"
-LICENSE="GPL-2-with-exceptions"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc examples"
-
-DEPEND="!<=dev-cpp/tbb-2.1.016"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-tests.patch
- sed -i \
- -e "s/-O2/${CXXFLAGS}/g" \
- build/*.inc \
- || die
-}
-
-src_compile() {
- if [[ $(tc-getCXX) == *g++ ]]; then
- myconf="compiler=gcc"
- elif [[ $(tc-getCXX) == *ic*c ]]; then
- myconf="compiler=icc"
- fi
- # from the Makefile, split debug
- cd src
- emake ${myconf} tbb_release tbbmalloc_release || die "emake failed"
- if use debug || use examples; then
- emake ${myconf} tbb_debug tbbmalloc_debug || die "emake debug failed"
- fi
-}
-
-src_test() {
- cd src
- emake -j1 ${myconf} test_release || die "emake test failed"
- if use debug || use examples; then
- emake ${myconf} test_debug tbbmalloc_test_debug || die "emake test debug failed"
- fi
-
-}
-
-src_install(){
- for l in $(find build -name lib\*.so.\*); do
- dolib.so ${l} || die
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%.*}
- done
- insinto /usr
- doins -r include || die
-
- dodoc README CHANGES doc/Release_Notes.txt
- if use doc ; then
- insinto /usr/share/doc/${PF}
- doins -r doc/html || die
- fi
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc || die
- insinto /usr/share/doc/${PF}/examples
- doins -r examples || die
- fi
-}
diff --git a/dev-cpp/tbb/tbb-3.0.035.ebuild b/dev-cpp/tbb/tbb-3.0.056.ebuild
index 5b54dfe973dc..ea4df3b27434 100644
--- a/dev-cpp/tbb/tbb-3.0.035.ebuild
+++ b/dev-cpp/tbb/tbb-3.0.056.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.035.ebuild,v 1.1 2010/07/19 15:43:09 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.056.ebuild,v 1.1 2010/08/04 22:23:35 bicatali Exp $
-EAPI=2
-inherit eutils versionator toolchain-funcs alternatives
+EAPI=3
+inherit eutils versionator toolchain-funcs
# url number
-MYU="78/155"
+MYU="78/157"
# release update
-MYR="%20update%20"1
+MYR="%20update%20"2
PV1="$(get_version_component_range 1)"
PV2="$(get_version_component_range 2)"
@@ -31,8 +31,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-tests.patch
sed -i \
-e "s/-O2/${CXXFLAGS}/g" \
- build/*.inc \
- || die
+ build/*.inc || die
}
src_compile() {