summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-05-28 19:09:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-05-28 19:09:15 +0000
commitc52184e521e35877fa409bdeda26386ac9053984 (patch)
tree37e2f995728fd31a68d91524707304bae384fec2 /dev-cpp/tbb
parentbump (diff)
downloadgentoo-2-c52184e521e35877fa409bdeda26386ac9053984.tar.gz
gentoo-2-c52184e521e35877fa409bdeda26386ac9053984.tar.bz2
gentoo-2-c52184e521e35877fa409bdeda26386ac9053984.zip
Disable buggy tests
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/ChangeLog6
-rw-r--r--dev-cpp/tbb/files/tbb-3.0.018-tests.patch20
-rw-r--r--dev-cpp/tbb/tbb-3.0.018.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-cpp/tbb/ChangeLog b/dev-cpp/tbb/ChangeLog
index 28ad079e6ef5..44fdd60e448a 100644
--- a/dev-cpp/tbb/ChangeLog
+++ b/dev-cpp/tbb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/tbb
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.4 2010/05/05 01:42:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/ChangeLog,v 1.5 2010/05/28 19:09:14 bicatali Exp $
+
+ 28 May 2010; Sébastien Fabbro <bicatali@gentoo.org> tbb-3.0.018.ebuild,
+ +files/tbb-3.0.018-tests.patch:
+ Disable buggy tests
*tbb-3.0.018 (05 May 2010)
diff --git a/dev-cpp/tbb/files/tbb-3.0.018-tests.patch b/dev-cpp/tbb/files/tbb-3.0.018-tests.patch
new file mode 100644
index 000000000000..c10e20a466e3
--- /dev/null
+++ b/dev-cpp/tbb/files/tbb-3.0.018-tests.patch
@@ -0,0 +1,20 @@
+--- build/Makefile.test.orig 2010-05-28 20:00:18.000000000 +0100
++++ build/Makefile.test 2010-05-28 20:06:20.000000000 +0100
+@@ -193,7 +193,7 @@
+ # If a component Y uses component X, then tests for Y should come after tests for X.
+ # Note that usually run_cmd is empty, and tests run directly
+ test_tbb_plain: $(TEST_PREREQUISITE) $(TASK_CPP_DIRECTLY_INCLUDED) $(TEST_TBB_PLAIN.EXE)
+- $(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
++ #$(run_cmd) ./test_tbb_version.$(TEST_EXT) $(args)
+ # Checking TBB version first to make sure the following testing has anything in it
+ $(run_cmd) ./test_assembly.$(TEST_EXT) $(args)
+ $(run_cmd) ./test_compiler.$(TEST_EXT) $(args)
+@@ -254,7 +254,7 @@
+
+ CPLUS_FLAGS_DEPRECATED = $(DEFINE_KEY)TBB_DEPRECATED=1 $(subst $(WARNING_KEY),,$(CPLUS_FLAGS_NOSTRICT)) $(WARNING_SUPPRESS)
+
+-TEST_TBB_OLD.OBJ = test_concurrent_vector_v2.$(OBJ) test_concurrent_queue_v2.$(OBJ) test_mutex_v2.$(OBJ) test_task_v2.$(OBJ)
++TEST_TBB_OLD.OBJ = test_concurrent_vector_v2.$(OBJ) test_concurrent_queue_v2.$(OBJ) test_mutex_v2.$(OBJ)
+
+ TEST_TBB_DEPRECATED.OBJ = test_concurrent_queue_deprecated.$(OBJ) \
+ test_concurrent_vector_deprecated.$(OBJ) \
diff --git a/dev-cpp/tbb/tbb-3.0.018.ebuild b/dev-cpp/tbb/tbb-3.0.018.ebuild
index 2aa1917a6517..baf84d5779a7 100644
--- a/dev-cpp/tbb/tbb-3.0.018.ebuild
+++ b/dev-cpp/tbb/tbb-3.0.018.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.018.ebuild,v 1.1 2010/05/05 01:42:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.018.ebuild,v 1.2 2010/05/28 19:09:14 bicatali Exp $
EAPI=2
inherit eutils versionator toolchain-funcs alternatives
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MYP}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-tests.patch
sed -i \
-e "s/-O2/${CXXFLAGS}/g" \
build/*.inc \