summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2009-08-09 11:10:58 +0000
committerIlya Volynets <iluxa@gentoo.org>2009-08-09 11:10:58 +0000
commitb9f3ec9a5e730a92ee812231ba1152f868cf106f (patch)
treed94270a4f2cda0cc4ff121277ba345d3ff5118c3 /dev-cpp/sptk
parentRemove old (diff)
downloadgentoo-2-b9f3ec9a5e730a92ee812231ba1152f868cf106f.tar.gz
gentoo-2-b9f3ec9a5e730a92ee812231ba1152f868cf106f.tar.bz2
gentoo-2-b9f3ec9a5e730a92ee812231ba1152f868cf106f.zip
Apply gcc-4.4-related fixes to SPTK 3.5.8.14
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/files/sptk-gcc-4.4.patch51
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild73
3 files changed, 131 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 0e1962e3f430..e146771c8a3f 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.61 2009/08/08 16:11:31 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.62 2009/08/09 11:10:58 iluxa Exp $
+
+*sptk-3.5.8.14-r1 (09 Aug 2009)
+
+ 09 Aug 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +files/sptk-gcc-4.4.patch, +sptk-3.5.8.14-r1.ebuild:
+ Apply gcc-4.4-related fixes
08 Aug 2009; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
sptk-3.5.8.10.ebuild, sptk-3.5.8.14.ebuild:
diff --git a/dev-cpp/sptk/files/sptk-gcc-4.4.patch b/dev-cpp/sptk/files/sptk-gcc-4.4.patch
new file mode 100644
index 000000000000..e14555d4f684
--- /dev/null
+++ b/dev-cpp/sptk/files/sptk-gcc-4.4.patch
@@ -0,0 +1,51 @@
+diff -uNr sptk-3.5.8.14/examples/registry.cpp sptk-3.5.8.14.fix/examples/registry.cpp
+--- sptk-3.5.8.14/examples/registry.cpp 2008-06-28 15:43:06.000000000 +1000
++++ sptk-3.5.8.14.fix/examples/registry.cpp 2009-08-09 09:42:56.000000000 +1000
+@@ -66,7 +66,9 @@
+ cout << "The registry doesn't contain window information" << endl;
+ }
+ }
+- catch (exception& e) { puts(e.what()); }
++ catch (exception& e) {
++ cerr << e.what() << endl;
++ }
+ }
+
+ void updateRegistry(CRegistryMode mode) {
+@@ -97,8 +99,8 @@
+
+ mySettings.save();
+ }
+- catch (exception& e) {
+- puts(e.what());
++ catch (exception& e) {
++ cerr << e.what() << endl;
+ }
+ }
+
+diff -uNr sptk-3.5.8.14/src/utils/CVariant.cpp sptk-3.5.8.14.fix/src/utils/CVariant.cpp
+--- sptk-3.5.8.14/src/utils/CVariant.cpp 2008-08-29 15:24:23.000000000 +1000
++++ sptk-3.5.8.14.fix/src/utils/CVariant.cpp 2009-08-09 09:36:25.000000000 +1000
+@@ -40,6 +40,7 @@
+
+ #include <map>
+ #include <math.h>
++#include <stdio.h>
+
+ using namespace std;
+ using namespace sptk;
+diff -uNr sptk-3.5.8.14/.themes.sptk/tar2h.cpp sptk-3.5.8.14.fix/.themes.sptk/tar2h.cpp
+--- sptk-3.5.8.14/.themes.sptk/tar2h.cpp 2007-07-21 12:54:26.000000000 +1000
++++ sptk-3.5.8.14.fix/.themes.sptk/tar2h.cpp 2009-08-09 09:32:50.000000000 +1000
+@@ -33,8 +33,9 @@
+ return 1;
+ }
+
+- printf("static size_t %s_len = %ld;\n", argv[2], st.st_size);
+- printf("static unsigned char %s[%ld] = {\n", argv[2], st.st_size);
++ long sz = st.st_size;
++ printf("static size_t %s_len = %ld;\n", argv[2], sz);
++ printf("static unsigned char %s[%ld] = {\n", argv[2], sz);
+
+ x = (unsigned char *)malloc(st.st_size);
+
diff --git a/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild b/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild
new file mode 100644
index 000000000000..213b6f7899c9
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 2006-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.14-r1.ebuild,v 1.1 2009/08/09 11:10:58 iluxa Exp $
+
+EAPI=1
+
+inherit cmake-utils
+
+IUSE="fltk odbc doc sqlite excel postgres aspell mysql gnutls"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6:1.1 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( virtual/mysql )
+ aspell? ( >=app-text/aspell-0.50 )
+ gnutls? ( net-libs/gnutls )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/sptk-gcc-4.4.patch"
+}
+
+src_compile() {
+ local mycmakeargs="$(cmake-utils_use_no postgres POSTGRESQL)
+ $(cmake-utils_use_no mysql MYSQL)
+ $(cmake-utils_use_no sqlite SQLITE3)
+ $(cmake-utils_use_no odbc ODBC)
+ $(cmake-utils_use_no aspell ASPELL)
+ $(cmake-utils_use_no fltk FLTK)
+ $(cmake-utils_use_no excel EXCEL)
+ $(cmake-utils_use_no gnutls TLS)"
+
+ mycmakeargs="${mycmakeargs} -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} -DNO_EXAMPLES:BOOLEAN=TRUE"
+
+ cmake-utils_src_configure
+
+ cmake-utils_src_compile
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ DOCS="README AUTHORS"
+ cmake-utils_src_install
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}