summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-11 06:35:48 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-11 06:35:48 +0000
commit11d6e70efd2948e2d20467a3b7cca2b8823aaa8b (patch)
tree4e2630d79f9d8f7cfe68a573a09ea3efdf244876 /dev-cpp/sptk
parentMissing #ifdef in patch, thanks to Michael Sterrett for noticing. (diff)
downloadgentoo-2-11d6e70efd2948e2d20467a3b7cca2b8823aaa8b.tar.gz
gentoo-2-11d6e70efd2948e2d20467a3b7cca2b8823aaa8b.tar.bz2
gentoo-2-11d6e70efd2948e2d20467a3b7cca2b8823aaa8b.zip
Fix building with OpenSSL >= 1.0.0 wrt #326959 by Diego E. 'FlaPettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog6
-rw-r--r--dev-cpp/sptk/files/sptk-4.02-openssl-1.patch16
-rw-r--r--dev-cpp/sptk/sptk-4.02.ebuild10
3 files changed, 29 insertions, 3 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 325ba6014996..73602f34ffe3 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.69 2010/06/17 20:09:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.70 2010/07/11 06:35:48 ssuominen Exp $
+
+ 11 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> sptk-4.02.ebuild,
+ +files/sptk-4.02-openssl-1.patch:
+ Fix building with OpenSSL >= 1.0.0 wrt #326959 by Diego E. 'FlaPettenò.
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> sptk-3.5.8.10.ebuild,
sptk-3.5.8.14.ebuild, sptk-3.5.8.14-r1.ebuild, sptk-4.00.ebuild,
diff --git a/dev-cpp/sptk/files/sptk-4.02-openssl-1.patch b/dev-cpp/sptk/files/sptk-4.02-openssl-1.patch
new file mode 100644
index 000000000000..df28abfb8184
--- /dev/null
+++ b/dev-cpp/sptk/files/sptk-4.02-openssl-1.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/326959
+
+--- src/encryption/CSymmetricSSLEncryption.cpp
++++ src/encryption/CSymmetricSSLEncryption.cpp
+@@ -48,9 +48,11 @@
+ memcpy(m_key, key, sizeof(m_key));
+ memcpy(m_vec, vec, sizeof(m_vec));
+ EVP_CipherInit_ex(&m_ctx, cipher, NULL, m_key, m_vec, direction);
++#if OPENSSL_VERSION_NUMBER < 0x10000000L
+ #ifdef EVP_CIPH_FLAG_LENGTH_BITS
+ M_EVP_CIPHER_CTX_set_flags(&m_ctx, EVP_CIPH_FLAG_LENGTH_BITS);
+ #endif
++#endif
+ }
+
+ CSymmetricSSLCipher::~CSymmetricSSLCipher()
diff --git a/dev-cpp/sptk/sptk-4.02.ebuild b/dev-cpp/sptk/sptk-4.02.ebuild
index c9e204fd5f00..32085499ad9d 100644
--- a/dev-cpp/sptk/sptk-4.02.ebuild
+++ b/dev-cpp/sptk/sptk-4.02.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-4.02.ebuild,v 1.2 2010/06/17 20:09:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-4.02.ebuild,v 1.3 2010/07/11 06:35:48 ssuominen Exp $
EAPI=1
-inherit cmake-utils
+inherit cmake-utils eutils
IUSE="fltk odbc doc sqlite excel postgres aspell mysql gnutls"
@@ -29,6 +29,12 @@ DEPEND="${RDEPEND}
CMAKE_IN_SOURCE_BUILD=1
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-openssl-1.patch
+}
+
src_compile() {
local mycmakeargs="$(cmake-utils_use_no postgres POSTGRESQL)
$(cmake-utils_use_no mysql MYSQL)