summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-08 22:48:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-08 22:48:32 +0000
commit834f2a15c4de368829f37ec6467a08b7cef76e8d (patch)
tree5841414c7cd350fa56b4cc1742098577231c12b4 /dev-cpp/pangomm
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-834f2a15c4de368829f37ec6467a08b7cef76e8d.tar.gz
gentoo-2-834f2a15c4de368829f37ec6467a08b7cef76e8d.tar.bz2
gentoo-2-834f2a15c4de368829f37ec6467a08b7cef76e8d.zip
New package for GNOME 2.24, pango bindings splitted off gtkmm sources.
(Portage version: 2.2_rc13/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'dev-cpp/pangomm')
-rw-r--r--dev-cpp/pangomm/ChangeLog10
-rw-r--r--dev-cpp/pangomm/metadata.xml6
-rw-r--r--dev-cpp/pangomm/pangomm-2.14.0.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-cpp/pangomm/ChangeLog b/dev-cpp/pangomm/ChangeLog
new file mode 100644
index 000000000000..1ba83644dcbf
--- /dev/null
+++ b/dev-cpp/pangomm/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/pangomm
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pangomm/ChangeLog,v 1.1 2008/11/08 22:48:32 eva Exp $
+
+*pangomm-2.14.0 (08 Nov 2008)
+
+ 08 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +pangomm-2.14.0.ebuild:
+ New package for GNOME 2.24, pango bindings splitted off gtkmm sources.
+
diff --git a/dev-cpp/pangomm/metadata.xml b/dev-cpp/pangomm/metadata.xml
new file mode 100644
index 000000000000..0c3fdbb65e79
--- /dev/null
+++ b/dev-cpp/pangomm/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-mm</herd>
+</pkgmetadata>
+
diff --git a/dev-cpp/pangomm/pangomm-2.14.0.ebuild b/dev-cpp/pangomm/pangomm-2.14.0.ebuild
new file mode 100644
index 000000000000..7e2b03b6944a
--- /dev/null
+++ b/dev-cpp/pangomm/pangomm-2.14.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pangomm/pangomm-2.14.0.ebuild,v 1.1 2008/11/08 22:48:32 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ interface for pango"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/pango-1.21.4
+ >=dev-cpp/glibmm-2.14.1
+ >=dev-cpp/cairomm-1.2.2
+ !<dev-cpp/gtkmm-2.13"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS CHANGES ChangeLog PORTING NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable doc docs)"
+}
+