summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:21:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:21:14 +0000
commit79eae95068842962af309ecc681f0ddb9f0a891f (patch)
tree80a4ca58410911374acd74197fc790052915a6e6 /dev-cpp/muParser
parentAdding doc use flag for proper doc installation (diff)
downloadgentoo-2-79eae95068842962af309ecc681f0ddb9f0a891f.tar.gz
gentoo-2-79eae95068842962af309ecc681f0ddb9f0a891f.tar.bz2
gentoo-2-79eae95068842962af309ecc681f0ddb9f0a891f.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/muParser')
-rw-r--r--dev-cpp/muParser/ChangeLog10
-rw-r--r--dev-cpp/muParser/files/muParser-1.30-build.patch28
-rw-r--r--dev-cpp/muParser/muParser-1.30.ebuild50
3 files changed, 86 insertions, 2 deletions
diff --git a/dev-cpp/muParser/ChangeLog b/dev-cpp/muParser/ChangeLog
index 596f04ae45f6..4581309b9539 100644
--- a/dev-cpp/muParser/ChangeLog
+++ b/dev-cpp/muParser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/muParser
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.8 2008/05/17 09:59:22 bicatali Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/ChangeLog,v 1.9 2009/03/09 16:21:14 bicatali Exp $
+
+*muParser-1.30 (09 Mar 2009)
+
+ 09 Mar 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/muParser-1.30-build.patch, +muParser-1.30.ebuild:
+ Version bump
17 May 2008; Sébastien Fabbro <bicatali@gentoo.org> muParser-1.28.ebuild:
Fixed syntax error in RDEPEND
diff --git a/dev-cpp/muParser/files/muParser-1.30-build.patch b/dev-cpp/muParser/files/muParser-1.30-build.patch
new file mode 100644
index 000000000000..9ded9274fd46
--- /dev/null
+++ b/dev-cpp/muParser/files/muParser-1.30-build.patch
@@ -0,0 +1,28 @@
+diff -Nur muparser.orig/configure muparser/configure
+--- muparser.orig/configure 2008-06-09 22:51:39.000000000 +0100
++++ muparser/configure 2009-03-09 16:12:02.335504093 +0000
+@@ -1927,10 +1927,6 @@
+ NONENONEs,x,x, &&
+ program_prefix=${target_alias}-
+
+-CFLAGS=
+-CXXFLAGS=
+-CPPFLAGS=
+-
+ for ac_prog in gawk mawk nawk awk
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+diff -Nur muparser.orig/Makefile.in muparser/Makefile.in
+--- muparser.orig/Makefile.in 2008-06-09 22:51:39.000000000 +0100
++++ muparser/Makefile.in 2009-03-09 16:07:55.871757201 +0000
+@@ -192,8 +192,8 @@
+ all: $(__muParser_lib___depname) $(__muParser_dll___depname) $(__example1___depname)
+
+ install: all $(__install_muParser_lib___depname) $(__install_muParser_lib_headers___depname) $(__install_muParser_dll___depname) $(__install_muParser_dll_headers___depname)
+- $(INSTALL_DIR) $(libdir)/pkgconfig
+- $(INSTALL_DATA) build/autoconf/muparser.pc $(libdir)/pkgconfig
++ $(INSTALL_DIR) $(DESTDIR)$(libdir)/pkgconfig
++ $(INSTALL_DATA) build/autoconf/muparser.pc $(DESTDIR)$(libdir)/pkgconfig
+
+ uninstall: $(__uninstall_muParser_lib___depname) $(__uninstall_muParser_lib_headers___depname) $(__uninstall_muParser_dll___depname) $(__uninstall_muParser_dll_headers___depname)
+
diff --git a/dev-cpp/muParser/muParser-1.30.ebuild b/dev-cpp/muParser/muParser-1.30.ebuild
new file mode 100644
index 000000000000..a58738307dce
--- /dev/null
+++ b/dev-cpp/muParser/muParser-1.30.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/muParser/muParser-1.30.ebuild,v 1.1 2009/03/09 16:21:14 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="http://muparser.sourceforge.net/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc"
+MY_PN="${PN/P/p}"
+MY_PV="v${PV/./}"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}_${MY_PV}.tar.gz"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # fix destdir and respect cxxflags
+ # cant really use autotools cause muparser use bakefile
+ # and too lasy to make an ebuild for it.
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_configure() {
+ econf --disable-samples
+}
+
+src_test() {
+ econf --enable-samples
+ emake || die "emake failed"
+ echo "LD_LIBRARY_PATH=${PWD}/lib samples/example1/example1 << EOF" > test.sh
+ echo "quit" >> test.sh
+ echo "EOF" >> test.sh
+ sh ./test.sh || die "test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Changes.txt Credits.txt || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r docs/html || die
+ fi
+}