summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-11-20 18:17:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-11-20 18:17:32 +0000
commit7f85fa406bbfd45bc73c0df0e7ffaf50f6795930 (patch)
tree4a943c429bd80ed88ff1720612bde8094fc0cb9b /dev-cpp/libxmlpp
parentVersion bump (diff)
downloadgentoo-2-7f85fa406bbfd45bc73c0df0e7ffaf50f6795930.tar.gz
gentoo-2-7f85fa406bbfd45bc73c0df0e7ffaf50f6795930.tar.bz2
gentoo-2-7f85fa406bbfd45bc73c0df0e7ffaf50f6795930.zip
Clean up old revisions.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/libxmlpp')
-rw-r--r--dev-cpp/libxmlpp/ChangeLog6
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.32.0-r1.ebuild59
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.32.0.ebuild43
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild46
4 files changed, 5 insertions, 149 deletions
diff --git a/dev-cpp/libxmlpp/ChangeLog b/dev-cpp/libxmlpp/ChangeLog
index f4fc03beedc2..91ebe0917ca7 100644
--- a/dev-cpp/libxmlpp/ChangeLog
+++ b/dev-cpp/libxmlpp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/libxmlpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.119 2011/10/30 14:54:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/ChangeLog,v 1.120 2011/11/20 18:17:32 eva Exp $
+
+ 20 Nov 2011; Gilles Dartiguelongue <eva@gentoo.org> -libxmlpp-2.32.0.ebuild,
+ -libxmlpp-2.32.0-r1.ebuild, -libxmlpp-2.34.1.ebuild:
+ Clean up old revisions.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> libxmlpp-2.34.2.ebuild:
alpha/ia64/sparc stable wrt #385699
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.32.0-r1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.32.0-r1.ebuild
deleted file mode 100644
index 720e0c73f7b6..000000000000
--- a/dev-cpp/libxmlpp/libxmlpp-2.32.0-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.32.0-r1.ebuild,v 1.2 2011/04/14 17:55:19 pacho Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-
-inherit autotools gnome2
-
-MY_PN="${PN/pp/++}"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
-HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
-SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="2.6"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/libxml2-2.6.1
- >=dev-cpp/glibmm-2.4"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( || (
- <dev-cpp/glibmm-2.27.97:2[doc?]
- >=dev-cpp/mm-common-0.9.3
- ) )
-"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable doc documentation)"
- DOCS="AUTHORS ChangeLog NEWS README*"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # don't waste time building the examples
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed Makefile.in failed"
-
- # doc-install.pl was removed from glibmm, and is provided by mm-common now
- # This should not be needed if the tarball is generated with mm-common-0.9.3
- if use doc && has_version '>=dev-cpp/glibmm-2.27.97'; then
- mm-common-prepare --copy --force
- eautoreconf
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- rm -fr "${ED}"usr/share/doc/libxml++*
- use doc && dohtml docs/reference/html/*
-}
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.32.0.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.32.0.ebuild
deleted file mode 100644
index 88099b6a0742..000000000000
--- a/dev-cpp/libxmlpp/libxmlpp-2.32.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.32.0.ebuild,v 1.8 2011/04/28 16:36:44 ssuominen Exp $
-
-EAPI="3"
-
-inherit gnome2
-
-MY_PN="${PN/pp/++}"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
-HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
-SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="2.6"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/libxml2-2.6.1
- >=dev-cpp/glibmm-2.4"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README*"
-
-src_prepare() {
- gnome2_src_prepare
-
- # don't waste time building the examples
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed Makefile.in failed"
-}
-
-src_install() {
- gnome2_src_install
-
- rm -fr "${ED}"usr/share/doc/libxml++*
- use doc && dohtml docs/reference/html/*
-}
diff --git a/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild b/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild
deleted file mode 100644
index d562b56d842d..000000000000
--- a/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libxmlpp/libxmlpp-2.34.1.ebuild,v 1.5 2011/10/04 14:10:37 jer Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-
-inherit gnome2
-
-MY_PN="${PN/pp/++}"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
-HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
-SRC_URI="mirror://gnome/sources/libxml++/${PV%.*}/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="2.6"
-KEYWORDS="alpha amd64 hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/libxml2-2.6.1
- >=dev-cpp/glibmm-2.4"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-pkg_setup() {
- G2CONF="${G2CONF} $(use_enable doc documentation)"
- DOCS="AUTHORS ChangeLog NEWS README*"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # don't waste time building the examples
- sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
- -i Makefile.am Makefile.in || die "sed Makefile.in failed"
-}
-
-src_install() {
- gnome2_src_install
-
- rm -fr "${ED}"usr/share/doc/libxml++*
- use doc && dohtml docs/reference/html/*
-}