summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-12-02 22:29:02 +0000
committerPacho Ramos <pacho@gentoo.org>2014-12-02 22:29:02 +0000
commit1fe01b05296a9816e9460ff040dbb1fe1c981ec6 (patch)
tree7865afd9c402c58559ebe1a444f7ca0408137312 /dev-cpp/libglademm
parentUse new python eclasses and make it buildable again (#487204 by Pariksheet Na... (diff)
downloadgentoo-2-1fe01b05296a9816e9460ff040dbb1fe1c981ec6.tar.gz
gentoo-2-1fe01b05296a9816e9460ff040dbb1fe1c981ec6.tar.bz2
gentoo-2-1fe01b05296a9816e9460ff040dbb1fe1c981ec6.zip
Update ebuild
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-cpp/libglademm')
-rw-r--r--dev-cpp/libglademm/ChangeLog8
-rw-r--r--dev-cpp/libglademm/libglademm-2.6.7.ebuild28
2 files changed, 18 insertions, 18 deletions
diff --git a/dev-cpp/libglademm/ChangeLog b/dev-cpp/libglademm/ChangeLog
index c67a4a077256..10c9930e0741 100644
--- a/dev-cpp/libglademm/ChangeLog
+++ b/dev-cpp/libglademm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/libglademm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libglademm/ChangeLog,v 1.88 2012/05/04 03:44:58 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libglademm/ChangeLog,v 1.89 2014/12/02 22:29:02 pacho Exp $
+
+ 02 Dec 2014; Pacho Ramos <pacho@gentoo.org> libglademm-2.6.7.ebuild:
+ Update ebuild
04 May 2012; Jeff Horelick <jdhore@gentoo.org> libglademm-2.6.7.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -364,4 +367,3 @@
gnome2.eclass version of foser <foser@sesmar.eu.org> gnome-c++
bindings.
initial release
-
diff --git a/dev-cpp/libglademm/libglademm-2.6.7.ebuild b/dev-cpp/libglademm/libglademm-2.6.7.ebuild
index 8e644fb34d46..114279dcdcf0 100644
--- a/dev-cpp/libglademm/libglademm-2.6.7.ebuild
+++ b/dev-cpp/libglademm/libglademm-2.6.7.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libglademm/libglademm-2.6.7.ebuild,v 1.11 2012/05/04 03:44:58 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libglademm/libglademm-2.6.7.ebuild,v 1.12 2014/12/02 22:29:02 pacho Exp $
-EAPI="3"
+EAPI="5"
GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
inherit gnome2
@@ -15,18 +16,16 @@ SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
IUSE="doc examples"
-RDEPEND=">=gnome-base/libglade-2.6.1:2.0
+RDEPEND="
+ >=gnome-base/libglade-2.6.1:2.0
>=dev-cpp/gtkmm-2.6:2.4
- >=dev-cpp/glibmm-2.4:2"
-
+ >=dev-cpp/glibmm-2.4:2
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
+ virtual/pkgconfig
+"
src_prepare() {
- gnome2_src_prepare
-
# we will control install manually in install
sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.am Makefile.in || \
die "sed Makefile.{am,in} failed (1)"
@@ -34,6 +33,8 @@ src_prepare() {
# don't waste time building the examples
sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
Makefile.am Makefile.in || die "sed Makefile.{am,in} failed (2)"
+
+ gnome2_src_prepare
}
src_compile() {
@@ -48,7 +49,7 @@ src_install() {
gnome2_src_install
if use doc ; then
- dohtml -r docs/reference/html/* || die "dohtml failed"
+ dohtml -r docs/reference/html/*
fi
if use examples; then
@@ -58,7 +59,4 @@ src_install() {
insinto "/usr/share/doc/${PF}"
doins -r examples || die "doins failed"
fi
-
- # Does not install static library
- find "${D}" -name "*.la" -delete || die "failed *.la removal"
}