summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-07-07 19:02:09 +0000
committerPacho Ramos <pacho@gentoo.org>2015-07-07 19:02:09 +0000
commitd400ffd08c04fb24acc42e4e3c99659c476bfe99 (patch)
tree74384ee9813074d425aa264de50d8a6d342cbe96 /dev-cpp/gtkmm
parentAnd fix glib depend too (diff)
downloadgentoo-2-d400ffd08c04fb24acc42e4e3c99659c476bfe99.tar.gz
gentoo-2-d400ffd08c04fb24acc42e4e3c99659c476bfe99.tar.bz2
gentoo-2-d400ffd08c04fb24acc42e4e3c99659c476bfe99.zip
Apply some upstream fixes to old slot
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-cpp/gtkmm')
-rw-r--r--dev-cpp/gtkmm/ChangeLog10
-rw-r--r--dev-cpp/gtkmm/files/gtkmm-2.24.4-missing-includes.patch200
-rw-r--r--dev-cpp/gtkmm/files/gtkmm-2.24.4-newer-glibmm.patch60
-rw-r--r--dev-cpp/gtkmm/files/gtkmm-2.24.4-papersize.patch45
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.24.4-r2.ebuild74
5 files changed, 388 insertions, 1 deletions
diff --git a/dev-cpp/gtkmm/ChangeLog b/dev-cpp/gtkmm/ChangeLog
index 6ec31cb237a3..ff16f332d7bd 100644
--- a/dev-cpp/gtkmm/ChangeLog
+++ b/dev-cpp/gtkmm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-cpp/gtkmm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.299 2015/06/09 15:04:27 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/ChangeLog,v 1.300 2015/07/07 19:02:09 pacho Exp $
+
+*gtkmm-2.24.4-r2 (07 Jul 2015)
+
+ 07 Jul 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/gtkmm-2.24.4-missing-includes.patch,
+ +files/gtkmm-2.24.4-newer-glibmm.patch, +files/gtkmm-2.24.4-papersize.patch,
+ +gtkmm-2.24.4-r2.ebuild:
+ Apply some upstream fixes to old slot
*gtkmm-3.16.0 (09 Jun 2015)
diff --git a/dev-cpp/gtkmm/files/gtkmm-2.24.4-missing-includes.patch b/dev-cpp/gtkmm/files/gtkmm-2.24.4-missing-includes.patch
new file mode 100644
index 000000000000..640d48a3d128
--- /dev/null
+++ b/dev-cpp/gtkmm/files/gtkmm-2.24.4-missing-includes.patch
@@ -0,0 +1,200 @@
+From 185abd365c2898ad77dbb33a099341fa28e5a496 Mon Sep 17 00:00:00 2001
+From: Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
+Date: Thu, 2 Jul 2015 19:53:16 +0200
+Subject: Add #includes needed with glibmm newer than 2.31.0.
+
+ * gdk/src/color.hg:
+ * gdk/src/pixbufanimationiter.hg:
+ * gdk/src/pixbufformat.hg:
+ * gdk/src/rectangle.hg:
+ * gdk/src/rgbcmap.hg:
+ * gdk/src/types.hg:
+ * gtk/src/enums.hg:
+ * gtk/src/main.hg:
+ * gtk/src/papersize.hg:
+ * gtk/src/textattributes.hg:
+ * gtk/src/treemodel.hg: Add individual includes now that gmmproc does not
+ add #include <glibmm.h> at the top of every generated header.
+ * gtk/gtkmm/border.h: Add #include <gtk/gtk.h> to make
+ glibmm/tools/test_scripts/testheaders.sh happy.
+
+diff --git a/ChangeLog b/ChangeLog
+index 73e1eac..1d6d4d0 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,22 @@
++2015-07-02 Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
++
++ Add #includes needed with glibmm newer than 2.31.0.
++
++ * gdk/src/color.hg:
++ * gdk/src/pixbufanimationiter.hg:
++ * gdk/src/pixbufformat.hg:
++ * gdk/src/rectangle.hg:
++ * gdk/src/rgbcmap.hg:
++ * gdk/src/types.hg:
++ * gtk/src/enums.hg:
++ * gtk/src/main.hg:
++ * gtk/src/papersize.hg:
++ * gtk/src/textattributes.hg:
++ * gtk/src/treemodel.hg: Add individual includes now that gmmproc does not
++ add #include <glibmm.h> at the top of every generated header.
++ * gtk/gtkmm/border.h: Add #include <gtk/gtk.h> to make
++ glibmm/tools/test_scripts/testheaders.sh happy.
++
+ 2012-03-14 Murray Cumming <murrayc@murrayc.com>
+
+ PaperSize: Correct the PaperSizeTraits pre-declaration.
+diff --git a/gdk/src/color.hg b/gdk/src/color.hg
+index ce22d4b..09c91fc 100644
+--- a/gdk/src/color.hg
++++ b/gdk/src/color.hg
+@@ -21,6 +21,8 @@
+ // the #ifndef GDKMM_DISABLE_DEPRECATED in deprecated classes) is generated:
+ _CONFIGINCLUDE(gdkmmconfig.h)
+
++#include <glibmm/arrayhandle.h>
++
+ _DEFS(gdkmm,gdk)
+
+ namespace Gdk
+diff --git a/gdk/src/pixbufanimationiter.hg b/gdk/src/pixbufanimationiter.hg
+index 4e12f52..f89a037 100644
+--- a/gdk/src/pixbufanimationiter.hg
++++ b/gdk/src/pixbufanimationiter.hg
+@@ -21,6 +21,7 @@
+
+ #include <glibmm/object.h>
+ #include <gdkmm/pixbuf.h>
++#include <glibmm/timeval.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+
+ _DEFS(gdkmm,gdk)
+diff --git a/gdk/src/pixbufformat.hg b/gdk/src/pixbufformat.hg
+index c460056..6c7daab 100644
+--- a/gdk/src/pixbufformat.hg
++++ b/gdk/src/pixbufformat.hg
+@@ -20,7 +20,7 @@
+ _DEFS(gdkmm,gdk)
+
+ #include <gdkmmconfig.h>
+-
++#include <glibmm/arrayhandle.h>
+
+ #ifndef DOXYGEN_SHOULD_SKIP_THIS
+ extern "C" { typedef struct _GdkPixbufFormat GdkPixbufFormat; }
+diff --git a/gdk/src/rectangle.hg b/gdk/src/rectangle.hg
+index f48de5a..01d1959 100644
+--- a/gdk/src/rectangle.hg
++++ b/gdk/src/rectangle.hg
+@@ -19,6 +19,7 @@
+ * Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <glibmm/value.h>
+ #include <gdk/gdk.h>
+
+ _DEFS(gdkmm,gdk)
+diff --git a/gdk/src/rgbcmap.hg b/gdk/src/rgbcmap.hg
+index bfdfdfe..817661f 100644
+--- a/gdk/src/rgbcmap.hg
++++ b/gdk/src/rgbcmap.hg
+@@ -24,6 +24,7 @@ _DEFS(gdkmm,gdk)
+ #m4 _POP()
+
+ #include <gdkmmconfig.h>
++#include <glibmm/arrayhandle.h>
+
+ #ifndef DOXYGEN_SHOULD_SKIP_THIS
+ extern "C" { typedef struct _GdkRgbCmap GdkRgbCmap; }
+diff --git a/gdk/src/types.hg b/gdk/src/types.hg
+index fd644b8..a05ba0c 100644
+--- a/gdk/src/types.hg
++++ b/gdk/src/types.hg
+@@ -19,6 +19,8 @@
+
+ _DEFS(gdkmm,gdk)
+
++#include <glibmm/arrayhandle.h>
++#include <glibmm/listhandle.h>
+ #include <gdk/gdk.h>
+ #include <gdkmmconfig.h>
+
+diff --git a/gtk/gtkmm/border.h b/gtk/gtkmm/border.h
+index a64c669..b48017e 100644
+--- a/gtk/gtkmm/border.h
++++ b/gtk/gtkmm/border.h
+@@ -22,6 +22,7 @@
+ */
+
+ #include <glibmm/value.h>
++#include <gtk/gtk.h> /* For GtkBorder */
+
+ namespace Gtk
+ {
+diff --git a/gtk/src/enums.hg b/gtk/src/enums.hg
+index 66c3696..ad3d20c 100644
+--- a/gtk/src/enums.hg
++++ b/gtk/src/enums.hg
+@@ -19,6 +19,7 @@
+ * Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
++#include <glibmm/value.h>
+ #include <gtkmmconfig.h> //For GTKMM_MAEMO_EXTENSIONS_ENABLED
+
+ _DEFS(gtkmm,gtk)
+diff --git a/gtk/src/main.hg b/gtk/src/main.hg
+index c6c05ed..2665445 100644
+--- a/gtk/src/main.hg
++++ b/gtk/src/main.hg
+@@ -22,6 +22,7 @@
+
+ #include <sigc++/sigc++.h>
+ #include <gdkmm/types.h> //For GdkEventKey
++#include <glibmm/optioncontext.h>
+
+ _DEFS(gtkmm,gtk)
+
+diff --git a/gtk/src/papersize.hg b/gtk/src/papersize.hg
+index 41fcb3c..3914cd1 100644
+--- a/gtk/src/papersize.hg
++++ b/gtk/src/papersize.hg
+@@ -17,6 +17,9 @@
+
+ _DEFS(gtkmm,gtk)
+
++#include <glibmm/keyfile.h>
++#include <glibmm/listhandle.h>
++
+ namespace Gtk
+ {
+
+diff --git a/gtk/src/textattributes.hg b/gtk/src/textattributes.hg
+index b043f98..3966529 100644
+--- a/gtk/src/textattributes.hg
++++ b/gtk/src/textattributes.hg
+@@ -22,6 +22,8 @@
+
+ _DEFS(gtkmm,gtk)
+
++#include <glibmm/value.h>
++
+ namespace Gtk
+ {
+
+diff --git a/gtk/src/treemodel.hg b/gtk/src/treemodel.hg
+index a04d924..360b4ed 100644
+--- a/gtk/src/treemodel.hg
++++ b/gtk/src/treemodel.hg
+@@ -18,6 +18,7 @@
+ */
+
+ #include <glibmm/interface.h>
++#include <glibmm/arrayhandle.h>
+ #include <gtkmm/treeiter.h>
+
+ _DEFS(gtkmm,gtk)
+--
+cgit v0.10.2
+
diff --git a/dev-cpp/gtkmm/files/gtkmm-2.24.4-newer-glibmm.patch b/dev-cpp/gtkmm/files/gtkmm-2.24.4-newer-glibmm.patch
new file mode 100644
index 000000000000..54a1ee0b34f5
--- /dev/null
+++ b/dev-cpp/gtkmm/files/gtkmm-2.24.4-newer-glibmm.patch
@@ -0,0 +1,60 @@
+From 9d52f886ffe556f9615f98a280d3a036a9ecf28e Mon Sep 17 00:00:00 2001
+From: Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
+Date: Sun, 5 Jul 2015 15:41:11 +0200
+Subject: More fixes to suit newish glibmm.
+
+ * gtk/src/entrycompletion.hg: Add a missing double quote in
+ _WRAP_PROPERTY("text_column, int), to avoid a warning from gmmproc 2.41.0
+ or newer.
+ * gtk/src/printunixdialog.hg: get_selected_printer(): Ref-counting correction.
+ Fix a .->, typo to make the refreturn option actually be used. Necessary
+ with gmmproc 2.29.13 or newer. Discussed in bug #657751, comment 5.
+
+diff --git a/ChangeLog b/ChangeLog
+index 1d6d4d0..c61ffa3 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,14 @@
++2015-07-05 Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
++
++ More fixes to suit newish glibmm.
++
++ * gtk/src/entrycompletion.hg: Add a missing double quote in
++ _WRAP_PROPERTY("text_column, int), to avoid a warning from gmmproc 2.41.0
++ or newer.
++ * gtk/src/printunixdialog.hg: get_selected_printer(): Ref-counting correction.
++ Fix a .->, typo to make the refreturn option actually be used. Necessary
++ with gmmproc 2.29.13 or newer. Discussed in bug #657751, comment 5.
++
+ 2015-07-02 Kjell Ahlstedt <kjell.ahlstedt@bredband.net>
+
+ Add #includes needed with glibmm newer than 2.31.0.
+diff --git a/gtk/src/entrycompletion.hg b/gtk/src/entrycompletion.hg
+index 3a32e4f..70c5cc7 100644
+--- a/gtk/src/entrycompletion.hg
++++ b/gtk/src/entrycompletion.hg
+@@ -218,7 +218,7 @@ dnl
+
+ _WRAP_PROPERTY("model", Glib::RefPtr<Gtk::TreeModel>)
+ _WRAP_PROPERTY("minimum_key_length", int)
+- _WRAP_PROPERTY("text_column, int)
++ _WRAP_PROPERTY("text_column", int)
+ _WRAP_PROPERTY("inline_completion", bool)
+ _WRAP_PROPERTY("popup_completion", bool)
+ _WRAP_PROPERTY("popup_set_width", bool)
+diff --git a/gtk/src/printunixdialog.hg b/gtk/src/printunixdialog.hg
+index 87de89f..c05e5c3 100644
+--- a/gtk/src/printunixdialog.hg
++++ b/gtk/src/printunixdialog.hg
+@@ -71,7 +71,7 @@ public:
+ #m4 _CONVERSION(`GtkPrinter*',`Glib::RefPtr<const Printer>',`Glib::wrap($3)')
+
+ _WRAP_METHOD(Glib::RefPtr<Printer> get_selected_printer(), gtk_print_unix_dialog_get_selected_printer, refreturn)
+- _WRAP_METHOD(Glib::RefPtr<const Printer> get_selected_printer() const, gtk_print_unix_dialog_get_selected_printer, refreturn. constversion)
++ _WRAP_METHOD(Glib::RefPtr<const Printer> get_selected_printer() const, gtk_print_unix_dialog_get_selected_printer, refreturn, constversion)
+
+ void add_custom_tab(const Widget& child, const Glib::ustring& tab_label);
+ _WRAP_METHOD(void add_custom_tab(const Widget& child, const Widget& tab_label), gtk_print_unix_dialog_add_custom_tab)
+--
+cgit v0.10.2
+
diff --git a/dev-cpp/gtkmm/files/gtkmm-2.24.4-papersize.patch b/dev-cpp/gtkmm/files/gtkmm-2.24.4-papersize.patch
new file mode 100644
index 000000000000..fb4d2b7dddd2
--- /dev/null
+++ b/dev-cpp/gtkmm/files/gtkmm-2.24.4-papersize.patch
@@ -0,0 +1,45 @@
+From 4fb3efa910a46364fa8ec4d60fcce557200e4dcb Mon Sep 17 00:00:00 2001
+From: Murray Cumming <murrayc@murrayc.com>
+Date: Wed, 14 Mar 2012 11:41:46 +0100
+Subject: PaperSize: Correct the PaperSizeTraits pre-declaration.
+
+* gtk/src/papersize.hg: PaperSizeTraits is a struct, not a class.
+clang++ noticed this while building Glom, though I have not run it on all of
+gtkmm.
+
+diff --git a/ChangeLog b/ChangeLog
+index ec2ce5a..73e1eac 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,4 +1,15 @@
++2012-03-14 Murray Cumming <murrayc@murrayc.com>
++
++ PaperSize: Correct the PaperSizeTraits pre-declaration.
++
++ * gtk/src/papersize.hg: PaperSizeTraits is a struct, not a class.
++ clang++ noticed this while building Glom, though I have not run it on all of
++ gtkmm.
++
+ 2.24.4:
++
++(Just regenerated with the correct glibmm version.)
++
+ 2.24.3:
+
+ 2013-04-04 Hubert Figuière <hub@figuiere.net>
+diff --git a/gtk/src/papersize.hg b/gtk/src/papersize.hg
+index 2e5700d..41fcb3c 100644
+--- a/gtk/src/papersize.hg
++++ b/gtk/src/papersize.hg
+@@ -21,7 +21,7 @@ namespace Gtk
+ {
+
+ #ifndef DOXYGEN_SHOULD_SKIP_THIS
+-class PaperSizeTraits;
++struct PaperSizeTraits;
+ #endif
+
+ /** Common paper names, from PWG 5101.1-2002 PWG: Standard for Media Standardized Names
+--
+cgit v0.10.2
+
diff --git a/dev-cpp/gtkmm/gtkmm-2.24.4-r2.ebuild b/dev-cpp/gtkmm/gtkmm-2.24.4-r2.ebuild
new file mode 100644
index 000000000000..85dd5f12f68b
--- /dev/null
+++ b/dev-cpp/gtkmm/gtkmm-2.24.4-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.24.4-r2.ebuild,v 1.1 2015/07/07 19:02:09 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for GTK+"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+COMMON_DEPEND="
+ >=dev-cpp/glibmm-2.34.1:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.28:2[${MULTILIB_USEDEP}]
+ >=dev-cpp/atkmm-2.22.7[${MULTILIB_USEDEP}]
+ >=dev-cpp/cairomm-1.10.0-r1[${MULTILIB_USEDEP}]
+ >=dev-cpp/pangomm-2.34.0:1.4[${MULTILIB_USEDEP}]
+ >=dev-libs/libsigc++-2.3.2:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtkmmlibs-20140508
+ !app-emulation/emul-linux-x86-gtkmmlibs[-abi_x86_32(-)] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? (
+ media-gfx/graphviz
+ dev-libs/libxslt
+ app-doc/doxygen )
+"
+
+src_prepare() {
+ # Apply fixes from 2.24 branch
+ epatch "${FILESDIR}"/${P}-papersize.patch
+ epatch "${FILESDIR}"/${P}-missing-includes.patch
+ epatch "${FILESDIR}"/${P}-newer-glibmm.patch
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 2 failed"
+ fi
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ --enable-api-atkmm \
+ $(multilib_native_use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog PORTING NEWS README"
+ einstalldocs
+}