summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-08 15:56:18 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-08 15:56:18 +0000
commit210a9d6bf923377dd45914ebab3ac2c3e3a6e807 (patch)
tree9cb564430f58bc596b34cea9dd82b0fc2877e2ec /dev-cpp/gtkmm/gtkmm-2.24.2.ebuild
parentRemove old, thanks to Mark Loeser for noticing. (diff)
downloadgentoo-2-210a9d6bf923377dd45914ebab3ac2c3e3a6e807.tar.gz
gentoo-2-210a9d6bf923377dd45914ebab3ac2c3e3a6e807.tar.bz2
gentoo-2-210a9d6bf923377dd45914ebab3ac2c3e3a6e807.zip
Version bump with upstream fix for bug #374353 reported by Justin Lecher and others. Remove affected version.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gtkmm/gtkmm-2.24.2.ebuild')
-rw-r--r--dev-cpp/gtkmm/gtkmm-2.24.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-cpp/gtkmm/gtkmm-2.24.2.ebuild b/dev-cpp/gtkmm/gtkmm-2.24.2.ebuild
new file mode 100644
index 000000000000..1f415ecb8b48
--- /dev/null
+++ b/dev-cpp/gtkmm/gtkmm-2.24.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtkmm/gtkmm-2.24.2.ebuild,v 1.1 2011/07/08 15:56:18 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ interface for GTK+2"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-cpp/glibmm-2.24:2
+ >=x11-libs/gtk+-2.24:2
+ >=dev-cpp/atkmm-2.22.2
+ >=dev-cpp/cairomm-1.2.2
+ >=dev-cpp/pangomm-2.27.1:1.4
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ media-gfx/graphviz
+ dev-libs/libxslt
+ app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog PORTING NEWS README"
+ G2CONF="${G2CONF}
+ --enable-api-atkmm
+ --disable-maintainer-mode
+ $(use_enable doc documentation)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 1 failed"
+ fi
+
+ if ! use examples; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 2 failed"
+ fi
+}