summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-04-30 14:36:24 +0000
committerMichał Górny <mgorny@gentoo.org>2014-04-30 14:36:24 +0000
commitd86e071adbd2545e669e560b0ead8752b614cc65 (patch)
tree21619b62c46979f4dd4468f525a704bd86a90b08 /dev-cpp/gtest
parentUnmask exiv2 after fixing. (diff)
downloadgentoo-2-d86e071adbd2545e669e560b0ead8752b614cc65.tar.gz
gentoo-2-d86e071adbd2545e669e560b0ead8752b614cc65.tar.bz2
gentoo-2-d86e071adbd2545e669e560b0ead8752b614cc65.zip
Simplify multilib code. Set proper flags for autotools-multilib.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/ChangeLog5
-rw-r--r--dev-cpp/gtest/gtest-1.7.0.ebuild30
2 files changed, 14 insertions, 21 deletions
diff --git a/dev-cpp/gtest/ChangeLog b/dev-cpp/gtest/ChangeLog
index 5d5e2df648bc..6004c03604b8 100644
--- a/dev-cpp/gtest/ChangeLog
+++ b/dev-cpp/gtest/ChangeLog
@@ -1,5 +1,8 @@
# ChangeLog for dev-cpp/gtest
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/ChangeLog,v 1.35 2013/11/06 09:57:53 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/ChangeLog,v 1.36 2014/04/30 14:36:24 mgorny Exp $
+
+ 30 Apr 2014; Michał Górny <mgorny@gentoo.org> gtest-1.7.0.ebuild:
+ Simplify multilib code. Set proper flags for autotools-multilib.
*gtest-1.7.0 (06 Nov 2013)
diff --git a/dev-cpp/gtest/gtest-1.7.0.ebuild b/dev-cpp/gtest/gtest-1.7.0.ebuild
index 874d5d188668..6cff8d0a0e46 100644
--- a/dev-cpp/gtest/gtest-1.7.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.7.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/gtest-1.7.0.ebuild,v 1.1 2013/11/06 09:57:53 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtest/gtest-1.7.0.ebuild,v 1.2 2014/04/30 14:36:24 mgorny Exp $
EAPI="5"
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -26,37 +28,25 @@ PATCHES=(
"${FILESDIR}/configure-fix-pthread-linking.patch" #371647
)
-AUTOTOOLS_AUTORECONF="1"
-
src_prepare() {
sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die
sed -i -r \
-e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
Makefile.am || die
autotools-multilib_src_prepare
-
- multilib_copy_sources
}
-src_configure() {
- multilib_parallel_foreach_abi gtest_src_configure
+multilib_src_install() {
+ default
+ multilib_is_native_abi && dobin scripts/gtest-config
}
-src_install() {
- autotools-multilib_src_install
- multilib_for_best_abi gtest-config_install
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
if use examples ; then
insinto /usr/share/doc/${PF}/examples
doins samples/*.{cc,h}
fi
}
-
-gtest_src_configure() {
- ECONF_SOURCE="${BUILD_DIR}"
- autotools-utils_src_configure
-}
-
-gtest-config_install() {
- dobin "${BUILD_DIR}/scripts/gtest-config"
-}