summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-13 00:00:11 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-13 00:00:11 +0000
commitea3f6b56e648b183b97d24786b8f6583db7a312d (patch)
treecc7602d9e2600fe1477920cd685e8aa4f48d9874 /dev-cpp/gnome-vfsmm
parentbump to 2.12.5, more gcc-4.3 fixes (diff)
downloadgentoo-2-ea3f6b56e648b183b97d24786b8f6583db7a312d.tar.gz
gentoo-2-ea3f6b56e648b183b97d24786b8f6583db7a312d.tar.bz2
gentoo-2-ea3f6b56e648b183b97d24786b8f6583db7a312d.zip
* bump to 2.22
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-cpp/gnome-vfsmm')
-rw-r--r--dev-cpp/gnome-vfsmm/ChangeLog8
-rw-r--r--dev-cpp/gnome-vfsmm/gnome-vfsmm-2.22.0.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-cpp/gnome-vfsmm/ChangeLog b/dev-cpp/gnome-vfsmm/ChangeLog
index d1b65fa49101..54ed7511e76c 100644
--- a/dev-cpp/gnome-vfsmm/ChangeLog
+++ b/dev-cpp/gnome-vfsmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/gnome-vfsmm
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.52 2008/01/03 20:33:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/ChangeLog,v 1.53 2008/03/13 00:00:11 eva Exp $
+
+*gnome-vfsmm-2.22.0 (12 Mar 2008)
+
+ 12 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-vfsmm-2.22.0.ebuild:
+ bump to 2.22.0
*gnome-vfsmm-2.20.0 (03 Jan 2008)
diff --git a/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.22.0.ebuild b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.22.0.ebuild
new file mode 100644
index 000000000000..bf3506b4b14c
--- /dev/null
+++ b/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.22.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gnome-vfsmm/gnome-vfsmm-2.22.0.ebuild,v 1.1 2008/03/13 00:00:11 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gnome-vfs"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+# glibmm dep is because build fails with older versions...
+RDEPEND=">=gnome-base/gnome-vfs-2.8.1
+ >=dev-cpp/glibmm-2.12"
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog NEWS README INSTALL"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ cd "${S}"/docs/reference
+ make all
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
+ cp -R examples "${D}"/usr/share/doc/${PF}
+ fi
+}