summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-04 17:32:40 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-04 17:32:40 +0000
commitad46fdab91129d4748b71c16b0d5d92a660f22ae (patch)
treed75ec5157936a82d9f8550370cf5e616168111a5 /dev-cpp/glog
parentDisable mount sloppy test since it violates the sandbox #453778 by Konstantin... (diff)
downloadgentoo-2-ad46fdab91129d4748b71c16b0d5d92a660f22ae.tar.gz
gentoo-2-ad46fdab91129d4748b71c16b0d5d92a660f22ae.tar.bz2
gentoo-2-ad46fdab91129d4748b71c16b0d5d92a660f22ae.zip
Version bump #467926 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-cpp/glog')
-rw-r--r--dev-cpp/glog/ChangeLog7
-rw-r--r--dev-cpp/glog/glog-0.3.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-cpp/glog/ChangeLog b/dev-cpp/glog/ChangeLog
index 6819a849e05d..e141c465b083 100644
--- a/dev-cpp/glog/ChangeLog
+++ b/dev-cpp/glog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/glog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glog/ChangeLog,v 1.9 2013/01/10 20:40:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glog/ChangeLog,v 1.10 2013/05/04 17:32:40 vapier Exp $
+
+*glog-0.3.3 (04 May 2013)
+
+ 04 May 2013; Mike Frysinger <vapier@gentoo.org> +glog-0.3.3.ebuild:
+ Version bump #467926 by Agostino Sarubbo.
10 Jan 2013; Mike Frysinger <vapier@gentoo.org> glog-0.3.2.ebuild:
Use configure flags to install doc files and fix EAPI=4 handling of $ED.
diff --git a/dev-cpp/glog/glog-0.3.3.ebuild b/dev-cpp/glog/glog-0.3.3.ebuild
new file mode 100644
index 000000000000..ec63f4fe2f34
--- /dev/null
+++ b/dev-cpp/glog/glog-0.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/glog/glog-0.3.3.ebuild,v 1.1 2013/05/04 17:32:40 vapier Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="Google's C++ logging library"
+HOMEPAGE="http://code.google.com/p/google-glog/"
+SRC_URI="http://google-glog.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="gflags static-libs unwind test"
+
+RDEPEND="gflags? ( dev-cpp/gflags )
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
+}
+
+src_configure() {
+ export ac_cv_lib_gflags_main=$(usex gflags)
+ export ac_cv_lib_unwind_backtrace=$(usex unwind)
+ use test || export ac_cv_prog_GTEST_CONFIG=no
+ econf \
+ --docdir="\${datarootdir}/doc/${PF}" \
+ --htmldir="\${datarootdir}/doc/${PF}/html" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Punt docs we don't care about (NEWS is 0 bytes).
+ rm "${ED}"/usr/share/doc/${PF}/{COPYING,NEWS,README.windows}
+
+ # --htmldir doesn't work (yet):
+ # https://code.google.com/p/google-glog/issues/detail?id=144
+ dohtml "${ED}"/usr/share/doc/${PF}/*
+ rm "${ED}"/usr/share/doc/${PF}/*.{html,css}
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}