summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2012-02-16 18:51:51 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2012-02-16 18:51:51 +0000
commit62e45bc473db925b8a834f9fcfc1dc3675ff941e (patch)
treeb30d5d652d60714ae9b1676f8b2e6712661e138e /dev-cpp/gflags
parentx86 stable wrt bug #402907 (diff)
downloadgentoo-2-62e45bc473db925b8a834f9fcfc1dc3675ff941e.tar.gz
gentoo-2-62e45bc473db925b8a834f9fcfc1dc3675ff941e.tar.bz2
gentoo-2-62e45bc473db925b8a834f9fcfc1dc3675ff941e.zip
Version bumps.
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gflags')
-rw-r--r--dev-cpp/gflags/ChangeLog11
-rw-r--r--dev-cpp/gflags/gflags-1.7.ebuild28
-rw-r--r--dev-cpp/gflags/gflags-2.0.ebuild28
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-cpp/gflags/ChangeLog b/dev-cpp/gflags/ChangeLog
index 3885e15e07fe..e475dfb07952 100644
--- a/dev-cpp/gflags/ChangeLog
+++ b/dev-cpp/gflags/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/gflags
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.14 2011/11/11 20:55:37 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.15 2012/02/16 18:51:51 nelchael Exp $
+
+*gflags-2.0 (16 Feb 2012)
+*gflags-1.7 (16 Feb 2012)
+
+ 16 Feb 2012; Krzysztof Pawlik <nelchael@gentoo.org> +gflags-1.7.ebuild,
+ +gflags-2.0.ebuild:
+ Version bumps.
11 Nov 2011; Mike Frysinger <vapier@gentoo.org> gflags-1.5.ebuild,
gflags-1.6.ebuild:
diff --git a/dev-cpp/gflags/gflags-1.7.ebuild b/dev-cpp/gflags/gflags-1.7.ebuild
new file mode 100644
index 000000000000..ec240fdc2813
--- /dev/null
+++ b/dev-cpp/gflags/gflags-1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-1.7.ebuild,v 1.1 2012/02/16 18:51:51 nelchael Exp $
+
+EAPI="3"
+
+DESCRIPTION="Google's C++ argument parsing library."
+HOMEPAGE="http://code.google.com/p/gflags/"
+SRC_URI="http://gflags.googlecode.com/files/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/*
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*
+}
diff --git a/dev-cpp/gflags/gflags-2.0.ebuild b/dev-cpp/gflags/gflags-2.0.ebuild
new file mode 100644
index 000000000000..f2910191b9ea
--- /dev/null
+++ b/dev-cpp/gflags/gflags-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-2.0.ebuild,v 1.1 2012/02/16 18:51:51 nelchael Exp $
+
+EAPI="3"
+
+DESCRIPTION="Google's C++ argument parsing library."
+HOMEPAGE="http://code.google.com/p/gflags/"
+SRC_URI="http://gflags.googlecode.com/files/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND=""
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ rm -rf "${D}"/usr/share/doc/*
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml doc/*
+}