summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2008-03-10 12:11:19 +0000
committerAlec Warner <antarus@gentoo.org>2008-03-10 12:11:19 +0000
commit075eca2aa9c55ccbf67bf8d8870dec62f46a0839 (patch)
treeebed353a909fc2f29745ccdd633e6d52639efec0 /dev-cpp/gflags
parentUpdate license to GPL-3 (diff)
downloadgentoo-2-075eca2aa9c55ccbf67bf8d8870dec62f46a0839.tar.gz
gentoo-2-075eca2aa9c55ccbf67bf8d8870dec62f46a0839.tar.bz2
gentoo-2-075eca2aa9c55ccbf67bf8d8870dec62f46a0839.zip
distutils fix from dev-zero
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-cpp/gflags')
-rw-r--r--dev-cpp/gflags/ChangeLog5
-rw-r--r--dev-cpp/gflags/gflags-0.7.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-cpp/gflags/ChangeLog b/dev-cpp/gflags/ChangeLog
index 91b34cc1b76b..0d132ca08303 100644
--- a/dev-cpp/gflags/ChangeLog
+++ b/dev-cpp/gflags/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/gflags
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.3 2008/03/09 08:27:44 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/ChangeLog,v 1.4 2008/03/10 12:11:19 antarus Exp $
+
+ 10 Mar 2008; Alec Warner <antarus@gentoo.org> gflags-0.7.ebuild:
+ distutils fix from dev-zero
09 Mar 2008; Alec Warner <antarus@gentoo.org> gflags-0.7.ebuild:
remove mirror://, it was wrong anyway
diff --git a/dev-cpp/gflags/gflags-0.7.ebuild b/dev-cpp/gflags/gflags-0.7.ebuild
index 408f56e7365f..de30b47d2f03 100644
--- a/dev-cpp/gflags/gflags-0.7.ebuild
+++ b/dev-cpp/gflags/gflags-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-0.7.ebuild,v 1.3 2008/03/09 08:27:44 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gflags/gflags-0.7.ebuild,v 1.4 2008/03/10 12:11:19 antarus Exp $
inherit distutils
@@ -12,12 +12,17 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="python"
-DEPEND=""
+DEPEND="python? ( dev-lang/python )"
RDEPEND="${DEPEND}"
src_compile() {
econf || die "econf failed"
emake || die "emake failed"
+ if use python;
+ then
+ cd python
+ distutils_src_compile
+ fi
}
src_install() {