summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2011-05-23 14:31:27 +0000
committerIlya Volynets <iluxa@gentoo.org>2011-05-23 14:31:27 +0000
commit959ef8e6a6e7656e52a203b12958bc91d3600ab5 (patch)
tree36d00cccc837c8d635e102b95c1ee5c6020d4dd0 /dev-cpp/cppserv/files
parentnew version uding new bootstrap. Should fix #327043 (diff)
downloadgentoo-2-959ef8e6a6e7656e52a203b12958bc91d3600ab5.tar.gz
gentoo-2-959ef8e6a6e7656e52a203b12958bc91d3600ab5.tar.bz2
gentoo-2-959ef8e6a6e7656e52a203b12958bc91d3600ab5.zip
Verbump cppserv to 0.2.14
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/cppserv/files')
-rw-r--r--dev-cpp/cppserv/files/cppserv-0.2.14-asneeded.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-cpp/cppserv/files/cppserv-0.2.14-asneeded.patch b/dev-cpp/cppserv/files/cppserv-0.2.14-asneeded.patch
new file mode 100644
index 000000000000..e559ee7f53f8
--- /dev/null
+++ b/dev-cpp/cppserv/files/cppserv-0.2.14-asneeded.patch
@@ -0,0 +1,57 @@
+--- adon-banai/rules.mk
++++ adon-banai/rules.mk
+@@ -253,7 +253,7 @@
+ $(Q)touch $$@
+ $(ADON_BUILD)/$(1)/$(2).so: $(ADON_BUILD)/$(2)-dep $(3)
+ $(LINK) $$(filter-out $(ADON_BUILD)/$(2)-dep,$$^) $$(SHLIB_FLAGS) $$(ADON_LIBFLAGS) \
+- $($(2)_SHLIB_FLAGS) $($(2)_LDFLAGS) $(LOCAL_LDADD) -Wl,-soname,$(2).so -shared -o $$@
++ $($(2)_SHLIB_FLAGS) $($(2)_LDFLAGS) $(LOCAL_LDADD) -Wl,-soname,$(2).so -shared -o $$@ $($(2)_LIBADD)
+ endef
+
+ #FIXME: -fPIC is bit non-portable
+@@ -300,7 +300,8 @@
+ $(ADON_BUILD)/$(1)/$(2): $(ADON_BUILD)/$(2)-dep $(3)
+ $(LINK) $$(filter-out $(ADON_BUILD)/$(2)-dep,$$^) $$(TARGET_LDFLAGS) \
+ $$(TOP_LDFLAGS) $$(ADON_LIBFLAGS) \
+- $(LOCAL_LDFLAGS) $($(2)_LDFLAGS) $$(LDFLAGS) -o $$@
++ $(LOCAL_LDFLAGS) $($(2)_LDFLAGS) $$(LDFLAGS) -o $$@ \
++ $($(2)_LDADD)
+ endef
+
+ # curdir, progname, instvar
+--- src/cxxsp/parser/Makefile.adon
++++ src/cxxsp/parser/Makefile.adon
+@@ -28,7 +28,7 @@
+ csplex.lpp
+
+ cxxsp_compile_SOURCES:= cxxsp_compile.cpp
+-cxxsp_compile_LDFLAGS:= -lutil -lcxxsp_parser -ldl -lservlet -lcxxtaglib
++cxxsp_compile_LDADD:= -lutil -lcxxsp_parser -lservlet -lcxxtaglib -ldl
+ cxxsp_compile_DEPS:=libcxxtaglib cxxsp_runtime_taglib
+
+ noinst_HEADERS:= \
+--- src/cxxsp/taglib/Makefile.adon
++++ src/cxxsp/taglib/Makefile.adon
+@@ -21,6 +21,6 @@
+ lib_LTLIBRARIES:=libcxxtaglib cxxsp_runtime_taglib
+ libcxxtaglib_SOURCES:=Taglib.cpp CompileTimeTaglib.cpp
+ cxxsp_runtime_taglib_SOURCES:=RunTimeTaglib.cpp
+-cxxsp_runtime_taglib_LDFLAGS:=-lcxxtaglib
++cxxsp_runtime_taglib_LDADD:=-lcxxtaglib
+ cxxsp_runtime_taglib_DEPS:=libcxxtaglib
+ noinst_HEADERS:=RunTimeTaglib.h
+--- src/container/Makefile.adon
++++ src/container/Makefile.adon
+@@ -37,10 +37,10 @@
+ connection.cpp \
+ requesthandler.cpp \
+ requestlistener.cpp
+-cppserv_LDFLAGS := -lservlet -lsputil4 -lsocket++ -lpthread -ldl -lserverconfig -rdynamic
++cppserv_LDADD := -lservlet -lsputil4 -lsocket++ -lpthread -lserverconfig -ldl -rdynamic
+ cppserv_CPPFLAGS := -I$(ADON_SRC)/include/container
+ cppserv_DEPS:= libservlet libserverconfig
+
+ ifeq ($(HAVE_LIBMAGIC),1)
+-cppserv_LDFLAGS+=-lmagic
++cppserv_LDADD+=-lmagic
+ endif